Jump to content
Sign in to follow this  
Nightwalker_z

ISDN Internet Einwahl Cisco 1003

Recommended Posts

Hallo,

ich habe mir vor ner Woche nen Cisco 1003 ISDN Router zugelegt. Jetzt werder ihr natürlich wieder denken:

"schon wieder einer, der so nen Schrott von eBay ersteigert hat."

Ich denk, dass die Teile schon gut sind und was taugen.

Leider schaff ich es nicht mich richtig ins Internet zu connecten. Ich will eine Verbindung zu Arcor aufbauen. Ich hab die aktuelle IOS Version drauf (12.1(24)) - also funktioniert das Natten schon mal. Mein Router hat 8MB Ram und ne 4MB Flashkarte.

In der Netzwerkumgebung von Windows ist der Router als Default Gateway eingetragen - also passt das schonmal.

Wenn ich vom Dosfenster nen Ping absetzen will, kommt keinerlei Reaktion vom Router (er wählt sich nicht ein) - von der IOS Kommandokonsole wählt er sich ein und kriegt sogar nen Ping hin - aber NUR wenn ich ne IP Adresse übergebe. Aus irgendeinem Grund

kriegt der Router es auch nicht gebacken nen Namen richtig aufzulösen.

 

Beispiel:

-------------------------------------------------------------------------------------

NW_ISDN_01#ping 198.133.219.25

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 198.133.219.25, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 204/207/208 ms

 

NW_ISDN_01#ping http://www.heise.de

Translating "www.heise.de"...domain server (255.255.255.255)

% Unrecognized host or address, or protocol not running.

-------------------------------------------------------------------------------------

 

Eigentlich sollte doch der DNS Server durch die Aushandlung mit dem Provider eingetragen sein.... anstattdessen macht er diesen 255.255.255.255 Quatsch.

 

Hier ist mal meine Konfig - vielleich fällt euch etwas auf

 

-------------------------------------------------------------------------------------

 

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname NW_ISDN_01

!

enable password xxxxxxxxxxx

!

ip subnet-zero

!

isdn switch-type basic-net3

!

interface Ethernet0

ip address 192.168.0.254 255.255.255.0

ip nat inside

no cdp enable

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

no cdp enable

ppp authentication chap pap callin

!

interface Dialer1

description Arcor Internet

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer remote-name ISP

dialer idle-timeout 180

dialer string 0192076

dialer-group 1

no cdp enable

ppp authentication chap pap callin

ppp chap hostname arcor

ppp chap password 7 151B0518013825213C73756253

ppp pap sent-username arcor password 7 110017111200050910

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

dialer-list 1 protocol ip permit

no cdp run

!

line con 0

password xxxxxxxxx

login

line vty 0 4

password xxxxxxxxx

login

!

end

 

 

--------------------------------------------------------------------------------

Wäre über ein paar Antworten froh...

Viele Grüße

Nightwalker_z

 

 

 

 

 

 

Und jetzt kommt die Konfig

Share this post


Link to post

Hi Nightwalker_z, willkommen on Board. :)

 

Sind das hier noch gültige Passworteinträge? Wenn ja, bitte unkenntlich machen.

ppp chap password 7 151B0518013825213C73756253

ppp pap sent-username arcor password 7 110017111200050910

 

Damian

Share this post


Link to post
Original geschrieben von Damian

Hi Nightwalker_z, willkommen on Board. :)

 

Sind das hier noch gültige Passworteinträge? Wenn ja, bitte unkenntlich machen.

 

Nachdem Du Ihn in den fraglichen Zeilen ja gequotet hast ist eine Änderung des Ursprungspostings nicht wirklich sinnvoll.

 

@Nightwalker_z

 

Kannst Du vom PC aus den Router anpingen?

 

Gruss

Markus

Share this post


Link to post

Huups ... sorry - stimmt... ich hab die "Info - Posten von Konfigurationen" schon gelesen... aber natürlich habe ich nur meine Kennwörter unkenntlich gemacht und nicht die vom Provider.

:D

 

Danke für den Hinweis.....

 

Und nun ein Aufruf an alle, die versuchen das Passwort zu knacken:

Geht auf http://www.arcor.de - da sind die Kennwörter bereits als Klartext abgelegt ;)

 

 

-------------------------------------------------------------------------------------

Ja... ich erreiche die ETH0 Adresse schon von meinem PC aus

 

interface Ethernet0

ip address 192.168.0.254 255.255.255.0

 

Hab auch mal spasseshalber auf der Router ein Loopback Interface eingerichtet ... (ne Class A 10er Addy) - die erreiche ich auch von meiner Workstation --> Der Router routet schon was...

 

 

Greetz

Nightwalker_z

Share this post


Link to post

Hallo

 

Trag mal folgendesw ein

 

access-list 1 permit 192.168.0.0 0.0.0.255

ip nat inside source list 1 interface dialer1 overload

 

 

Beim Client bitte den DNS eintragen.

 

Bitte poste obs funktioniert hat

Share this post


Link to post

access-list 1 permit 192.168.0.0 0.0.0.255

ip nat inside source list 1 interface dialer1 overload

Danke für die Antwort.

Der erste Befehl ist mir klar, aber was ist mit dem 2ten...

in meinem int eth0 hab ich doch schon ein nat inside

 

------------------------------------------------------------------------------------

Also ... ich hab mich mal über meine ISDN Karte über ne DFÜ Verbindung bei Arcor eingewählt und hab mit ipconfig /all den DNS Server herausbekommen.

Auf dem Router hab ich die zwei Adressen über den ip name-server Befehl aufgenommen.

Funktioniert einwandfrei:

NW_ISDN_01#ping [url]www.golem.de[/url]

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 217.110.105.181, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/68/72 ms

 

Auf meiner Windows Kommandozeile:

 

C:\>ping 217.110.105.181

Ping wird ausgeführt für 217.110.105.181 mit 32 Bytes Daten:

Antwort von 217.110.105.181: Bytes=32 Zeit=63ms TTL=244
Antwort von 217.110.105.181: Bytes=32 Zeit=47ms TTL=244
Antwort von 217.110.105.181: Bytes=32 Zeit=47ms TTL=244
Antwort von 217.110.105.181: Bytes=32 Zeit=47ms TTL=244

Ping-Statistik für 217.110.105.181:
   Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0 (0% Verlust),
Ca. Zeitangaben in Millisek.:
   Minimum = 47ms, Maximum =  63ms, Mittelwert =  51ms

 

Passt alles

ABER ... wenn ich auf meiner Windows Kommandozeile folgendes

eingebe: ping http://www.golem.de

kommt die Fehlermeldung, dass der Host unbekannt ist. Irgendwie werden die Namen nicht aufgelöst.

Auf meiner Windows Kiste habe ich unter den Netzwerkeinstellungen aber den Router als Default Gateway und als DNS Server angegeben ... das dürfte doch dann so klappen.

 

Grüsse

Nightwalker_z

Share this post


Link to post

Entweder du gibst auf den Windows Kisten als DNS-Server direkt den DNS des Providers an oder du packst folgende Zeile in deine Routerconfig:

 

ip dns server`

 

Damit du am Router auch eine Auflösung des Namens bekommst, füge folgende Zeile hinzu:

 

ip name-server A.B.C.D ( IP des DNS Server des ISP)

Share this post


Link to post

Das hab ich ja schon ... siehe ein bisschen weiter oben

Vom IOS aus werden mir auch die Namen aufgelöst - aber von meiner Windows Kiste nicht. Jetzt hab ich halt in der Netzwerkumgebung die DNS Server manuell eingetragen aber es muss doch auch anders gehen....

 

Jetzt noch was zum Thema interesting traffic:

 

access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq www
access-list 101 permit udp 192.168.0.0 0.0.0.255 any eq domain
access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq smtp
access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq pop3
dialer-list 1 protocol ip list 101

 

Das hab ich an meinem Router eingetragen und das funktioniert auch klasse. Das Problem ist, dass sich der Timer nicht mehr auf seinen maximalen Wert setzt. Eigentlich sollte es ja so sein:

Ich mach meinen Browser auf - das Teil wählt sich ein. Der Timer geht runter bis ich nen weiteren HTTP Request mache - dann setzt er sich wieder auf seinen Maximalwert...

Hier nochmal die Konfig:

 

Building configuration...
Current configuration : 1651 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname NW_ISDN_01
!
enable password xxxxxxxxxxxxxxxxxxxxx
!
username xxxxxx password xxxxxxxxxxxxxxxxxxxx
!
!
ip subnet-zero
no ip domain-lookup
ip name-server 145.253.2.81
ip name-server 145.253.2.203
!
isdn switch-type basic-net3
!
interface Ethernet0
ip address 192.168.0.254 255.255.255.0
ip nat inside
no cdp enable
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap pap callin
!
interface Dialer1
description Arcor Internet
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer remote-name ISP
dialer idle-timeout 60
dialer string 07567999999
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname arcor
ppp chap password xxxxxxxxxxxx
ppp pap sent-username arcor password xxxxxxxxxxx
!
ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq www
access-list 101 permit udp 192.168.0.0 0.0.0.255 any eq domain
access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq smtp
access-list 101 permit tcp 192.168.0.0 0.0.0.255 any eq pop3
dialer-list 1 protocol ip list 101
no cdp run
!
line con 0
password xxxxxxxxxx
login
line vty 0 4
password xxxxxxxxxxx
login
!
end

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...