Jump to content

Probleme mit Weiterleitung von Lan nach Wan


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo allerseits...

 

Tut mir leid, wenn ich hier mit einem Thema komme, was bestimmt schon x-tausend mal gebracht wurde, aber gerade für mein Problem habe ich nichts gefunden.

 

Ich bin absoluter Anfänger und habe keine Ahnung, wie man unter Win2000 Routing&Ras konfiguriert bzw. DNS so, weil ich das bisher noch nie brauchte. Gelesen hab ich zwar schon genügend drüber, aber Praxis und Theorie sind 2 verschiedene Dinge.

 

Folgendes Problem:

Ich habe einen PDC (W2k) mit Exchange Server.

Auf diesem läuft ein Terminalserver - das wars soweit.

Angeschlossen sind 5 Clients.

 

Der PDC geht per DSL-Router ins Internet.

 

Das lokale Netzwerk ist durchnummeriert (die Clients von 192.168.115.2 - 6), der Server hat die 192.168.115.10, der DSL-Router die 192.168.115.1

 

Vom Server aus über den Router bekomme ich die Verbiundung ins Internet (als Standartgateway den Router und als DNS-Server die T-Online-DNS-Server).

 

Die Clients haben als Gateway den Server (192.168.115.10) und auch als DNS-Server.

Die Verbindung zwischen Clients und Server geht super, die Clients gehen aber nicht ins Internet.

 

Was genau muss ich wie machen, damit ich auf dem Server den internen Netzwerkverkehr nach aussen routen kann?

 

Ich hab hier ne kleine Anleitung in den Threads gefunden, aber die hilft nicht viel weiter, die ist so kurz gehalten, das ich damit nichts anfangen kann.

 

Gateway f. default Route auf W2K Server = IP Adresse des Routers - damit ist wohl der Stabndart Gateway gemeint (IP des Routers eintragen). Das ist erledigt.

Gateway auf den Clients - Lan IP des Servers - erledigt.

DNS aus Clients = W2K Server - erledigt

Route auf W2K Server due Trafic fürs Internet an Router weiterleitet ---> dies fehlt mir. Wie geht das denn genau, hat jemand ne Schritt-für-Schritt-Anleitung?

Mir geht es dabei mehr um die Bedienung von W2k als um Grundlagenkenntnisse für DNS / Routing und Ras.

DNS-Forwarder (DNS des Providers) in W2K-Server eintragen - wo genau trage ich das wie ein?

 

Der Router ist ein LinkPro 4Port m. Firewall.

 

Für eure Hilfe wäre ich echt sehr dankbar.

 

 

 

Ciao,

Rüdiger

 

 

Windows 2000-IP-Konfiguration

 

Hostname. . . . . . . . . . . . . : server

Primäres DNS-Suffix . . . . . . . : domain.local

Knotentyp . . . . . . . . . . . . : Broadcastadapter

IP-Routing aktiviert. . . . . . . : Ja

WINS-Proxy aktiviert. . . . . . . : Nein

DNS-Suffixsuchliste . . . . . . . : domain.local

 

Ethernetadapter "3Com EtherLink Server 10-100 Mbps PCI NIC with 3XP":

 

Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : 3Com EtherLink Server 10/100 Mbps PC

I NIC with 3XP Processor (3CR990SVR97)

Physikalische Adresse . . . . . . : 00-0A-5E-1C-73-68

DHCP-aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.115.10

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

Standardgateway . . . . . . . . . : 192.168.115.1

DNS-Server. . . . . . . . . . . . : 194.25.2.129

212.185.252.136

Primärer WINS-Server. . . . . . . : 192.168.115.1

Link to comment

Also, fangen wir am Server an:

Der Server sollte sich selber in den IP-Eigenschaften als DNS-Server eingetragen haben, er ist ein W2k-DC, der braucht die interne DNS-Namensauflösung.

Danach gehst du unter Start/Verwaltung/DNS in die DNS-Konsole, schaust unter Forward-Lookupzonen. Ist dort die RootZone drin, die mit dem Punkt "."? Wenn ja, dann löschen und den Server neu booten. Wenn nein, dann ist es o.k.

 

Jetzt die Clients:

Die Clients haben als DNS Server den 2000-Server eingetragen (192.168.115.10), das ist auch ok. Aber als Gatewayeintrag sollten sie den Router bekommen (192.168.115.1)

 

Das war eigentlich alles. Jetzt sollte es gehen.

 

P.S: Du hast einen WINS-Server eingetragen, ist auch einer auf dem Server installiert?

 

grizzly999

Link to comment

Hallo grizzly,

 

herzlichen Dank für Deine Hilfe.

 

Auf dem Server ist nur eine Netzwerkkarte installiert, ja. Ich könnte auch eine zweite einbauen (bzw. auf dem Serverboard ist noch ne GBit-Lan drauf), aber wozu? Um internes und externes Netz strikt zu trennen? Oder geht es auch so und einacher?

 

Die Forward-Lookup-Zone mit dem Punkt hatte ich bereits gelöscht, ich hab ja vorher hier schon einiges gelesen :-)

 

Wenn ich auf den Clients die IP des Routers eintrage, bekommen die Clients Probleme - sie finden nämlich den Exchange Server nicht mehr, welcher auch noch auf dem Server mitläuft.

Muss ich vielleicht auf dem Router noch einige Routen eintragen oder hab ich etwas vergessen zu konfigurieren, damit dies geht?

 

Ich habe sowieso beim einrichten der servergesteuerten Benutzerprofile und Laufwerke feststellen müssen, das nicht alles so läuft, wie es sollte. Bei einem User findet er ein Nutzerprofil unter \\server.domain.local\c\... , beim nächsten findet er es genau mit der Adressierung nicht, da muss das dann \\server\c\... heissen.

 

Ein WinS Server ist nicht installiert. Wäre dies von Vorteil? Ich habe einfach mit meinem gefährlichen Halbwissen mal einige Konfigurationen ausgetestet, so unter anderem auch mal ein IP-Tunneling eingerichtet (mir fehlt einfach das nötige Wissen, um genau zu sagen: Das brauch ich dafür, das ist in der Situation besser etc.).

 

Ciao und schönen Abend noch

Rüdiger

Link to comment

Hallo Rüdiger,

 

also um RRAS (routing und RRAS) laufen zu lassen, benötigst du zwei Netzwerkkarten im Server. Eine Für LAN und eine für WAN.

Der Server schirmt dann den lokalen Verkehr, vom Internetverkehr.

Um einen "gewissen" Grad an Sicherheit zu bekommen, würde ich mir gedanken über NAT auf dem Server machen (sofern dein Router diese funktion nicht schon erledigt.

Dein Problem mit Exchange im Bezug auf die Konfiguration die Grizzly vorschlug, solltest du nochmal genauer posten. Vielleicht ist es auch nur ein DNS Problem (z.B. mit der Reverse Lookupzone). Welche Version von Exchange nutzt du denn? Und wie sieht es mit NetBios aus, hast du da vielleicht irgendetwas aktiviert, das durch nen zusätzlichen WINS Server beheben liese?

 

Ach wieder so viele Fragen...

 

Aber um so mehr hier steht umso besser kann dir geholfen werden...

Link to comment
Original geschrieben von Ruediger010

Windows 2000-IP-Konfiguration

 

Hostname. . . . . . . . . . . . . : server

Primäres DNS-Suffix . . . . . . . : domain.local

Knotentyp . . . . . . . . . . . . : Broadcastadapter

IP-Routing aktiviert. . . . . . . : Ja

WINS-Proxy aktiviert. . . . . . . : Nein

DNS-Suffixsuchliste . . . . . . . : domain.local

 

Ethernetadapter "3Com EtherLink Server 10-100 Mbps PCI NIC with 3XP":

 

Verbindungsspezifisches DNS-Suffix:

Beschreibung. . . . . . . . . . . : 3Com EtherLink Server 10/100 Mbps PC

I NIC with 3XP Processor (3CR990SVR97)

Physikalische Adresse . . . . . . : 00-0A-5E-1C-73-68

DHCP-aktiviert. . . . . . . . . . : Nein

IP-Adresse. . . . . . . . . . . . : 192.168.115.10

Subnetzmaske. . . . . . . . . . . : 255.255.255.0

Standardgateway . . . . . . . . . : 192.168.115.1

DNS-Server. . . . . . . . . . . . : 194.25.2.129

212.185.252.136

Primärer WINS-Server. . . . . . . : 192.168.115.1

 

Hallo Rüdiger,

in der DNS-Konfiguration liegt der Hund begraben: Active Directory benötigt als Voraussetzung einen funktionierenden DNS-Server in der Microsoft-Version (DDNS), der die sogenannten SRV-Einträge für bestimmte Netzwerkdienste der Domäne bereitstellt. Damit diese Einträge überhaupt erstellt werden, muss sich Dein Server sich erst mal "bei sich selbst" registrieren.

 

Folgendes ist zu tun:

 

1) Trage in der IP-Konfiguration auf dem DC als DNS-Server nur die eigene IP 192.168.115.10 ein, also nicht die DNS-Server des Providers (194.25.2.192 und 121.185.252.136).

dann gibst Du an der Eingabeaufforderung ein:

 

ipconfig /registerdns

 

Ein Serverneustart bewirkt in diesem Fall natürlich das gleiche.

 

2) Trage auf dem DC in der DNS-Konfiguration unter "Weiterleitung" die beiden DNS-Server Deines Providers (194.25.2.192 und 121.185.252.136) als "Forwarder" in die Liste ein. Wenn Du Die root-Zone (.) in der DNS-Standardkonfiguration bereits gelöscht hast, sollten die entsprechenden Einträge unter diesem Registerreiter möglich sein. Sonst erscheint das Ganze grau, und man kann nichts eintragen. Wenn alles eingetragen ist, solltest Du den DNS-Server mal neu starten (Rechtsklick auf den Servernamen in der DNS-Konfiguration...)

 

3) Du musst sicherstellen, dass alle Clients als DNS-Server nur die IP des lokalen DC eingetragen haben, das geht entweder per DHCP oder eben händisch. Dann solltest Du noch sicherstellen, dass die Clients auch selbst ein Domänensuffix (domain.local) besitzen, das geht auch per DHCP oder händisch in den Eigenschaften der Arbeitsumgebung.

 

Wenn alle Clients dann mal neu gestartet wurden oder eben auf jedem client nach dem korrekten DNS-Eintrag lokal mal ipconfig /registerdns ausgeführt wurde, erfolgt die DNS-Auflösung nur noch über den DC: Der löst jetzt DNS-Abfragen für die lokale Zone selbst auf (weil er sich jetzt auch selbst fragen darf...) und leitet die Anfragen, die er selbst nicht auflösen kann an die DNS-Server des Providers im Internet weiter. Die Antworten gibt er an den Client zurück und speichert sie in seinem DNS-Cache zwischen.

 

Jetzt sollte alles korrekt funktionieren.

 

Gruß, JoeSan

Link to comment

Hallo JeoSan,

 

genau dies hab ich schon wie von dir beschrieben getestet. Macht er aber leider nicht.

Der Hund liegt darin begraben, das der DSL-Router gleichzeitig Netzwerk-Switch ist und alle Computer direkt am DSL-Router hängen. Ich weiss nicht, wieso er es nicht macht - aber es geht irgendwie nicht.

 

Ich habe mittlerweile folgendes gemacht:

DSL-Router abgeklemmt.

2. (onboard)-Netzwerkkarte mit dem DSL-Modem verbunden und als DSL-Verbindung per DFÜ-Netzwerk eingerichtet.

 

Leider geht jetzt gar nichts mehr.

Der Server kann keine Verbindung mit der Domäne domain.local herstellen, wieso auch immer - keine Ahnung.

 

Ciao,

Rüdiger

 

 

Original geschrieben von JoeSan

Hallo Rüdiger,

in der DNS-Konfiguration liegt der Hund begraben: Active Directory benötigt als Voraussetzung einen funktionierenden DNS-Server in der Microsoft-Version (DDNS), der die sogenannten SRV-Einträge für bestimmte Netzwerkdienste der Domäne bereitstellt. Damit diese Einträge überhaupt erstellt werden, muss sich Dein Server sich erst mal "bei sich selbst" registrieren.

 

Folgendes ist zu tun:

 

1) Trage in der IP-Konfiguration auf dem DC als DNS-Server nur die eigene IP 192.168.115.10 ein, also nicht die DNS-Server des Providers (194.25.2.192 und 121.185.252.136).

dann gibst Du an der Eingabeaufforderung ein:

 

ipconfig /registerdns

 

Ein Serverneustart bewirkt in diesem Fall natürlich das gleiche.

 

2) Trage auf dem DC in der DNS-Konfiguration unter "Weiterleitung" die beiden DNS-Server Deines Providers (194.25.2.192 und 121.185.252.136) als "Forwarder" in die Liste ein. Wenn Du Die root-Zone (.) in der DNS-Standardkonfiguration bereits gelöscht hast, sollten die entsprechenden Einträge unter diesem Registerreiter möglich sein. Sonst erscheint das Ganze grau, und man kann nichts eintragen. Wenn alles eingetragen ist, solltest Du den DNS-Server mal neu starten (Rechtsklick auf den Servernamen in der DNS-Konfiguration...)

 

3) Du musst sicherstellen, dass alle Clients als DNS-Server nur die IP des lokalen DC eingetragen haben, das geht entweder per DHCP oder eben händisch. Dann solltest Du noch sicherstellen, dass die Clients auch selbst ein Domänensuffix (domain.local) besitzen, das geht auch per DHCP oder händisch in den Eigenschaften der Arbeitsumgebung.

 

Wenn alle Clients dann mal neu gestartet wurden oder eben auf jedem client nach dem korrekten DNS-Eintrag lokal mal ipconfig /registerdns ausgeführt wurde, erfolgt die DNS-Auflösung nur noch über den DC: Der löst jetzt DNS-Abfragen für die lokale Zone selbst auf (weil er sich jetzt auch selbst fragen darf...) und leitet die Anfragen, die er selbst nicht auflösen kann an die DNS-Server des Providers im Internet weiter. Die Antworten gibt er an den Client zurück und speichert sie in seinem DNS-Cache zwischen.

 

Jetzt sollte alles korrekt funktionieren.

 

Gruß, JoeSan

Link to comment

Mittlerweile geht alles - fast.

2 Netzwerkkarten. Eine fürd lokale Netz (115.10), eine für die Wan-Verbindung (192.168.1.2 ->>> DSL-Router: 192.168.1.1).

RRas konfiguriert mit Nat ->>> Verbindung zwischen beiden Netzwerken geht. Alle clients kommen auf den exchange Server und ins Internet.

 

Aber: Nächstes Problem:

Terminalserver. Externe Leute kommen nicht mehr auf den Terminalserver.

Hab schon alles mögliche versucht.

Hat jemand einen Tip?

 

Ciao,

Rüdiger

 

 

Original geschrieben von lupo45

Versuch mal mit dem tracert-Befehl eine Routenverfolgung zu machen, dann siehst du, an welcher Stelle sein Routing klemmt...

Link to comment
Original geschrieben von Ruediger010

Mittlerweile geht alles - fast.

2 Netzwerkkarten. Eine fürd lokale Netz (115.10), eine für die Wan-Verbindung (192.168.1.2 ->>> DSL-Router: 192.168.1.1).

RRas konfiguriert mit Nat ->>> Verbindung zwischen beiden Netzwerken geht. Alle clients kommen auf den exchange Server und ins Internet.

 

Aber: Nächstes Problem:

Terminalserver. Externe Leute kommen nicht mehr auf den Terminalserver.

Hab schon alles mögliche versucht.

Hat jemand einen Tip?

 

Ciao,

Rüdiger

 

Hm, neue Situation, wenn ich das richtig verstanden habe:

Der DSL-Router ist jetzt in dem neuen Subnetz 192.168.1.0/24 und also nicht mehr direkt mit dem internen Netz verbunden. Der Server muss also routen. Der DSL-Router braucht eine statische Route in Dein internes Netz mit der IP der externen Schnittstelle des Servers als Gateway, also 192.168.115.0 Mask 255.255.255.0 Gateway 192.168.1.2.

 

Was meinst Du mit "externen Leuten"? Sollen die von außen über VPN auf den Terminalserver (Der gleichzeitig dein DC ist, zugreifen? Übers Internet? Dann bräuchtest Du eine öffentliche IP von Deinem Provider, mit dem Du NAT-Betreiben kannst. Dieses NAT muss auf dem DSL-Router konfiguriert werden. Außerdem ist das mit oder ohne Firewall und DMZ gefährlich..., so ein DC mit Exchange Server und aktiviertem Terminalserver hat ziemlich viele Ports offen...

 

Gruß, JoeSan

Link to comment

Hi JoeSan,

 

danke für Deine Tips.

Was die "externen" Leute betrifft: Die sollen entweder über VPN, oder - vorzugsweise - über Terminalclient auf den Server zugreifen (per Internet).

 

Feste IP hab ich keine, ich hab n festen Host bei dyndns, IP-Aktualisierung wird vom Router unterstützt.

 

Ich versuche deine Tipps mal, herzlichen Dank.

 

Ciao,

Rüdiger

 

PS: Router ist für den Remotezugriff freigegeben, nur hab ich das Problem, das ich da nicht draufkomme, um ihn von extern zu konfigurieren.

 

 

Original geschrieben von JoeSan

Hm, neue Situation, wenn ich das richtig verstanden habe:

Der DSL-Router ist jetzt in dem neuen Subnetz 192.168.1.0/24 und also nicht mehr direkt mit dem internen Netz verbunden. Der Server muss also routen. Der DSL-Router braucht eine statische Route in Dein internes Netz mit der IP der externen Schnittstelle des Servers als Gateway, also 192.168.115.0 Mask 255.255.255.0 Gateway 192.168.1.2.

 

Was meinst Du mit "externen Leuten"? Sollen die von außen über VPN auf den Terminalserver (Der gleichzeitig dein DC ist, zugreifen? Übers Internet? Dann bräuchtest Du eine öffentliche IP von Deinem Provider, mit dem Du NAT-Betreiben kannst. Dieses NAT muss auf dem DSL-Router konfiguriert werden. Außerdem ist das mit oder ohne Firewall und DMZ gefährlich..., so ein DC mit Exchange Server und aktiviertem Terminalserver hat ziemlich viele Ports offen...

 

Gruß, JoeSan

Link to comment

Hi...

 

Funktioniert so leider nicht.

Hab genau das wie unten angegeben eingegeben.

Terminalserver reagiert nicht.

 

Ich hoffe nicht, das ich am Server noch Rip konfigurieren muss.

Damit mir in Zukuft aber nicht mehr solche Probleme passieren, hab ich mir endlich mal ein paar schöne Bücher bestellt. Mal sehen, wann die kommen, da kann ich dann richtig lernen .-)

 

Ciao,

Rüdiger

 

 

Original geschrieben von JoeSan

Hm, neue Situation, wenn ich das richtig verstanden habe:

Der DSL-Router ist jetzt in dem neuen Subnetz 192.168.1.0/24 und also nicht mehr direkt mit dem internen Netz verbunden. Der Server muss also routen. Der DSL-Router braucht eine statische Route in Dein internes Netz mit der IP der externen Schnittstelle des Servers als Gateway, also 192.168.115.0 Mask 255.255.255.0 Gateway 192.168.1.2.

 

Was meinst Du mit "externen Leuten"? Sollen die von außen über VPN auf den Terminalserver (Der gleichzeitig dein DC ist, zugreifen? Übers Internet? Dann bräuchtest Du eine öffentliche IP von Deinem Provider, mit dem Du NAT-Betreiben kannst. Dieses NAT muss auf dem DSL-Router konfiguriert werden. Außerdem ist das mit oder ohne Firewall und DMZ gefährlich..., so ein DC mit Exchange Server und aktiviertem Terminalserver hat ziemlich viele Ports offen...

 

Gruß, JoeSan

Link to comment

Also nochmal: Der DSL-Router hat 192.168.1.1, der Server zum DSL-Router 192.168.1.2 und für das interne Netz 192.168.115.10

Die Arbeitsstationen mit 192.168.115.2 - ...4 haben Zugriff aufs Internet über den Server per NAT.

Terminalserver reagiert aber nicht.

 

Wie muss die statische Route auf dem Router denn genau aussehen? So, wie unten beschrieben, tut sich leider überhaupt nichts.

Muss Rip aktiviert werden?

Oder noch irgend ein DNS-Eintrag getätigt werden oder ähnliches?

Ich hab keine Ahnung, wäre sehr nett, wenn mir jemand n Tipp geben könnte.

Es handelt sich um einen Router LinkPro BR401F.

 

Ciao,

Rüdiger

 

 

 

 

Der DSL-Router ist jetzt in dem neuen Subnetz 192.168.1.0/24 und also nicht mehr direkt mit dem internen Netz verbunden. Der Server muss also routen. Der DSL-Router braucht eine statische Route in Dein internes Netz mit der IP der externen Schnittstelle des Servers als Gateway, also 192.168.115.0 Mask 255.255.255.0 Gateway 192.168.1.2.

Link to comment

Hallo,

 

RIP muss nicht aktiviert werden, das ist eine andere Baustelle... Kannst Du aus dem internen Netz per TS-Client auf den Server zugreifen? Ein Kollege hat seinen DynDns-Host erst nach einigem Konfigurationsaufwand ans Laufen gebracht, deshalb nochmal ein paar Fragen:

 

Kannst Du Deinen Server aus dem Internet anpingen? Mach mal einen tracert auf aus dem Internet auf deinen DynDNS-Host. Meldet er sich auf eine telnet-Anfrage (d.H ist das routing in Ordnung.

Hat der Terminalserverzugriff vor der Aktion mit den zwei Netzwerkkarten funktioniert, d.h. konntest Du per TS-Client übers Internet auf den Server in Deinem internen Netz (mit also funktionierendem Dyn-DNS) zugreifen, oder nicht? Welchen TS-Client hast Du dafür genutzt (Remotedesktopclient, TS-Client oder TS-Webaccess), Wie ist TS auf Deinem Server eingerichtet: Remoteverwaltungsmodus oder Anwendungsservermodus und wenn Anwendungsservermodus, hast Du den TS-Lizenzserver installiert und aktiviert?

 

Ich weiß, viele Fragen... aber mir fehlt leider immer noch das Verständnis für Dein Netzwerk.

 

Gruß, JoeSan

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...