Jump to content

KB5004779 - OAuth Zertifikat


Go to solution Solved by NorbertFe,

Recommended Posts

Hi zusammen,

 

eine kurze Frage in die Runde, zwecks den Erfahrungen des KB5004779 Sicherheitspatch von Juli und dem "Microsoft Exchange Server Auth Certificate".

 

Microsoft beschreibt ja den Issues unter Punkt 5, dass es sporadisch zu Fehlern in OWA und ECP nach der Installation vom Sicherheitspatch kommen kann.

 

Jetzt habe ich natürlich schon einige Server gepatcht und habe ehrlich gesagt nie den Befehl:

 

(Get-AuthConfig).CurrentCertificateThumbprint | Get-ExchangeCertificate | Format-List

 

zuvor ausgeführt und nachgesehen, was zurückgegeben wird. :smile2: (Schande über mein Haupt).

 

Hat jemand Erkenntnisse was genau passiert, wenn z.B. das Zertifikat nicht abgelaufen ist, aber der Befehl einen Fehler zurück bringt?

 

image.png.19dab9e05f0ec561673f810eb3d47a2b.png

 

Hier wird mir ein anderer Fingerabdruck als vom  "Microsoft Exchange Server Auth Certificate" ausgegeben.

 

Sollte hier im voraus ein neues Zertifikat erstellt werden und dann erst das Sicherheitsupdate eingespielt werden?

 

Wie sind hier eure Erfahrungen?

 

Danke euch :shy:

 

Grüße
Phil

 

 

 

 

 

 

Link to post
  • Solution
vor 5 Minuten schrieb Gerber:

Sollte hier im voraus ein neues Zertifikat erstellt werden und dann erst das Sicherheitsupdate eingespielt werden?

Nein, wenn das vorhandene Auth Zertifikat noch gültig ist, brauchst du bloß das Zertifikat in der auth config eintragen und fertig.

vor 6 Minuten schrieb Gerber:

Sollte hier im voraus ein neues Zertifikat erstellt werden und dann erst das Sicherheitsupdate eingespielt werden?

Wenn du ein gültiges hast und nur in der konfig ein nicht mehr vorhandenes eingetragen ist, nimm einfach das vorhandene in die konfig.

  • Like 1
Link to post

Hey NorbertFe,

 

danke dir.

 

Dann werde ich das vorhandene nutzen und über :

 

Set-AuthConfig -NewCertificateThumbprint <ThumbprintFromStep1> -NewCertificateEffectiveDate (Get-Date)
Set-AuthConfig -PublishCertificate
Set-AuthConfig -ClearPreviousCertificate

 

einfügen, korrekt?

 

Danach noch die Pools wiederverwenden und es sollte passen.

 

Grüße

Phil

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...