Jump to content
Ebenezer

Exchange 2010 -> Zugriff auf Globale Adresseliste schlägt fehl

Recommended Posts

Hi, alle Outlook Clients (es gibt nur 2010) erhalten seit ein paar Tagen beim Zugriff auf die Globale Adressliste plötzlich die Meldung "der Vorgang ist fehlgeschlagen". Auf dem (einzigen) Exchange 2010 (CU 23) habe ich folgendes beobachtet bzw. schon probiert (der Exchange wurde vor vielen Jahren mal von Exchange 2003 migriert, via ADSIEDIT mussten einige PublicFolder Einträge entfernt werden um ihn deinstallieren zu können):

- Standard-Offlineadressliste entfernt und unter gleichem Namen neu erstellt

- Logging erhöht -> Get-EventLogLevel -Identity "MSExchangeSA\OAL Generator" -Level Expert

- Get-AddressList | Update-AddressList -> hier werden drei fehlerhafte Empfänger (Öffentliche Ordner) angezeigt die alle am Ende ein "Wiederhergestellt" in Klammern zu stehen haben

- Get-OfflineAdressBook | Update-OfflineAddressBook -> anschließend erscheinen im Eventlog MSExchangeSA 9330 und MSExchangeSA 9334

 

OABGen-Fehler "80040115" (interne ID "50004ca") beim Zugriff auf Active Directory "DC1" für "".
- \Standard-Offlineadressliste

 

OABGen-Fehler "80040115" beim Initialisieren des Prozesses zum Generieren des Offlineadressbuch. Es wurden keine Offlineadressbücher generiert. Informationen hierzu finden Sie im Ereignisprotokoll.
- \Standard-Offlineadressliste

 

Folgenden Artikel kenne ich schon - die Punkte 1-4 sind m.E. nicht zutreffend:

 

https://blogs.msdn.microsoft.com/dgoldman/2007/11/15/oab-generation-fails-to-generate-with-errors-9330-and-9334/

 

Dann bin ich auf Diskussionen gestoßen wo die Ausführung des Tools oabvalidate.exe (nur erhältlich durch Microsoft PSS) geholfen hat. Gefunden habe ich nun folgendes:

 

https://archive.codeplex.com/?p=oabvalidate

 

Hier befindet sich u.a. ein PS-Script namens "Export-LingeringLinkObjects.ps1" ... macht das dasselbe wie die o.a. exe? Hat hier noch Jemand einen Lösungsansatz für mich? DC1 läuft übrigens unter 2008 R2. Ich hatte gesehen, dass ein ähnliches Problem durch ein MS Update aus dem Herbst 2018 verursacht wurde, jedoch betraf das wohl nur DCs unter Windows Server 2016.

 

Danke!
 

Nico

 

 

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...