Jump to content

Empfohlene Beiträge

Hallo Windows-Profis!

 

Ich habe folgendes Setup, was nicht so funktioniert wie es sollte.

Ich habe ein Failover-Cluster, bestehend aus 2 Windows Server 2016 mit der File Server Rolle installiert. Vom SAN kommt eine LUN per iSCSI, die an beide Hosts gemappt ist. Auf der Disk ist ein NTFS-Filesystem und sie hängt momentan an Node1.

Ich habe auf der File Server Rolle einen neuen NFS-Share angelegt auf dieser Disk gespeichert, das funktioniert alles. Der NFS-Share macht einen Failover wenn ein Node nicht mehr erreichbar ist.

 

Und jetzt kommt mein Problem: Da auf dieses Share auch Linux-Systeme zugreifen müssen, würde ich gerne UNIX-Konforme Zeichen abfangen und habe dazu das gefunden: https://blogs.technet.microsoft.com/sfu/2012/01/26/file-name-translation-revisited/

 

Wie da angegeben habe ich auf beiden Cluster-Nodes das File C:\charmap.txt angelegt mit folgendem Inhalt (zu Testzwecken mal nur mit 2 Zeichen):

0x003a : 0x002d ; replace : with -
0x005c : 0x005f ; replace \ with _

Ebenfalls habe ich das File über regedit konfiguriert und den Service for NFS als auch die Cluter Rolle neu gestartet.

Laut nfsadmin ist auch alles so, wie es sein soll:

The following are the settings on localhost 
 
Locking Daemon Grace Period  : 45 seconds
Activity logging Settings   : 
Protocol for Portmap        : TCP+UDP
Protocol for Mount          : TCP+UDP
Protocol for NFS            : TCP+UDP
Protocol for NLM            : TCP+UDP
Protocol for NSM            : TCP+UDP
Protocol for Mapping Server : TCP+UDP
Protocol for NIS            : TCP+UDP
Enable NFS V3 Support       : Enabled 
Renew Authentication        : Enabled 
Renew Authentication Interval : 600 seconds
Directory Cache             : 128 KB
Translation File Name       : C:\charmap.txt
Dot Files Hidden            : Disabled 
NetGroup Source             : none
NIS Server                  : 
NIS Domain                  : 
LDAP Server or AD Domain    : 

Allerdings kann ich auf einem UNIX-Client immer noch kein File anlegen, welches z.B. te:st.txt heisst. Auf der Cluster-Disk sehe ich ein File mit unbekanntem File-Type mit dem Namen Te.

Was mache ich falsch? Kann mir jemand helfen?

 

Vielen Dank,

Alex

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
10 hours ago, magheinz said:

ganz ehrlich: sowas macht man nicht.

Hi,

 

hast du dafür auch eine genauere Ausführung? Ich will das ja nicht machen, weil man es kann, sondern weil 99,9% der Clients UNIX sind...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Weil auch kein vernünftiger Unix/Linuxuser Doppelpunkte in Dateinamen nimmt. Es gibt oft genug im Austausch mit anderen Probleme mit deutschen Umlauten, da denkt man über Sonderzeichen lieber gar nicht erst nach.

 

Auch Windows selber hat oft genug Probleme mit den übersetzten Verzeichnisnamen. Mal ist c:\Benutzer, dann aber wieder c:\users.

 

Ein Dateiname sollte immer eindeutig sein was bedeutet, man nimmt den kleinsten gemeinsamen Nenner an Zeichen und Stringlängen etc der beteiligten Systeme.

Alleine das ignorieren von Gross- und Kleinschreibung bei Windows genügt für reichlich Probleme in der Zusammenarbeit.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ach ja: ich schreibe das hier übrigens an meinem Arbeitsplatz. Einen Debian-Stable-Rechner.

Linuxclients haben wir hier nur in der IT. Server aber im 3Stelligen Bereich.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×