Jump to content

Relaunch 2018: Willkommen im neuen Forum - Das MCSEboard.de wurde runderneuert. Wir wünschen Euch viel Spaß an Board.

Melde dich an, um diesem Inhalt zu folgen  
Jim di Griz

Netz Hyper-V NIC-Infos inkonsistent

Empfohlene Beiträge

Hallo,

habe ein sehr merkwürdiges Verhalten auf einem voll gepatchten 2012 R2 Hyper-V.

Die Kurzzusammenfassung ist: Infos der 2 aktiven NICs im ServerManager und in Netzwerk und Freigabecenter sind nicht identisch und ändern sich nach reboot.

 

Eine NIC auf dem Hyper-v ist eine externe NIC eines converged Switch (VMM), eine NIC ist ein externer Hyper-V Switch. der Server hat 4 NICs, 2 als Bond, eine nicht connected.

die 6 Netzwerke in Hyper-V funktionieren problemlos, VMs können jederzeit miteinander kommunizieren und sie können auch mit der Aussenwelt kommunizieren.

Im Servermanager werden allerdings beide NICs als "DHCP-konfiguriert" angezeigt, wenn ichdie funktionierende feste IP der NIC dann im Freigabecenter ändern will kommt: es sei keine Netzkarte installiert. Lösche ich dann den externen Switch und lege ihn neu an kann ich TCP konfigurieren. Allerdings dreht sich dann das Problem, im Servermanager wird die korrekte IP angezeigt während in den Netzeigenschaften der NIC nun DHCP angezeigt wird.

edit: ipconfig /all zeigt die korrekte ip-config an

dabei funktioniert die festeingestellte IP die ganze Zeit (RDP, ping, Hyper-V)

Das Ganze fiel nur auf weil plötzlich Kerberos auf einen SMB3 Share Share nicht mehr funktioniert (public netz). IP Zugriff auf denselben Share funktionierte.

 

Sozusagen alles voll virtualisiert und funktionierend aber nicht mehr kontrollierbar.

Hat so etwas irgendwer schon mal gesehen oder irgendeinen Tip was da los ist?

 

vielen Dank

bearbeitet von Jim di Griz

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

 

es ist nicht ganz einfach nachzuvollziehen, was du meinst. Ich vermute aber, dass es ein Verständnisproblem bei der Zuordnung ist.

 

Ein vSwitch hat keine IP-Adresse (genau wie ein echer Switch auch keine hat). Vermutlich meinst du also die virtuelle Netzwerkkarte im Host, die entstanden ist, weil der Haken "Gemeinsames Verwenden ... im Management OS zulassen" (so ähnlich) aktiviert ist. Wenn der Host allerdings auf diesem vSwitch gar keine Verbindung braucht (was der Normalfall ist - er braucht keine), dann sollte man den Haken lieber abschalten.

 

Gruß, Nils

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

erstmal danke für die Antwort. Die virt. NICS sollte ich evtl. noch einmal ünerdenken, Der Host beheimatet aktuell 23 VMs und "es ist etwas komplizierter". Er war mal geclustert und wird wieder geclustert werden.

Whatever i have done, das Ganze läuft schon seit Jahren in etwa so, aber das hier beschriebene Verhalten habe ich noch nie gesehen.

Das Problem ist, das diese virtuellen NICs auf dem Hyper-V zwar funktionieren, sich aber nicht konfigurieren lassen. die Infos zu den virtuellen NICs unterscheiden sich zwischen ServerManager und Netzwer- und Freigabecenter. Aussserdem lassen sich die TCP/IP Eigenschaften der NICs nciht ändern mit der Meldung: Es muss eine NIC installiert sein damit sich TCP/IP konfigurieren lässt. Das ist schon sehr strange.

Natürlich ist das ein "Test-Lab". Der Beitrag ist erstmal nur eine Nachfrage ob so etwas schon mal jemand erlebt hat.

 

Das war vielleicht auch schon wieder zuviel. auf den Kern gebracht:

Wie kann es sein das sich NIC-Eigenschaften und Server-Manager Eigenschaften einer NIC so krass unterscheiden und was kann man da tun? Wie kann es sein das eine NIC komplett funktioniert, trotzdem kommt beim Konfigurieren der TCP/IP Eigenschaften die Meldung es sei keine NIC installiert? sowas würde ich bei NT 4.0 erwarten aber nicht bei Server 2012.  es passiert genau dies: https://youtu.be/G0S5dBeLwPs?t=11

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo

danke, kann ich machen. der Fehler tritt allerdings nur auf dem Host-Level auf. Im Report fehlt das SystemCenter VMM-Level mit den logical Networks. VM-Namen habe ich entfernt.

Der Hyper-V Host wird mit Virtual Machine Manager verwaltet

Tolles Skript!

Host Level Hyper-V Level VM Level physical network adapters Hyper-V virtual switches virtual network adapters vSwitches of type External

pNIC Intel® I350 Gigabit Network Connection #2
(NET 44-2)

vSwitch 44-2
vSwitch ports connected: 6

 

 

pNIC Microsoft Network Adapter Multiplexor Driver
(DL3 F LS Team)

Team DL3 F LS Team

NIC/Team 254253
NIC/Team 254254

vSwitch DL3 F LS Team
vSwitch ports connected: 24

 

 

 

pNIC Intel® I350 Gigabit Network Connection
(Ethernet)

vSwitch NET 00
vSwitch ports connected: 1

 

Nebenfrage, total unabhängig vom Ausgangsproblem : Wie kommuniziert denn irgendeine externe Quelle mit einer VM ohne externen vSwitch mit virt. NIC auf dem Host? Vielleicht seh ich ja auch den Wald vor lauter Bäumen nicht.


vielleicht noch weiter reduziert: Hyper-V weg, ein Server 2012 R2.

2 NICs im Server. Es existiert keinerlei DHCP Server .

die TCP/IP Infos der NICs im Server-Manager und in den Eigenschaften der Netzweradapter unterscheiden sich diametral.

Der ServerManager sagt: DHCP ist aktiviert. Die NIC-Eigenschaften sagen garnichts, bei Anklicken TCP/IP v4 kommt die Meldung: keine Netzkarte aktiviert/vorhanden.

Ich lösche die NICs und installiere sie neu im Gerätemanager.

Danach: der ServerManager zeigt die korrekten seit Jahren fest vergebenen IPs an, und in den TCP/IP-Eigenschaften der NICs ist DHCP aktiviert.

Während in beiden Fällen alles (Ping RDP whatever) funktioniert. Grenzt schon an Hexerei.

bearbeitet von Jim di Griz

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

 

ich fürchte, so kommen wir nicht weiter. Sorry, aber aus der Ferne kann ich hier nichts für dich tun.

 

 

Wie kommuniziert denn irgendeine externe Quelle mit einer VM ohne externen Switch mit virt. NIC auf dem Host?

 

Naja, halt über den vSwitch. Ohne vSwitch kann eine VM nicht kommunizieren.

 

Der Switch selbst stellt eine Verbindung für alle vNICs her, die daran angebunden sind. Normalerweise sind das nur die VMs. Dazu braucht der Host (= das Management OS) aber keine vNIC, denn er kommuniziert ja normalerweise über eine eigene physische Netzwerkkarte. In deinem Szenario könnte man dafür die nicht verbundene nehmen.

Mit der Kommunikation der VMs hat der Host (= das Management OS) nichts zu tun, genau wie ServerA nichts mit der Kommunikation von ServerB zu tun hat.

 

Best-Practice-Design für einen "herkömmlich" angebundenen Host:

  • 1 oder mehrere NICs (Teaming), über die die VMs ins LAN kommen. Hier (und nur hier) definiert man den vSwitch, Haken "Gemeinsame Verwendung" abschalten. Hierüber kommunizieren dann ausschließlich die VMs.
  • optional: 1 oder mehrere NICs (MPIO), um das Storage anzubinden. Kein vSwitch, nur Storage-Traffic.
  • optional: 1 oder mehrere NICs (separate Karten) für die Clusterkommunikation. Kein vSwitch.
  • 1 NIC, mit der der Host (= das Management OS) selbst ans LAN angebunden wird. Kein vSwtich. Hierüber spricht der Host mit dem AD, mit WSUS usw.

Gruß, Nils

bearbeitet von NilsK

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo, na denn danke soweit.

 

nur zur Klarstellung: haette gar nicht von Hyoer-V anfangen sollen. es ist ein Problem der NICs auf dem Server. Dasselbe Problem gibt es auch mit physikalischen NICs, siehe youtube Link weiter oben.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

das ist in etwa was ich hier habe:https://charbelnemnom.com/2014/05/create-a-converged-network-fabric-in-vmm-2012-r2/

 

das Problem ist jedoch, das ich den vNICs auf dem Host keine andere IP geben kann weil das OS meldet das keine NIC da ist und deswegen keine neue IP eingetragen werden kann. Während alles läuft. Domäne, Kerberos, ping, alles über die alte IP einer vNIC die angeblich nicht da ist im GUI.

Dann lösche ich die vNiC, erstelle eine neue vNIC und kann dann eine IP vergeben. ich rebotote. Die neue IP funktioniert, aber die TCP/IP Eigenschaften zeigen nun DHCP ohne IP an. während die neue IP erreichbar ist.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  

×