Jump to content

SCVMM 2012SP1 Netzwerke einrichten


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich habe eine Frage zum Einrichten eines weiteren Netzwerkes in einer Testumgebung.

 

vorhanden ist, bzw. was bisher funktioniert:

 

- Host, 2 Nics, als LACP Team

- über das Team laufen Mangement, sowie ein vlan 102

- am Cisco Switch ist ein LAG konfiguriert und das vlan angelegt

- Kommunikation zu einen XenServer klappt

 

Jetzt benötige ich ein weiteres, nicht geroutetes vlan, welches auch über den Teaming Adapter geht, woran ich aktuell scheitere.

 

Folgende 2 Varianten hatte ich ausprobiert:

1. Variante

Logisches Netzwerk angelegt, Network Site, VLAN ID 111, 172.26.1.0/24

VM Network angelegt und dem logischen Netz zugeordnet

Hosteigenschaften, Logical Network connectivity des Teaming Adapters das neue logische VLAN angehakt

VM NIC PVS Network hinzugefügt, Enable VLAN angehakt, VLANID 111 gesetzt

der NIC innerhalb der VM dann eine statische IP aus diesem Netz gegeben

 

2. Variante

dem bereits vorhandenen Logischen Netzwerk, welches die Network Site mit der VLAN ID 102 hat, habe ich eine weitere Network Site hinzugefügt, eben VLAN 111, 172.26.1.0/24

in den Hosteigenschaften taucht dann das Subnet mit der VLAN ID unter dem vorhandenen Logischen Netzwerk auf, dann den Haken gesetzt

NIC hinzugefügt, Netzwerk ausgewählt und bei VLAN ID die entsprechende gesetzt

 

1. Frage: welche der beiden Varianten wäre die korrekte ?

 

In beiden Fällen habe ich es nicht geschafft eine VM zu pingen, welche auf dem XenServer läuft. Diese hat auch eine statische IP aus dem selben Netz (ohne Gateway, nicht geroutet). Auf dem XenServer ist ein externes Netz angelegt und mit dem externen Bond verbunden, sowie der VM zugewiesen.

 

Das auf dem Switch angelegte vlan ist jeweils mit den XenServer Ports, als auch mit den Hyper-V LAG Ports verbunden.

 

Was ich noch getestet hatte: ich habe dem port des Management PCs das vlan 111 zugeteilt und dem eine statische

IP aus dem 172.26.1.x netz gegeben. Ich konnte dann die VM auf dem XenServer anpingen, die auf dem Hyper-V

jedoch nicht.

 

Hat einer eine Idee, woran das liegen könnte, das die Kommunikation nicht klappt? Wie gesagt, es läuft bereits ein vlan (geroutet) über den Switch, wo vms vom hyper-v mit vms auf dem xenserver kommunizieren können.

 

Danke für Tipps,

Gruß

Marcus

Edited by travelfreak
Link to comment

Hi,

 

ich habe jetzt nochmal ein vlan konfiguriert und so angelegt, wie ich es bereits getan hatte und es funktioniert.

Also eben: Logical Network anlegen, Site hinzufügen, VM Network anlegen und im Logical Network des Host Teaming Adapters aktivieren.

Dann eben der Netzwerk dem Adapter zuweisen und korrekte VLAN ID einstellen.

 

Der einzige Unterschied bei diesen Netz ist, das es geroutet ist. Das PVS Netzwerk, welches nicht funktioniert, soll ein nicht geroutetes Netz sein (ohne Default Gateway).

 

Weis jemand, ob ich hier an der Switch Konfiguration (oder doch an der Hyper-V Konfig) etwas besonders einstellen muss? Wie bereits erwähnt,

wenn ich an meinem Mgmt PC eben das vlan 111 auf den port konfiguriere, dann kann ich vom pc aus eine vm im XenServer anpingen, jedoch

keine VM im Hyper-V Host.

 

Hat Hyper-V ein Problem damit, das es ein 172.26.1.0/24 Netz ist; das 192.168.3.0/24 ging problemlos.

 

Mit dem Logical Switch, Port Profilen etc. werde ich mich nach und nach beschäftigen. Komme aus der XenServer Welt, eins nach dem anderen ;)

 

Danke nochmal,

Gruß

Marcus

Edited by travelfreak
Link to comment

Hallo,

 

einen kleinen Schritt weiter. Obwohl es ein nicht geroutetes Netz werden soll, hab ich dem Netz mal eine Schnittstelle auf dem Switch

gegeben. Ich kann jetzt vom Hyper-V Host direkt das Gateway 172.26.1.1 anpingen und auch die VMs auf dem anderen XenServer.

Mit der Schnittstelle wird es nichts zu tun haben, ich habe den Host auch mal gepatcht und gebootet.

 

Jeder klappt es aus den VMs heraus noch nicht. Ich habe mal ein paar Screenshots von der Config angehängt. Vielleicht hat noch

einer eine Idee.

 

Eigentlich habe ich nichts anders gemacht, wie bei den schon vorhandenen vlans 102 und 103.

 

Danke, Gruß

Marcus

 

 

 

 

 

post-8751-0-88653500-1381529180_thumb.jpg

post-8751-0-73316500-1381529195_thumb.jpg

post-8751-0-62489300-1381529208_thumb.jpg

post-8751-0-60118900-1381529218_thumb.jpg

post-8751-0-90775100-1381529228_thumb.jpg

Link to comment

Hi,

 

danke für den Hinweise. Selbst wenn ich die Netzwerke so anlege, wie von dir vorgeschlagen, klappt es nicht.

Müssten die VMs nicht wissen welches VLAN sie verwenden sollen, da ich es bei der Hardwarekonfiguration der

Netzwerkkarte ja auswähle? Wie gesagt, vom Host selber kann ich die Schnittstelle des Netzes pingen und

eben das komische ist, das 2 angelegte VLANs (2 Logical Networks) problemlos funktionieren.

 

Hat jemand noch eine Idee, woran das liegen könnte ?

 

Danke, Gruß

Marcus

 

 

post-8751-0-86552400-1381687295_thumb.jpg

post-8751-0-96692200-1381687376_thumb.jpg

Edited by travelfreak
Link to comment

Moin,

 

oberflächlich betrachtet fällt mir an der Konfiguration nichts auf. Ich gehe mal davon aus, dass die lokale Firewall in den VMs ICMP nicht blockiert ...

 

Hast Du die Möglichkeit dem Switch eine IP Adresse in jedem beteiligten VLAN zu geben?

Dann könntest Du mal versuchen vom Switch aus die VMs zu pingen und umgekehrt. Anschließend mal einen Blick in den ARP Cache von Switch und VMs werfen.

Link to comment
  • 4 weeks later...
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...