Jump to content

TMG - Weblistener


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen

 

Wir verwenden bei uns in der Firma einen Windows Server 2008 R2 mit einem Forefront TMG um den Zugriff von aussen auf verschiedene Dienste (OWA, Intranet usw.) weiterzuleiten. Bis jetzt greifen wir von aussen auf eine IP zu, welche dann von einer Firewall (Zywall USG 100) zum TMG weitergeleitet wird, also nur der Port 443. Der TMG entscheidet dann mit einem Weblistener, ob die Abfrage einer Regel entspricht und leitet diese dann dem entsprechen ins interne Netz weiter. Die Links von extern waren bis jetzt immer nach diesem Format https://domain.ch/dienst.

 

Nun haben wir uns aber an der Firewall eine zweite externe IP zugelegt, welche wir wieder mit dem Port 443 von der Firewall weiterleiten lassen zum TMG, aber auch dort zur einen anderen Schnittstelle, welche sich am im selben Netz befindet, wie die erste. Auf dieser Schnittstelle haben wir nun auch noch einen neuen Weblistener eingerichtet, welcher neue Dienste nach aussen frei gegeben soll, aber mit einem anderen Link (https://dienst.domain.ch).

 

Nun besteht aber das Problem, dass der zweite Weblistener vom Internet und dem Netz 1 her nicht funktioniert, sondern nur vom Netz 2, wenn man einfach in der Host-Datei eines Testclients die direkte IP des TMGs mit dem jeweiligen Link (https://dienst.domain.ch) einträgt. Wenn man es vom Internet und dem Netz 1 her probiert, kommen die Pakete schon beim TMG an, werden aber keiner Regel zugeordnet. Ich habe nun schon alles Mögliche versucht: Firewall getauscht, Netz 2 in 2 Netzte aufgeteilt usw.

 

Hatte jemand schon dasselbe Problem oder kann mir jemand helfen?

 

Für jede mögliche Hilfe bedanke ich mich schon vielmals im Voraus.

 

post-64549-0-09341600-1366891971_thumb.png

Link to comment

Hi,

 

- IP-Konfiguration des zweiten Interfaces komplett entfernen

- IP-Adresse auf das erste Interface mit drauf legen (Secondary-IP)

- Routing prüfen

- TMG Listner prüfen, ggf. neu anlegen

- TMG durchstarten

 

.. müsste das Problem lösen..!?

Problem bei deiner beschriebenen Konstellation sind zwei Default-Gateways. Wenn du die IP als Secondary auf die erste Verbindung bindest, hast du nur ein definiertes Gateway und somit einen konsistenten Weg.

 

 

Beste Grüße

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...