Jump to content
Sign in to follow this  
kibo

Encaps Frame-Relay - Vorsicht Dummi Frage

Recommended Posts

Hi @ all.

ich hätte mal ne algemeine Frage (da sich meine 1600er strikt weigern)

Ich hab 2 1600er via DCE und DTE Kabel miteinander verbunden.

(HDLC & PPP laufen reibungslos)

 

Könnt ihr mir prinzipiell sagen ob und wie man eine Frame Relay Verbindung zwischen diesen beiden Routern aufbaut?

Ich bekomme es nicht ans laufen.

 

Auf beiden Routern ist die Encapsulation auf Frame-Relay eingestellt. Die LMIs stehen auf Cisco. Username / Passwörter stimmen auch (braucht man die eigentlich?)

Die beiden Interface sind auch in einem Netz (192.168.0.0 /24)

 

Hab bei Cisco was über SubInterface Verbindungen gelesen. Aber das hab ich so auch nicht zum laufen gebracht. (Subinterface-Point-to-Point)

 

Hat zufällig jemand ne Musterkonfig? Oder kann jemand mal in kurzen Worten die Konfig beschreiben? Also LMI/DLCI/Frame-Relay-Mapping...

 

Wenn das jetzt zu allgemein ist. Kann ich auch mal die Konfigs der beiden Router posten. Prinzipiell hab ich halt das Prob das die Leitung immer "up/down" ist. Der PVC sagt "inaktiv oder deleted"

 

Grüsse Kibo

Share this post


Link to post

Hallo kibo,

 

die frame relay verbindung läuft auf basis des subinterfaces z.b. serial0.110 (110 wäre PVC). du musst lediglich auf beiden maschinen die PVC erstellen. also im global config modus.... z.b int ser 0/0.1 dann bist du im subinterface drinne, dort kannst du die encapsulation einstellen usw.

 

könnte dir eine standart running config schreiben, hab aber jetzt keine zeit.

 

gruß

 

BJW

 

CCNP

Share this post


Link to post

Hi - Danke für deine Antwort.

 

meinst du also dass ich auf beiden Routern Subinterface anlegen muss? Ich hatte es bis jetzt immer nur auf einem gemacht. Der 2te Router hatte framerelay direkt auf dem Interface gesetzt.

Ich werd das morgen in der Arbeit mal testen. Wenn du die Zeit für ne Konfig findest - wäre das natürlich subba...

 

Grüsse Kibo

Share this post


Link to post

jo auf beiden interfacen.

 

ich mach dir morgen mal ne standard konfig. sollte man mich inner firma net nerven :-)

 

Gruß

 

Basti

Share this post


Link to post

Hi zusammen, ich habs jetzt nochmal versucht, aber es geht immer noch net... Vielleicht hat jemand ja ne Idee...

Grüsse aus München

 

 

ROUTER 1

********

 

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname rmws-kibo-de01

!

enable secret 5 $1$76Gr$O0Kd77XSdSDqugBEmhtnS1

enable password kibo

!

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

encapsulation frame-relay

!

interface Serial0.210 point-to-point

ip address 192.168.0.1 255.255.255.0

bandwidth 64000

frame-relay interface-dlci 210

!

interface BRI0

no ip address

shutdown

!

no ip classless

!

line con 0

line vty 0 4

password test

login

!

end

 

 

 

 

 

ROUTER 2

********

Current configuration:

!

version 11.2

no service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname rmws-kibo-de03

!

enable secret 5 $1$DDMF$koJklEAw8IS8pevBvqZar1

!

username rmws-kibo-de01 password 0 cisco

!

interface Ethernet0

no ip address

shutdown

!

interface Serial0

no ip address

encapsulation frame-relay

no fair-queue

!

interface Serial0.200 point-to-point

ip address 192.168.0.2 255.255.255.0

frame-relay interface-dlci 200

!

no ip classless

!

line con 0

password test

logging synchronous

line vty 0 4

login

!

end

Share this post


Link to post

Hi,

 

wenn ich das richtig lese und verstehe habe, dann mußt du auf beiden seiten die gleichen PVC haben. Das heißt setze doch einfach mal beide auf das Subinterface auf die 200 oder 210. Ich weiß das ist nicht ganz Sinnvoll aber was solls. Ich habe auch mal versucht eine Frame-Relay Strecke aufzubauen. Bin auch gescheitert. Mir wurde damals gesagt dies geht nicht, da man einen Frame-Relay Switch benötigt. Diese Aussage habe ich damals so stehen gelassen ohne weiter zu prüfen. Wenn du aber es schaffst wäre es super.

Share this post


Link to post

hi

 

der pvc ist auf beiden nicht identisch.

 

Desweiteren musst du auf DCE die clock einrichten.

 

Gruß

 

Bastian

Share this post


Link to post

Hi to All

 

Sollte das Problem gelöst sein ? einfach nicht weiter nachdenken

wenn nicht sollte es so gehen, ist getestet

 

Router 1

#############################

 

k5rt10#sh run

Building configuration...

 

Current configuration : 1222 bytes

!

version 12.2

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname k5rt10

!

logging queue-limit 100

enable secret xxx

enable password 7 0205

!

ip subnet-zero

!

!

no ip domain lookup

!

frame-relay switching

!

!

!

!

interface FastEthernet0/0

description LAN K5

ip address 192.168.250.253 255.255.255.0

speed 100

half-duplex

!

interface Serial0/0

description WAN --> k5rt20(s0)

bandwidth 2048

ip address 192.168.99.1 255.255.255.252

!

interface Serial0/1

bandwidth 2048

no ip address

shutdown

!

interface Serial0/2

description WAN --> k5rt30

bandwidth 2048

no ip address

encapsulation frame-relay

!

interface Serial0/2.210 point-to-point

ip address 192.168.99.9 255.255.255.252

frame-relay interface-dlci 210

!

interface Serial0/3

no ip address

shutdown

!

router eigrp 1

redistribute static

network 192.168.99.0

network 192.168.250.0

no auto-summary

!

no ip http server

ip classless

!

!

!

logging 192.168.250.100

snmp-server community public RO

snmp-server community xxxx RW

snmp-server location Testsystem

snmp-server enable traps tty

!

line con 0

line aux 0

line vty 0 4

password xxxx

login

!

!

end

 

 

k5rt10#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

* - candidate default, U - per-user static route, o - ODR

P - periodic downloaded static route

 

Gateway of last resort is not set

 

D 192.168.30.0/24 [90/2297856] via 192.168.99.10, 00:14:11, Serial0/2.210

D 192.168.10.0/24 [90/1889792] via 192.168.99.2, 00:14:11, Serial0/0

C 192.168.250.0/24 is directly connected, FastEthernet0/0

192.168.99.0/30 is subnetted, 3 subnets

C 192.168.99.8 is directly connected, Serial0/2.210

C 192.168.99.0 is directly connected, Serial0/0

D 192.168.99.4 [90/2273792] via 192.168.99.2, 00:14:11, Serial0/0

D 192.168.20.0/24 [90/1889792] via 192.168.99.2, 00:14:11, Serial0/0

 

 

 

 

 

router 2

########################

 

k5rt30#sh run

Building configuration...

 

Current configuration:

!

version 11.1

service timestamps debug datetime

service timestamps log datetime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname k5rt30

!

enable secret xxxxx

enable password xxxxx

!

ip subnet-zero

frame-relay switching

!

interface Loopback10

description LAN K5

ip address 192.168.30.254 255.255.255.0

!

interface Serial0

description WAN --> k5rt20(s1)

ip address 192.168.99.6 255.255.255.252

bandwidth 128

clockrate 125000

!

interface Serial1

description WAN --> K5RT10(S2)

no ip address

encapsulation frame-relay

clockrate 2000000

frame-relay intf-type dce

!

interface Serial1.210 point-to-point

ip address 192.168.99.10 255.255.255.252

bandwidth 2048

frame-relay interface-dlci 210

!

interface TokenRing0

ip address 26.133.20.1 255.255.255.0

ring-speed 16

!

interface BRI0

no ip address

shutdown

!

router eigrp 1

network 192.168.99.0

network 192.168.30.0

network 192.168.15.0

network 26.0.0.0

!

ip classless

logging buffered

logging 192.168.250.100

snmp-server community public RO

snmp-server community xxxx RW

snmp-server location Testsystem K5RT30

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

 

k5rt30#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route

 

Gateway of last resort is not set

 

192.168.99.0/24 is variably subnetted, 4 subnets, 2 masks

C 192.168.99.8/30 is directly connected, Serial1.210

D 192.168.99.0/30 [90/2273792] via 192.168.99.9, 00:13:36, Serial1.210

D 192.168.99.0/24 is a summary, 00:14:09, Null0

C 192.168.99.4/30 is directly connected, Serial0

D 192.168.10.0/24 [90/2401792] via 192.168.99.9, 00:13:36, Serial1.210

C 192.168.30.0/24 is directly connected, Loopback10

D 192.168.20.0/24 [90/2401792] via 192.168.99.9, 00:13:36, Serial1.210

D 192.168.250.0/24 [90/1764352] via 192.168.99.9, 00:13:36, Serial1.210

 

:)

Share this post


Link to post

ja sieht gut aus :-)

 

@kibo: du siehst auch direkt das er die clockrate auf der dce seite gesetzt hat, denke dieses ist auch dein Prob inkl. der PVC's

 

danke für die ausführliche Hilfe.

 

Gruß

 

Basti

Share this post


Link to post

Hi to ALL

 

bleibt noch abschliesend zu sagen: so ein Router Rücken an Rücken geschaltet ist kein Frame Relay Switch wie z.B. eine IGX (8420 oder sowas) deswegen ist es notwendig min. einer der beiden Router zu Switch zu machen, da dies in der Beispiel Config gedreht war (DCE und DTE) habe ich es auf beiden konfiguriert.

 

Also wenn Ihr unsicher seit solltet Ihr den Befehl

frame-relay switching (Globale Konfig)

auf beiden Routern konfigurieren.

 

 

Viel Spas beim Testen

 

Gruß

Markus

Share this post


Link to post

Vielen Dank

Ihr seid die grössten, besten, tollsten und schlausten...

 

Das war der entscheidende Eintrag

(interface)

frame-relay intf-type dce !!!!!!!

 

hätte man auch selbst drauf kommen können...

 

Danke - jetzt kann i endlich wieder ruhig schlafen.....

Grüsse Kibo

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...