Jump to content
Sign in to follow this  
r4z13l

Vlan + bssid

Recommended Posts

Hallo Zusammen,

 

ich habe auf einem 2960-Switch zum testen einem Port zwei VLAN´s zugewiesen:

 

interface GigabitEthernet1/0/31
switchport trunk allowed vlan 5,10
switchport mode trunk
switchport nonegotiate
macro description cisco-switch
spanning-tree link-type point-to-point

 

An diesem Port hängt ein kleiner Netgear-Switch und an diesem Switch ein Accesspoint (1242). Unschön, weiß ich, ist jedoch auch nur zum testen.

 

Auf dem AP habe ich 2 SSID´s in den verschieden VLAN´s konfiguriert.

Jedoch komme ich nur über VLAN 10 ins Internet.

In VLAN 10 ist ein DHCP Server activ, im VLAN 5 arbeite ich mit statischen IP - Adressen.

 

anbei noch die config vom Switch:

 

Building configuration...

Current configuration : 2767 bytes
!
version 12.4
no service pad
service timestamps debug uptime
service timestamps log datetime msec
service password-encryption
service sequence-numbers
!
hostname apTest
!
enable secret 5 ...
!
no aaa new-model
!
!
dot11 vlan-name DHCP vlan 10
dot11 vlan-name festeIP vlan 5
!
dot11 ssid SSID01
  vlan 5
  authentication open
  mbssid guest-mode
!
dot11 ssid SSID02
  vlan 10
  authentication open
  authentication key-management wpa version 2
  mbssid guest-mode
  wpa-psk ascii 7 ...
!
power inline negotiation prestandard source
!
!
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 10 mode ciphers aes-ccm
!
ssid SSID01
!
ssid SSID02
!
mbssid
channel 2437
station-role root
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.5
encapsulation dot1Q 5
no ip route-cache
bridge-group 5
bridge-group 5 subscriber-loop-control
bridge-group 5 block-unknown-source
no bridge-group 5 source-learning
no bridge-group 5 unicast-flooding
bridge-group 5 spanning-disabled
!
interface Dot11Radio0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
bridge-group 10 spanning-disabled
!
interface Dot11Radio1
no ip address
no ip route-cache
shutdown
no dfs band block
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.5
encapsulation dot1Q 5
no ip route-cache
bridge-group 5
no bridge-group 5 source-learning
bridge-group 5 spanning-disabled
!
interface FastEthernet0.10
encapsulation dot1Q 10
no ip route-cache
bridge-group 10
no bridge-group 10 source-learning
bridge-group 10 spanning-disabled
!
interface BVI1
ip address 192.168.0.x 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.0.x
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
bridge 1 route ip
!
!
!
line con 0
logging synchronous
line vty 0 4
logging synchronous
login local
!
end

 

 

Habt ihr eine Idee was ich falsch mache?

Share this post


Link to post
Share on other sites

Hi,

 

da fehlen mir jetzt noch so ein oder andere... Läßt der "Mini" Switch die VLAN Tacs sauber durch? (Ist der VLAN fähig?) - gehen die Verbindungen mit den VLAN´s sauber wenn du auf dem Switch die Ports zuweißt?

Share this post


Link to post
Share on other sites

Hi,

 

einzeln funktionieren die VLAN´s problemlos.

Der kleine Switch unterstützt keine VLAN´s. Leider kann ich aber erst morgen vormittag den AP direkt an den Switch hängen um zu gucken ob das dann funktioniert.

 

Ich werde das morgen ausprobieren und Berichten ;)

Share this post


Link to post
Share on other sites

Guten Morgen,

schließe ich den AP direkt an den Switch an habe ich leider das gleiche Ergebnis :(

Ich bin um jede Idee dankbar!

 

lg r4

 

EDIT:

Ich glaube ich bin einen Schritt weiter:

Der Switch unterstützt nicht dot1Q:

sh interface GigabitEthernet1/0/31 capabilities

GigabitEthernet1/0/31
 Model:                 WS-C2960S-48FPS-L
 Type:                  10/100/1000BaseTX
 Speed:                 10,100,1000,auto
 Duplex:                half,full,auto
 Trunk encap. type:     802.1Q
 Trunk mode:            on,off,desirable,nonegotiate
 Channel:               yes
 Broadcast suppression: percentage(0-100)
 Flowcontrol:           rx-(off,on,desired),tx-(none)
 Fast Start:            yes
 QoS scheduling:        rx-(not configurable on per port basis),
                        tx-(4q3t) (3t: Two configurable values and one fixed.)
 CoS rewrite:           yes
 ToS rewrite:           yes
 UDLD:                  yes
 Inline power:          yes
 SPAN:                  source/destination
 PortSecure:            yes
 Dot1x:                 yes

 

Will ich beim AP auf 802.1Q umstellen, wird mir dies zwar Vorgeschalgen, ich kann es aber nicht auswählen:

ap(config-subif)#encapsulation ?
 dot1Q  IEEE 802.1Q Virtual LAN

ap(config-subif)#encapsulation 802.1Q 5
                              ^
% Invalid input detected at '^' marker.

Edited by r4z13l

Share this post


Link to post
Share on other sites

Hi,

 

ohne die Konfiguration von Cisco näher zu kennen,

würde ich tippen dass es nicht

encapsulation 802.1Q 5

sondern

encapsulation dot1Q 5

heißen muss (genauso wie Du es auch in der Switch-Konfiguration benutzt hast).

Daher kommt zumindest die "Invalid input" Meldung.

Vielleicht hilft das ja schon.

Viele Grüße

Share this post


Link to post
Share on other sites

Hi ,

 

momentan ist der AP ja mit

encapsulation dot1Q

konfiguriert. Mein Problem liegt momentan darin, dass ich am Switch nicht auf dot1Q oder am AP nicht auf 802.1Q umstellen kann :(

Share this post


Link to post
Share on other sites

Ok,

 

ich hatte mich auf

 

Will ich beim AP auf 802.1Q umstellen, wird mir dies zwar Vorgeschalgen, ich kann es aber nicht auswählen:

ap(config-subif)#encapsulation ?
 dot1Q  IEEE 802.1Q Virtual LAN

ap(config-subif)#encapsulation 802.1Q 5
                              ^
% Invalid input detected at '^' marker.

 

bezogen. Da liegt ja der von mir vorher beschriebene Tippfehler vor.

Und laut

 

Trunk encap. type:     802.1Q

unterstützt der Switch doch 802.1Q :confused:

"dot1Q" ist nur eine andere (einfachere) Schreibweise für 802.1Q (siehe z.B. dot1q and 802.1Q)

 

Auf dem Switch müsstest Du für das Interface GigabitEthernet1/0/31

noch folgendes konfigurieren:

switchport trunk encapsulation dot1q

und noch das gleiche native Vlan wie auf dem AP.

Hier ist auch ein Konfigurationsbeispiel für eine ähnliche Konstellation:

http://www.cisco.com/en/US/tech/tk722/tk809/technologies_configuration_example09186a0080665ceb.shtml

Edited by Zoni
typo und Ergänzung um Switch-Konfiguration

Share this post


Link to post
Share on other sites

Hi,

 

dann verstehe ich nicht, warum es nicht funktioniert:

 

Ausgabe vom Switch:

sh interface GigabitEthernet1/0/31 trunk

Port        Mode             [color="Red"]Encapsulation[/color]  Status        Native vlan
Gi1/0/31    on               [color="Red"]802.1q[/color]         trunking      1

Port        Vlans allowed on trunk
Gi1/0/31    1,5,10

Port        Vlans allowed and active in management domain
Gi1/0/31    1,5,10

Port        Vlans in spanning tree forwarding state and not pruned
Gi1/0/31    1,5,10

 

 

Ausgabe AP:

sh interface dot11Radio 0

Dot11Radio0 is up, line protocol is up
...
 [color="Red"]Encapsulation 802.1Q[/color] Virtual LAN, Vlan ID  1., loopback not set

 

 

Das heißt doch, dass beide die selbe encapsulation methode verwenden?

Share this post


Link to post
Share on other sites

Vom AP:

 

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0
FastEthernet0

This is configured as native Vlan for the following interface(s) :
Dot11Radio0
FastEthernet0

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 1              16738                   0
       Other                                           0                 529

  0 packets, 0 bytes input
  70 packets, 23975 bytes output
       Bridging        Bridge Group 1              16739                   0
       Other                                           0                 529

  20997 packets, 1937932 bytes input
  459 packets, 32663 bytes output

Virtual LAN ID:  5 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0.5
FastEthernet0.5

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 5               2815                1974
       Other                                           0                   3

  1104 packets, 134039 bytes input
  1981 packets, 137405 bytes output
       Bridging        Bridge Group 5               2815                1974
       Other                                           0                   3

  1905 packets, 129540 bytes input
  35 packets, 5537 bytes output

Virtual LAN ID:  10 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0.10
FastEthernet0.10

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 10              9638                9609
       Other                                           0                  10

  2301 packets, 317727 bytes input
  7343 packets, 2260834 bytes output
       Bridging        Bridge Group 10              9643                9614
       Other                                           0                  10

  7860 packets, 2300469 bytes input
  2290 packets, 317448 bytes output

Share this post


Link to post
Share on other sites

Hallo,

 

(nach wie vor ohne Garantie ;-):

Was mich stutzig macht ist, die "0" bei Transmitted:

Protocols Configured: Address: Received: Transmitted:

Bridging Bridge Group 1 16738 0

In dem Artikel bei Cisco wird noch das Native Vlan auf dem AP konfiguriert.

VLANs on Aironet Access Points Configuration Example - Cisco Systems

Das müsste ja dann bei Dir folgendermaßen lauten:

interface fastethernet 0.1
encapsulation dot1q 1 native
exit
interface dot11radio 0.1
encapsulation dot1q 1 native

 

Danach sollte dann bei "show vlans" nicht mehr

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interfaces: Dot11Radio0

FastEthernet0

sondern

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

 

vLAN Trunk Interfaces: Dot11Radio0.1

FastEthernet0.1

anzeigen (analog zu dem Cisco-Konfigurationsbeispiel).

Edited by Zoni
ergänzt

Share this post


Link to post
Share on other sites

Hi,

 

habe ich gerade eingetragen. Leider ohne Verbesserung:

interface Dot11Radio0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled

 

interface FastEthernet0.1
encapsulation dot1Q 1 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled

 

EDIT:

Ich habe auch einen PC mit einer festen IP an den kleinen Switch gehängt. Dieser kommt problemlos ins Internet und in lokale Netzwerk. Die Switchconfig scheint also i.O. zu sein.

 

Vielen Dank für eure Hilfe & Geduld :)

Edited by r4z13l
Test des Switch

Share this post


Link to post
Share on other sites

sh vlan:

 

Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0.1
FastEthernet0.1

This is configured as native Vlan for the following interface(s) :
Dot11Radio0
FastEthernet0

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 1              21709                1529
       Other                                           0                 643

  0 packets, 0 bytes input
  1543 packets, 145348 bytes output
       Bridging        Bridge Group 1              21711                1531
       Other                                           0                 643

  3251 packets, 283480 bytes input
  11 packets, 4114 bytes output

Virtual LAN ID:  5 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0.5
FastEthernet0.5

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 5               3778                2571
       Other                                           0                   9

  1537 packets, 169585 bytes input
  2577 packets, 179574 bytes output
       Bridging        Bridge Group 5               3778                2571
       Other                                           0                   9

  2469 packets, 167892 bytes input
  51 packets, 7769 bytes output

Virtual LAN ID:  10 (IEEE 802.1Q Encapsulation)

  vLAN Trunk Interfaces:  Dot11Radio0.10
FastEthernet0.10

  Protocols Configured:   Address:              Received:        Transmitted:
       Bridging        Bridge Group 10             12079               12088
       Other                                           0                  18

  2548 packets, 354341 bytes input
  9586 packets, 2662745 bytes output
       Bridging        Bridge Group 10             12082               12090
       Other                                           0                  18

  10351 packets, 2721500 bytes input
  2534 packets, 353822 bytes output

 

 

 

show dot11 associations:

 

802.11 Client Stations on Dot11Radio0:

SSID [sSID01] :

MAC Address    IP address      Device        Name            Parent         State
0446.65xx.xxxx 192.168.0.x   unknown       -               self           Assoc

 

verbinde ich das Gerät mit der zweiten SSID:

 

802.11 Client Stations on Dot11Radio0:

SSID [sSID02] :

MAC Address    IP address      Device        Name            Parent         State
0446.65xx.xxxx 192.168.16.x   unknown       -               self           Assoc

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...