Jump to content
Sign in to follow this  
Maraun

Exchange 2003 Active Sync Push-Funktion

Recommended Posts

Hallo zusammen,

 

ich hab folgendes Problem:

Unser Exchange 2003 hat Active Sync, OMA und OWA aktiviert und OMA (OWA auf dem IPhone) und OWA (Zugriff per Client) funktioniert. Active Sync funktioniert nur, wenn ich im IPhone wirklich die App öffne. Dann wird die Mail sofort übermittelt, allerdings funktioniert das nicht, wenn die App geschlossen ist. Ich sehe keine weitere ungelesene Mail bei der App.

HTTPS ist nicht geforced und die Einstellungen im IIS / Active Sync Ordner unter Directory Security sind Basic authentication, sonst ist nichts angehakt.

 

Es erscheint auch kein Fehler. Die Mail wurde abgesendet und das IPhone zeigt kein weiteres Mail an. Sobald ich die App öffne, erscheint das Mail dann sofort.

 

Vielleicht hat mir jemand einen Tipp, ob das mit der http-Session zu tun hat oder was ich noch probieren könnte?

 

Danke vorab und viele Grüße

Alex

Share this post


Link to post
Share on other sites

Ich habe den Zugriff per internes WLAN hier getestet und da ist keine Firewall dazwischen. Allerdings wurde unser Exchange in der Vergangenheit mit 2 IP´s betrieben und meldet seit jeher den ActiveSync 3005 Error im Eventlog. Jetzt habe ich die 2te IP, die nicht mehr genutzt wird, entfernt (da der Exchange mir übergeben wurde) aber die Fehler bleiben nach wie vor bestehen:

Unexpected Exchange mailbox server error. Server:mailserver.domäne User:userxyz. HTTP status code [422]. Verify that the Exchange mailbox Server is working correctly.

Diese Meldung kommt für jeden ActiveSync Benutzer. Bei der Überprüfung unserer ActiveSync Konfiguration auf dem Exchange ist mir aufgefallen, dass wir einige andere Einstellungen haben, als eine Konfiganleitung von ActiveSync für Exchange 2003, die ich im Web gefunden habe. Unter anderem ist im IIS Verzeichnis OMA der Anwendungspool nicht ExchangeMobileBrowseApplication, die IISWeb VirtualDir Location heißt nur /LM/W3SVC/1/ROOT ohne Microsoft-ServerActiveSync und wir haben im SystemManager des Exchange unter den HTTP-Protokollen kein virtuelles verzeichnis Namens exchDAV.

Hat mir vielleicht jemand eine Anleitung oder ein Aufstellung der zu setzenden Konfigeinstellungen für ActiveSync? Sind die oben aufgeführten Einstellungen unter Umständen an der fehlenden Push-Funktionalität Schuld?

Formularbasierte Authentifizierung ist ebenso deaktiviert wie die SSL-Verschlüsselung. Lediglich ein SSL-Zertifikat ist von mir auf dem Exchange installiert worden, dass aber bei IPhones und anderen Geräten keine Probleme bereitet, bei Verbindungen wie OWA / OMA.

 

Danke für jede Hilfe.

 

Grüße

Alex

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

ich muss leider diesen Thread nochmals zum Leben erwecken, da ich das Problem weiterhin habe und mir noch Tipps oder Hilfe erhoffe.

Mittlerweile habe ich zwei Dinge versucht:

- Erstellen eines sekundären virtuellen Verzeichnisses samt Berechtigungen für das Verzeichnis und den Einstellungen basierend auf mehreren Tutorials für das Thema. In diesem Tut wird neben dem Verzeichnis noch beschrieben, wie die anderen virtuellen Verzeichnisse (Exchange-OMA, OMA, Microsoft-Server-ActiveSync) angelegt und konfiguriert sein müssen. Vielleicht kann das bei Gelegenheit auch mal jemand mit mir abgleichen. Nach dem Umsetzen des Tutorials hat Active Sync gar nicht mehr funktioniert.

 

- Konfigurieren von Timeoutwerten für Leerlaufsitzungen im Exchange

In der Registry Werte für Min und MaxHeartbeatInterval gesetzt, ohne Erfolg.

 

Wie geschrieben funktioniert das Pushen von Mails per OWA, das heißt, die IPhones haben als Adresse den OWA eingetragen und Pushen die Mails dann auch. Sobald aber der Exchange selber eingetragen wird, funktioniert das Pushen nicht mehr. Frage ich sie dann manuell am IPHone ab, ist die Mail sofort da. Kann das wirklich ein Firewall-Problem sein, obwol Push per OWA geht?

Es erscheint auf dem Exchange auch noch regelmäßig im Application-Protokoll der Fehler 3005 Server Active Sync Fehler und der Hinweis 3033 Server Active Sync, "The average of the most recent [200] heartbeat intervals used by clients is less than or equal to [540]".

 

Vielleicht kann mir ja jemand bei dem Problem noch Tipps oder Hilfe geben.

 

Danke und Grüße

Alex

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...