Jump to content
Sign in to follow this  
werth

RPC-Server Fehler beim Aufruf von Forefront TMG-Verwaltung

Recommended Posts

Hallo liebe Community,

 

vorweg, Ich bin Neuling, falls ihr Infos braucht die Ihr in meinem Post nicht finden koennt, bitte Bescheid geben welche ihr braucht und wo ich diese finden kann.

 

Wir haben hier ein recht frisches Windows Essential Business Server 2008

 

Verwaltungsserver

Sicherheitsserver (VM auf einem ESXi)

Nachrichtenserver (VM auf einem ESXi)

 

Nun hatten wir letztens Probleme mit dem Speicherplatz in einem unserer Datastores und haben die (ausgeschalteten) VM's verschoben, Platz geschaffen und wieder an alte stelle zurueck gepackt.

 

Es scheint alles wie gewohnt, allerdings funktioniert die Verbindung vom Verwaltungsserver mit Forefront TMG-Verwaltung zum Sicherheitsserver nicht mehr. Fehler: "Fehler beim Aktualisieren - Der RPC-Server ist nicht verfügbar)

 

Die Google Suche hilft mir absolut nicht weiter. Im Bezug auf Forefront und EBS bekomme ich kaum bis garkeine Hits.

 

Soweit ich das einschaetzen kann, laufen die erforderlichen Dienste sowohl auf dem Verwaltungsserver als auch auf dem Sicherheitsserver.

 

Auch der Internet Zugriff ueber den Sicherheitsserver funktioniert nichtmehr vom Verwaltungsserver/Nachrichtenserver.

 

An den Firewalleinstellungen habe ich nichts gedreht.

 

Zur Fehlerbeschreibung habe ich bei Microsoft auf folgender Seite die Problemloesung zu Rate gezogen, leider ohne Erfolg. Möglicherweise hilft es euch aber dabei den Fehler eingrenzen/einschaetzen zu koennen.

 

Das Programm "Ntdsutil" ( http://support.microsoft.com/kb/839880/de )

 

Unternehmens- und Domänenadministratoren können das Programm "Ntdsutil" verwenden, um Active Directory zu verwalten und zu reparieren und Probleme mit der RPC-Endpunktzuordnung zu behandeln. Gehen Sie folgendermaßen vor, um Probleme mit der RPC-Endpunktzuordnung zu behandeln:

 

1. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie in das Feld Öffnen die Zeichenfolge cmd ein, und klicken Sie anschließend auf OK.

2. Geben Sie NTDSUtil ? ein, und drücken Sie die [EINGABETASTE].

3. Geben Sie Metadata cleanup in die ntdsutil:-Eingabeaufforderung ein, und drücken Sie dann die [EINGABETASTE].

4. Geben Sie in die metadata cleanup:-Eingabeaufforderung Connections ein, und drücken Sie die [EINGABETASTE].

5. Geben Sie in die Eingabeaufforderung Connections: den Befehl Connect to server localhost ein, und drücken Sie die [EINGABETASTE].

 

Hier bekomme ich die Fehlerausgabe:

DsBindWithSpnWxW-Fehler 0x6ba(Der RPC-Server ist nicht verfügbar.)

 

mfg werth

Edited by werth

Share this post


Link to post

Hallo werth,

 

schön dass du uns gefunden hast.

 

Bitte achte in Zukunft darauf auch Großbuchstaben zu nutzen. Die Wahrscheinlichkeit dass dir jemand hilft steigt drastisch mit der guten und leichten Lesbarkeit deiner Beiträge!

 

Vielen Dank für dein Verständnis!

Share this post


Link to post

Die Replikation mit Active Directory funktioniert.

Jeder der Server kann sowohl den Servernamen/FQDN als auch die IP-Adresse pingen.

Share this post


Link to post

Liegt es an der Art meines Posts, dass hier Niemand antwortet oder an dem Problem selbst?

Ich bin wirklich etwas ratlos wie ich weiter vorgehen kann um das Problem eingrenzen zu können. hilfe bitte

Share this post


Link to post

Soo..

 

durch abschalten der windows firewall (netsh firewall set opmode disable)

habe ich herausgefunden, dass das Problem wohl in der Firewallkonfiguration liegen muss.

Mit abgeschalteter Firewall funktioniert die Verbindung ohne Probleme.

Ich werde mich da mal weiter etwas damit beschäftigen, falls Ihr aber Hinweise für mich habt, nehme ich diese gerne entgegen.

 

mfg werth

Share this post


Link to post

Problem gelöst! Yeehha!

 

Meine Lösung sah folgendermaßen aus:

 

Es scheint so als waeren zwei bestimmte FW-Regeln betroffen, die den internen tcp verkehr regelt, die andere den rpc verkehr. Habe beide Regeln gelöscht (vorher ein Backup gemacht) und neue Regeln angelegt mit den EXAKT selben Einstellungen.

 

Dann musste noch ein Haken in den Systemweiten Einstellungen (Forefront TMG-Verwaltung/Firewalleinstellungen/Systemrichtlinie bearbeiten -> Active Directory) gesetz werden, der strikte RPC-Einhaltung erzwingt.

 

nun ist wieder alles beim alten.

Dieses Topic kann als gelöst markiert werden.

 

Lieben Gruß,

werth

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...