Jump to content
Sign in to follow this  
iDiddi

Für Intern-Adapter (RRAS) wird DNS-Eintrag erstellt

Recommended Posts

Hallo zusammen,

 

habe ein merkwürdiges Problem an unserem SBS2k3-Server.

 

Dort ist eine Netzwerkkarte aktiv. Diese ist an RRAS (ohne Routing) gebunden, um VPN-Verbindungen zu ermöglichen. Der RAS-Server bezieht seine eigene IP + 9 für die Clients vom lokalen DHCP-Server.

 

LAN-Adapter: 192.168.1.5

RRAS-Intern-Adapter: 192.168.1.60 (DHCP)

 

Geht alles Einwandfrei. Nur registriert sich diese "RAS"-IP des Servers ins DNS, sodass dort zwei Host-Einträge für den Server existieren(?).

 

Server --> HOST --> 192.168.1.60

Server --> HOST --> 192.168.1.5

 

Damit haben die Client-PCs natürlich ein Problem, da diese nun per DNS-Abfrage die falsche IP zurückgeliefert bekommen.

 

Auf einem anderen Server mit identischer RRAS-Konfiguration gibt es keine Probleme. Hab jetzt schon einiges versucht, diesen Eintrag wieder los zu werden, aber der wird immer wieder neu erstellt, sobald sich jemand einwählt und sich der Intern-Adapter eine IP zieht.

 

Kennt Jemand das Problem und/oder weiß Rat?

 

Danke vorab

iDiddi

Share this post


Link to post

Hat sich erledigt.

 

Hab dem RRAS einfach einen statischen IP-Bereich zugewiesen. Komischerweise registriert der den nun nicht mehr im DNS. Manche Sachen muss man nicht verstehn.

 

Gruß

iDiddi

Share this post


Link to post

Hallo IThome,

 

vielen Dank für Deine Antwort. Der KB-Artikel hört sich ganz nach meinem Problem an. Hat auch mit Sicherheit was damit zu tun, allerdings eben nicht ganz:

 

Um dieses Problem zu umgehen, können Sie die RAS-Verbindungen so konfigurieren, dass diese einen statischen Pool von IP-Adressen verwenden, der sich in einem anderen IP-Subnetz als die lokalen Computer befindet

 

So hatte ich es ja intuitiv gemacht, allerdings liegen die IP-Adressen bei mir im gleichen Adressbereich. Dürfte also gar nicht zum Erfolg führen.

 

Ich vermute, der RRAS-Dienst hatte irgendwo in den tiefen der Registrierung einen falschen Wert im Zusammenhang mit dem lokalen DHCP-Server gesetzt. Da ich die IP's nun statisch vergebe, wurde das Problem behoben.

Vielleicht geht's ja jetzt auch, wenn ich wieder auf DHCP umstelle? Muss ich mal testen. Bin aber erst einmal froh, dass es wieder läuft.

 

Danke nochmals für Deine Mühe :)

 

Gruß

iDiddi

Share this post


Link to post

Naja, auch der statische Wert, der sich im gleichen Adressbereich befindet, sollte sich im DNS registrieren. Allerdings wird ein statischer Wert, der sich NICHT im gleichen Adressbereich befindet, ebenfalls im DNS registriert. In diesem Fall macht das aber nichts, da der DNS-Server per Default Subnetmask-Ordering eingeschaltet hat. Diese Funktion liefert alle registrierten Adressen zurück, ordnet sie aber in der Reihenfolge so an, dass die Adressen aus dem anfragenden Subnetz ganz oben stehen.

Befindet sich die RRAS Adresse im gleichen Subnetz (egal ob statisch vergeben oder per DHCP) und ist auch diese Adresse im DNS registriert, dann greift Subnetmask-Ordering nicht, sondern das ebenfalls per Default eingeschaltete DNS Round Robin. Round Robin ordnet auch an, allerdings reihum. So passiert es dann eben, dass mal die LAN-Adresse in der Antwort des DNS-Servers ganz oben steht und mal die RRAS-Adresse (die vom LAN aus nicht erreichbar ist).

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...