Jump to content
Sign in to follow this  
mr.sarge

W2k3 IE8 Hintergrund-Darstellungsproblem

Recommended Posts

Hallo!

 

wir habe auf unseren Terminalservern (Windows 2k3, Citrix PS 4.0) ein seltsames Problem. Und zwar haben wir via GPO einen Desktophintergrund (BMP/gestreckt) definiert: auf den Servern auf denen noch IE6 installiert ist wird der Hintergrund ordnungsgemäß dargestellt, auf den Servern auf denen jedoch IE8 installiert ist wird der Hintergrund als "nebeneinander" angezeigt obwohl mit GPO als gestreckt definiert!?

In diversen Foren wird berichtet daß seit IE7 Active Desktop nicht mehr unterstützt wird und man diese Option deaktivieren sollte, jedoch habe ich keine Möglichkeit gefunden den Desktop-Hintergrund anderweitig festzulegen. Hat jemand einen Tip oder eine Idee?

 

Vielen Dank im Voraus!

 

mfg

Share this post


Link to post
jedoch habe ich keine Möglichkeit gefunden den Desktop-Hintergrund anderweitig festzulegen. Hat jemand einen Tip oder eine Idee?

 

Eigenes adm schrauben. ;)

 

CLASS MACHINE
CATEGORY "Desktop"
		POLICY "Desktop Wallpaper"
			KEYNAME "Control Panel\Desktop"
			EXPLAIN "!!Wallpaper_Hlp"
			PART " Desktop wallpaper" TEXT END PART
			PART " " EDITTEXT
				KEYNAME "Control Panel\Desktop"
				VALUENAME "Wallpaper"
			END PART ; 
			PART " How to set the wallpaper?" TEXT END PART
			PART " " DROPDOWNLIST
				KEYNAME "Control Panel\Desktop"
				VALUENAME "WallpaperStyle"
				REQUIRED
				ITEMLIST
					NAME "Centered"	VALUE "0"
					NAME "Stretched"	VALUE "2"
					NAME "Tiled"	VALUE "1"
				END ITEMLIST
			END PART ; 
		END POLICY ;Desktop Wallpaper

[sTRINGS]
Wallpaper_Hlp="This will set the default Desktop Wallpaper. You can enter any .bmp file you want. Example \\servername\sharename\filename.bmp The second option is to set the background picture option to display the wallpaper, you entered in the option above, e.g. fullscreen."

 

Bye

Norbert

Share this post


Link to post

Hallo Norbert,

 

das Template funktioniert leider nicht bzw. wird überhaupt kein Hintergrund angezeigt. Habe darauf hien die Registry-Einstellungen verglichen:

bei deinem Template wird der Hintergrund in folgendem Pfad festgelegt: HKCU\Control Panel\Desktop

 

via Standard-GPO jedoch im folgenden:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

 

zusätzlich muss noch "Active Desktop" aktiviert werden, ansonsten wird auch mit Standard-GPO der Hintergrund nicht angezeigt.

 

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer -> ForceActiveDesktopOn"=dword:00000001

 

mfg,

 

Sarge

Share this post


Link to post

Mein Template funktioniert auf jeden Fall bis Windows 2003. Danach kann sich etwas geändert haben, da müßte man jetzt nachschauen. Es geht aber definitiv ohne Active Desktop.

 

Bye

Norbert

Share this post


Link to post

Wir setzten Windows 2003 SP2 mit Citrix PS 4.0 ein.

Habe Active Desktop komplett deaktiviert und auch versucht bei einem User die Registry-Einstellungen manuell zu setzen. Der Hintergrund wird dann aber überhaupt nicht mehr angezeigt. Vielleicht überschneidet sich noch eine andere Einstellung im GPO oder es hat etwas mit TS zu tun ?

 

mfg,

 

Sarge

Share this post


Link to post

Um das ruaszufinden sollte man einfach mal ein rsop.msc anwerfen. Ansonsten kann es natürlich sein, dass der Hintergrund per ICA/rdp Richtlinie ausgeblendet wird.

 

Bye

Norbert

Share this post


Link to post
Um das ruaszufinden sollte man einfach mal ein rsop.msc anwerfen. Ansonsten kann es natürlich sein, dass der Hintergrund per ICA/rdp Richtlinie ausgeblendet wird.

 

Bye

Norbert

 

Hallo Norbert,

 

du hattest recht, es war tatsächlich noch eine Einstellung bei den ICA-Verbindungen aktiv (disable wallpaper). Jetzt funktioniert sowohl dein Template als auch die Standard-GPO ohne Active Desktop bzw. wird das Hintergrundbild beidesmal richtig angezeigt. Es scheint also etwas mit IE7/8 in Kombination mit Active Desktop zu tun zu haben.

 

Vielen Dank nochmals für deinen Tip!

 

mfg,

 

Sarge

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...