Jump to content
Sign in to follow this  
rhoersch

Explorer Absturz nach CD-Entnahme, wenn Fenster offen

Recommended Posts

Unter Windows XP SP3 habe ich folgendes Problem:

 

Wenn ein Explorerfenster geöffnet ist, das den Inhalt einer eingelegten CD zeigt, und die CD wird herausgenommen, so stürzt der Explorer ab. Bei einem Usb – Stick oder einem ext. Kartenleser passiert das nicht, hier springt der Explorer einfach auf das nächstbeste Laufwerk oder die Systemsteuerung.

 

 

Von diesem Phänomen sind fast sämtliche PCs unsrer Praxis betroffen,lediglich ein neu aufgesetzter PC, der nur mit dem c't – offline-Update aktualisiert wurde, ist nicht betroffen.

 

Im Verdacht standen der Virenscanner (Trend Micro Worry Free Business) sowie Nero, aber der frisch aufgesetzte PC zeigt auch mit Virenscanner den Fehler nicht und PCs ohne Nero haben ihn trotzdem. Das war es also nicht. "Windows Search" ist auch nicht installiert. Auch die Mitgleidschaft in der Domäne ist nicht die Ursache.

 

Das besonders Ärgerliche ist, dass z.B. auch ein offenes Word – Dokument nicht mehr gespeichert werden kann, bloß weil die Kollegin mal eben mit einer CD mit Röntgenbildern kam und man vergessen hat, das Explorerfenster zu schließen, bevor man die CD wieder aus dem Laufwerk genommen hat. Auch ein Neustart des Explorers (mit Prozeß beenden, neuer Task: Explorer) hilft nicht, das ganze System muss neu gestartet werden.

 

Mit verschiedenen Autostart – optionen für die CD (und DVD-) Laufwerke habe ich auch schon experimentiert, nichts hat bislang geholfen. Unser Hardwarehändler kennt das Problem auch und hat es auch noch nicht gelöst…

 

Mit freundlichen Grüßen

Ralph

Share this post


Link to post

Hi.

 

Gibt es dazu Einträge in der Ereignisanzeige oder Texte von irgendwelchen Fehlermeldungen?

Ist der Fehler unabhängig vom Inhalt der CDs?

Da euer Hardware-Distributor das Problem auch kennt, gibt es bei den Rechnern Gemeinsamkeiten in der Hardwareausstattung?

 

Vielleicht liegt der Fehler beim Laufwerkscontroller des Mainboards. Alle Treiber auf den aktuellsten Stand bringen und mal im Forum oder beim Support des jeweiligen Hardwareherstellers anklopfen.

 

Damian

Share this post


Link to post

Kann jetzt natürlich nicht schauen, bin ja zu Hause am WE.

 

Es sind aber recht verschiedene PCs mit verschiedenen Chipsätzen, VIA, SiS und Intel verschiedener Generationen. Ich glaube deshalb nicht an 'ne Hardware – Geschichte.

 

Ralph

Share this post


Link to post

Cool. Problem kenne ich. Das ist ein Bug im Trend Micro AEGES-Modul. Entweder ein Patch vom Hersteller fordern oder das AEGES-Modul über die Konfig (oder irgend ein INI) abschalten. So die Erfahrung mit unserem Trend Micro Office Scan.

Share this post


Link to post

Hallo zusammen,

 

@damian:

 

im Ereignisprotokoll findet sich folgendes:

 

Beim Senden der Benachrichtigung der Zielgerätänderung an Fenster von "C:\WINDOWS\Explorer.EXE" wurde das Zeitlimit überschritten.

 

Ich habe nun mal auf meinem PC (also an meinem Arbeitsplatz) TrendMicro deinstalleirt, und siehe da, der Fehler war weg. Trend Micro wieder installiert, und der Fehler ist wieder da.

 

Was ich aber nicht kapiere, ist, wieso der frisch aufgesetzte PC den Fehler nicht hat, obwohl da auch TrendMicro installiert ist. Vielleicht ist ja bei der Deinstallation doch was übriggeblieben.

 

Ich habe mal in der Ofcscan.ini im TrendMicro – Programmverz.

 

[AEGIS]

Enable=0

PopupAlert=1

PopupsLowRiskMsg=0

 

eingestellt, (Enable stand vorher auf Enable=1)

 

Dann Neustart.

Das hat leider nichts gebracht. Groll und Ärger. (AERGIS ??)

 

@de.le : Wie bis du das Problem denn letzendlich losgeworden?

Share this post


Link to post
Was ich aber nicht kapiere, ist, wieso der frisch aufgesetzte PC den Fehler nicht hat, obwohl da auch TrendMicro installiert ist. Vielleicht ist ja bei der Deinstallation doch was übriggeblieben.

Weil Du sicherlich bis dato kein Update gezogen hattest...

 

[AEGIS]

Enable=0

Das war der von TM empfohlene Workaround, der bei uns sehr wohl funktioniert hat.

 

Wir haben bezüglich des Problems über den Distributor einen Call bei TM eröffnet. Dieser hat uns einen Patch zur Verfügung gestellt. Das Problem ist also dort bereits bekannt und ich kann mir vorstellen, dass es inzwischen ein öffentlich zugängliches Update für betroffene Produkte gibt.

 

Gruß

de.le

Share this post


Link to post

Hallo zusammen,

 

Nachdem TrendMicro als Übeltäter entlarvt war, hab ich dann selber auch einen Call dort aufgemacht und recht schnell Antwort erhalten:

 

 

Fuehren Sie bitte folgende Schritte durch und teilen mir das Ergebnis mit:

 

TmPreFilter - Treiber im MiniFilter-Modus ausführen:

a. Oeffnen Sie den Registrierungseditor.

b. Suchen Sie den folgenden Registrierungsschluessel:

HKLM\SYSTEM\CurrentControlSet\Services\TmPreFilter\Parameters\

EnableMiniFilter(DWORD).

c. Setzen Sie den Wert des Schluessels auf 1.

TmPreFilter wird nach dem Neustart des Computers im MiniFilter-Modus ausgefuehrt.

 

…. Und das hat funktioniert, zumindest erstmal an 2 Clients. Ich schau nachher mal in den neuen PC, was dort in der Registry steht, ob die das jetzt standardmäßig bei der Installation auch so einstellen und dann bei Deinstallation und Wiederinstallation den Schlüssel nicht ändern. Aber ist ja auch egal, Hauptsache Fehler ist WEG!

 

Danke für eure Hilfe.

Ralph

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...