Jump to content

Probleme mit Store


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo an alle,

 

ich stehe hier gerade vor einem kleinen Rätsel, bei dem ich nicht wirklich weiter komme. Um das ganze zu erklären muss ich leider etwas weiter ausholen... also nicht über den folgenden "Roman" wundern :)

 

Wir sind gerade dabei unseren Exchange Server zu virtualisieren. Als Virtualisierungslösung kommt dabei XenServer 5.5 zum Einsatz. Storageseitig läuft das ganze dann auf einem DataCore SanMelody Storage.

Momentan läuft unsere Exchange-Umgebung noch auf einem physikalischen Server mit lokalem Storage. Die Version ist ein Exchange Server 2003 Enterprise (Patchstand ist aktuell).

Ich habe nun einen Exchange Server 2007 in die Exchange Organisation aufgenommen. Dieser Server wurde auf der virtuellen Plattform (XenServer, DataCore) installiert. Wenn ich nun einen Test mit dem MS-Tool Load Generator durchführe (Test 24 Stunden, 150 Outlook-Online-User, Heavy Load) kann ich nach dem Abschluss der Tests mit eseutil sehen, dass der Store nicht mehr konsistent ist (CRC-Fehler). Dieses Ergebnis kann ich so oft ich will simulieren. Offensichtlich sollte ich den Fehler also im Storage-Subsystem suchen. Die beiden Hersteller (Citrix & DataCore) konnten jedoch aus extra generierten Logs keine Fehler herauslesen.

Daher habe ich nun auf der virtuellen Plattform eine zweite Testdomäne mit einem eigenen Exchange hochgezogen und die selben Tests durchgeführt.

Zu meiner Verwunderung tritt der Fehler hier nicht auf. Somit kann ich also XenServer und DataCore als Fehlerquelle ausschließen.

 

Daher nun meine Frage. Hat hier jemand eine Idee an welcher Stelle ich bei der Fehlersuche weitermachen kann?

 

Falls Ihr noch Fragen habt, versuche ich diese dann auch etwas kürzer zu beantworten. :)

 

Gruß

Thomas

Link to post
kann ich nach dem Abschluss der Tests mit eseutil sehen, dass der Store nicht mehr konsistent ist (CRC-Fehler).

 

Was genau kannst du denn da sehen?

 

Dieses Ergebnis kann ich so oft ich will simulieren. Offensichtlich sollte ich den Fehler also im Storage-Subsystem suchen. Die beiden Hersteller (Citrix & DataCore) konnten jedoch aus extra generierten Logs keine Fehler herauslesen.

 

Was passiert, wenn du einfach mal die DB löschst und eine neue anlegst? Selbes Verhalten?

 

 

Bye

Norbert

 

PS: Warum jetzt noch Exchange 2007?

Link to post

Hallo Norbert,

 

mit eseutil sehe ich z.b. einen "Bad Checksum Error Count: found (234)".

Im Eventlog bekomme ich dann die Klassiker: ESE-Fehler 474 & 1018.

 

Wenn ich die DB komplett lösche, neu anlege und dann den Test erneut starte, bekomme ich das gleiche Verhalten.

 

Gruß

Thomas

Link to post

Hi Norbert,

 

das witzige ist, dass es dieselbe Plattform (also auch dieselben Server) ist.

Es ist also einfach eine neue Testdomäne auf unserer produktiven Virtualisierungsplattform.

 

Sorry, hatte vorher noch die Frage zu 2007 übersehen.

Dass wir nur auf 2007 gehen hat lizenztechnische Gründe. Man will hier noch nicht das Geld für die 2010er-Client-CALs in die Hand nehmen.

 

Gruß

Thomas

Link to post
  • 3 weeks later...
Hi Norbert,

 

 

Sorry, hatte vorher noch die Frage zu 2007 übersehen.

Dass wir nur auf 2007 gehen hat lizenztechnische Gründe. Man will hier noch nicht das Geld für die 2010er-Client-CALs in die Hand nehmen.

 

Ich habe noch einige Kunden die lieber auf Ex 2007 gehen, da dieses unter Windows 2003 betrieben werden kann um den Invest für Windows 2008 CALs hinauszuzögern.

 

Gruss

Holger

Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...