Jump to content
Sign in to follow this  
kashgar63

2000 Prof.: Systemsteuerung -> Software -> keine Einträge ?

Recommended Posts

Hallo,

 

unter Systemsteuerung -> Software (2000 Prof.) sind bei mir keinerlei Einträge zu sehen, hat jemand eine Idee wie man das "reparieren" kann?

 

Vielen Dank

 

kashgar63

Share this post


Link to post

Habe was in meiner privaten Knowledge-Base gefunden, Grüße Olaf:

 

 

This is cover in Microsoft Knowledge Base Article Q266668

 

------------------------------------------------------------------------------------------------------------------------------------

Fix a corrupt Add/Remove Programs panel

 

The Add/Remove Programs Panel in Windows 2000 depends on a number of components and Registry entries to display correctly. Some programs, when installed or removed, may damage these components and cause the Add/Remove Programs Panel to display incorrectly or not at all.

Here are some of the errors that may appear if the panel is damaged:

 

An unexpected error occurred. Class not registered

res://appwiz.cpl/listbox.htc

Line:225

 

Object doesn't support this property or method res://appwiz.cpl/default.hta

Line: 75

 

If you see either of these errors, chances are the problem involves the APPWIZ.CPL component, which is invoked by the panel. If this component is damaged or missing, you will get the above error, but what's more likely is that it's simply become unregistered. To fix this, fire up a command prompt by typing CMD, and at the command prompt type REGSVR32 APPWIZ.CPL.

 

If this doesn't work, check to see if the APPWIZ.CPL component is missing. If it is, try running SFC (System File Checker) with the /SCANNOW option (i.e., type SFC /SCANNOW). You may be asked to provide the Windows 2000 CD-ROM.

 

 

1 * [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}] "ADODB.Recordset"

 

2 * [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32] "C:\Program Files\Common Files\System\ado\msado15.dll"

 

3 * [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\InprocServer32] "ThreadingModel"="Apartment"

 

4 * [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\ProgID] "ADODB.Recordset.2.5"

 

5 * [HKEY_CLASSES_ROOT\CLSID\{00000535-0000-0010-8000-00AA006D2EA4}\VersionIndependentProgID] "ADODB.Recordset"

 

6 * HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29} "Microsoft OLE DB Row Position Library"

 

7 * HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\InprocServer32 "C:\Program Files\Common Files\System\Ole DB\oledb32.dll" "ThreadingModel"="Both"

 

8 * HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\ProgID "RowPosition.RowPosition.1"

 

9 * HKEY_CLASSES_ROOT\CLSID\{2048EEE6-7FA2-11D0-9E6A-00A0C9138C29}\VersionIndependentProgID "RowPosition.RowPosition"

 

10 * [HKEY_CLASSES_ROOT\CLSID\{352EC2B7-8B9A-11D1-B8AE-006008059382}\InProcServer32] "%SystemRoot%\System32\appwiz.cpl"

 

 

 

 

If this also doesn't work, you can run an in-place upgrade from the Windows 2000 CD-ROM -- insert the CD-ROM, and select "Upgrade to Windows 2000."

------------------------------------------------------------------------------------------------------------------------------------

Share this post


Link to post

Hallo,

 

Danke erst mal für eure Antworten.

 

- Systemsteuerung -> Software über den Explorer anwählen bringt (natürlich) auch nichts

 

- die Liste auf der linken Seite ist auch nicht zu sehen (also nix mit Windowskomponenten hinzufügen/entfernen, nur der graue Hintergrund), oben steht nur Text (Programme hinzufügen/entfernen ...), in dem Zusammenhang, womit die setupapi.dll austauschen?

 

Bevor ich die anderen Sachen ausprobiere mache ich erstmal ein Image, kann ein paar Tage dauern bis das möglich ist (Arbeitsplatzrechner), will nicht noch mehr zerschiessen ;-)

- die appwiz.cpl ist immerhin vorhanden

 

Melde mich wieder, wenn es läuft (oder auch nicht läuft)

 

Gruss

 

kashgar63

Share this post


Link to post

Hallo kashgar63,

 

die setupapi.dll ist bei deinem System u.U. kaputt.

Nimm einfach eine setupapi.dll von einem funktionierenden

System!!!! auf gleiches SP achten.

 

grüße

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...