Jump to content
Sign in to follow this  
Kr99

DNS Server macht Probleme bei W2k

Recommended Posts

HI Leutz,

 

folgendes Problem:

 

Habe 1 W2k AD Server nun will ich einen 2. AD Server als Backup integrieren. Wenn ich "dcpromo" starte und die Daten der Domaine eingebe kommt folgende meldung beim Backup-Server.

 

Assistent zum Installieren von Active Directory

 

Auf die Liste der Domänen in der Gesamtstruktur konnte nicht zugegriffen werden. Der Fehler wurde eventuell durch ein DNS-Lookupproblem verursacht.......

 

Im Event Log der 1. AD Server finde ich auch ganz komische Einträge!

 

Die Registrierung für den DNS-Eintrag "1c59a48b-f905-45af-992d-88d793c696a7._msdcs.xxx.xxxxxxxx.xxx. 600 IN CNAME server1.xxx.xxxxxxxx.xxx." ist fehlgeschlagen. Fehler:

Die DNS-RR-Menge, die nicht vorhanden sein sollte, wurde gefunden.

 

oder

 

Die Registrierung für den DNS-Eintrag "_ldap._tcp.lan.omega-force.de. 600 IN SRV 0 100 389 server1.xxx.xxxxxxxx.xxx." ist fehlgeschlagen. Fehler:

Das Format wurde vom DNS-Server nicht erkannt.

 

ich denke mal das es daran liegt das der 2. Server sich nicht als Secondärer Server beim ersten Server anmelden kann!

 

Oder was meint ihr?

Share this post


Link to post

Hallo,

 

das einzige Problem das ich in diesem Fall mal hatte war das ich dem Server keine fixe IP gegeben habe. Alle IP einstellungen prüfen.

 

Oder die Zonen prüfen ob sie eingerichtet sind.

 

Gruß Noris

Share this post


Link to post

HI

 

also laut der MS Anleitung soll ich den "Delete the MX record or change the record from a wildcard character to a specific mail host or domain. " löschen aber wie bekomme ich raus welcher das ist?

 

Oder muss ich eventuell die gesamte Zone manuell wieder aufbauen?? Wird dadurch nicht das AD beschädigt wenn ich die Domaine aus dem DNS lösche?

 

IP-Einstellungen sind in Ordnung.

Share this post


Link to post

Das wäre eine Lösungsmöglichkeit, wenn es dieser Fehler überhaupt ist. Hast du denn einen MX-Eintrag inder Zone? Dazu musst du in der DNS-Verwaltung in deiner Zone nachschauen, ob da ein Eintrag vom Typ MX drin steht (im Menü erweiterte Ansicht anschalten).

 

Man kann auch in einer Domäne einen DNS plattmachen und neu einrichten. Wenn netzwerktechnisch und sonst auf dem DC alles läuft stellt das kein Problem dar.

 

grizzly999

Share this post


Link to post

Habe mal den DNS-Stamm durchsucht, habe aber keinen MX Typ gefunden.

 

Das heist dan wohl das ich den Stamm neu anlegen werde.

 

Oder weis jemand noch eine andere Lösung zu dem Problem?

 

mfg

 

KR99

Share this post


Link to post

SO habe nun mal das gemacht das im anderen Thread gestanden hat.

 

Habe den Server darauf hin 2x durchbooten lassen nun sind alle Fehlermeldungen ausser einer sind verschwunden!

 

Ereignistyp: Fehler

Ereignisquelle: NETLOGON

Ereigniskategorie: Keine

Ereigniskennung: 5774

Datum: 03.10.2003

Zeit: 14:09:54

Benutzer: Nicht zutreffend

Computer: SERVER1

Beschreibung:

Die Registrierung für den DNS-Eintrag "xxx.xxxxxxx.de. 600 IN A 10.67.198.65" ist fehlgeschlagen. Fehler:

Das Format wurde vom DNS-Server nicht erkannt.

Daten:

0000: 29 23 00 00 )#..

 

Ich kann wegen dieser Fehlermeldung den 2. AD Backup Server immer noch nicht aufnehmen. Ist wieder der gleihe Fehler wie oben bei "Assistent zur Installation des Active Directory"

 

Hat jemand noch ne Idee wie ich den Fehler eleminieren kann?

 

thx

 

Kr99

Share this post


Link to post

Der Fehler könnte gemäß KB-Artikel Q259277 daher rühren, dass der Netlogon-Dienst vor dem DNS-Dienst startet. Führe nach entsprechender Sicherung des Registry-Keys mal die dort beschriebene Methode aus:

Konfigurieren Sie den Netlogon-Dienst so, dass er vom DNS-Dienst abhängig ist. Dadurch wird der Netlogon-Dienst erst nach dem DNS-Dienst gestartet. Gehen Sie hierzu folgendermaßen vor: Führen Sie REGEDT32 aus, und gehen Sie zu:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon

 

Doppelklicken Sie im rechten Fenster auf den Wert DependOnService, und fügen Sie zur nächsten verfügbaren leeren Zeile DNS hinzu. Klicken Sie auf OK, und beenden Sie den Registrierungseditor.

 

Eigentlich müsste der Netlogon Dienst es dann im 5-Minuten Abstand weiter versuchen und nachher die Einträge registrieren.

 

Sind denn die Einträge für die Services drin (_msdcs, _tcp, _udp; _sites) und wenn ja ist da dann der DC mit seinem vollen Namen eingetragen, teilweise muss man da einige Stufen runter navigieren?

 

Ist der SOA Eintrag vorhanden und i.o.?

Ist der NS-Eintrag und der A-Eintrag des DC vorhanden?

 

grizzly999

Share this post


Link to post

Grosses THX. Ich konnte soeben des 2. AD Server einbinden.

 

Aber nun gibt es ein zweites Problem.

 

Die Server Replizieren sich nicht! Sprich im EventLog gibt es ne menge Fehlermeldungen.

 

Hier einige davon:

 

Ereignistyp: Warnung

Ereignisquelle: NTDS KCC

Ereigniskategorie: (1)

Ereigniskennung: 1265

Datum: 03.10.2003

Zeit: 19:31:43

Benutzer: Nicht zutreffend

Computer: SERVER1

Beschreibung:

Der Versuch, eine Replikationsverknüpfung mit den Parametern

 

Partition: CN=Schema,CN=Configuration,DC=lan,DC=Domaine,DC=de

Quell-DSA-DN: CN=NTDS Settings,CN=SERVER1,CN=Servers,CN=Standardname-des-ersten-Standorts,CN=Sites,CN=Configuration,DC=lan,DC=Domaine,DC=de

Quell-DSA-Adresse: 1609e073-fd2b-4a08-be1b-5c0011f21d63._msdcs.lan.domaine.de

Intersite Transport (falls vorhanden):

 

ist mit folgendem Status fehlgeschlagen:

 

In der Endpunktzuordnung sind keine weiteren Endpunkte verfügbar.

 

Die Daten befinden sich im Statuscode. Der Vorgang wird wiederholt.

Daten:

0000: d9 06 00 00 Ù...

 

oder dieser:

 

Ereignistyp: Warnung

Ereignisquelle: NTDS Replication

Ereigniskategorie: (5)

Ereigniskennung: 1586

Datum: 03.10.2003

Zeit: 19:27:47

Benutzer: Jeder

Computer: SERVER2

Beschreibung:

Der Prüfpunktvorgang mit dem primären Domänencontroller wurde nicht einwandfrei durchgeführt. Der Prüfpunktvorgang wird in vier Stunden erneut durchgeführt. Eine volle Synchronisation der Sicherheitsdatenbank mit Windows NT 3.5x/4.0-Domänencontrollern kann stattfinden, wenn dieser Computer zum primären Domänencontroller heraufgestuft wird, bevor der nächste Prüfpunktvorgang durchgeführt wird. Fehler: Der Namenskontext wird entweder gerade entfernt oder wird nicht vom angegebenen Server repliziert.

 

Ereignistyp: Warnung

Ereignisquelle: NtFrs

Ereigniskategorie: Keine

Ereigniskennung: 13508

Datum: 03.10.2003

Zeit: 19:20:19

Benutzer: Nicht zutreffend

Computer: SERVER2

Beschreibung:

Der Dateireplikationsdienst konnte die Replikation von SERVER1 nach SERVER2 für c:\winnt\sysvol\domain mit DNS-Namen server1.lan.domaine.de nicht aktivieren. Es wird ein neuer Versuch gestartet.

Mögliche Ursachen für diese Warnung sind:

 

[1] Der DNS-Name server1.lan.domaine.de von diesem Computer konnte nicht ausgewertet werden.

[2] Der Dateireplikationsdienst wird auf server1.lan.domaine.de nicht ausgeführt.

[3] Die Topologieinformationen im Active Directory dieses Replikats wurden noch nicht auf allen Domänencontrollern repliziert.

 

Diese Ereignisprotokollmeldung wird einmal pro Verbindung angezeigt. Nachdem der Fehler behoben wurde, wird eine andere Ereignisprotokollmeldung angezeigt, die bestätigt, dass die Verbindung hergestellt wurde.

Daten:

0000: 0d 00 00 00 ....

 

Kann mir hiermit jemand weiterhelfen?

 

mfg

 

Kr99

Share this post


Link to post

Irgendwas ist da oberfaul.

Gehe her und gib auf dem ersten Domänencontroller dcdiag ein, und dasselbe mit netdiag

Ich glaube, dass beim dcdiag einige Fehler zu Tage treten werden.

War schon mal ein anderer DC im Netz?

 

grizzly999

Share this post


Link to post

WO muss ich den diese Befehle eingeben?

 

Im CMD sagt mir das System das er diese Befehle nicht kennt!

 

Es war noch kein anderer AD Server integriert.

 

Irgendwelche Ideen? Wo kann man den an den Replikations-Sachen Änderungen vornehmen? Vielleicht passt da was nicht!

 

mfg

 

Kr99

Share this post


Link to post

Oh, sorry. Du musst von der CD unter \Support\Tools\ die Support-Tools installieren. Ist bei mir schon immer so automatisch, dass ich vergesse, dass diese Tools dort drin sind.

 

grizzly999

Share this post


Link to post

@grizzly999

 

THX THX THX!!!!!

 

Mit den Support Tools konnte ich meinen Fehler finden und dann beseitigen!!!!

 

Fehler: Anscheinend hat der 1. AD Server versucht sich mit seinen Internet Server zu replizieren anstatt des 2. AD Servers. Dann habe ich nochmal alle Server durchgebootet und da schau an es geht,

 

Ist zwar merkwürdig aber nun geht es anscheinend!!!!

 

Nur noch eine kleine Frage!

 

Gibt es ein kleines Programm oder Skript mit dem ich die Replikation manuell immer starten kann. Damit ich keine 15 Minuten warten muss wenn ich mal was auf einem der beiden AD Server geändert habe!

 

mfg

 

KR99

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...