Jump to content
Sign in to follow this  
Alex_bonsai

Windows Server 2008 Failover Cluster keine Freigabe

Recommended Posts

Also ich habe einen Windows Server 2008 Failover Cluster mit 2 Knoten. Auf diesem habe ich einen File Server laufen.

 

Ging auch soweit 2 Monate gut. Wenn ich jedoch jetzt eine Freigabe im Failovercluster erstellen möchte kommt die Fehlermeldung: Ordner konnte nicht ertellt werden, SMB Fehler.

 

Weiterhin ist mir noch aufgefallen, dass beim Anmelden das Netzlaufwerk des Fileservers angeblich nicht verbunden werden kann. Aber man kann im Explorer darauf zugreifen. Ist zwar mit dem roten X gekennzeichnet aber Zugriff möglich.

 

Ebenfalls lässt sich auf dem Knoten 2 auch im Explorer keine Freigabe mehr auswählen. Aber nur auf dem Laufwerk des Fileservers.

 

 

Jemand eine zündende Idee?

 

Danke für eure Hilfe.

Share this post


Link to post

Hallo und willkommen an Board erstmal

 

Kannst du bitte mal den genauen Text der Fehlermeldung posten? Damit kann man dann bei der Recherche etwas mehr anfangen.

 

Weiterhin ist mir noch aufgefallen, dass beim Anmelden das Netzlaufwerk des Fileservers angeblich nicht verbunden werden kann.

Wo meldest du dich an? Welche Netzlaufwerk des Fileservers wird nicht verbunden?

 

Ebenfalls lässt sich auf dem Knoten 2 auch im Explorer keine Freigabe mehr auswählen. Aber nur auf dem Laufwerk des Fileservers.

Kannst du das mal bitte ein wenig präzisieren? Hier versteh ich dann endgültig nur Bahnhof.

Share this post


Link to post

Hallo,

 

der genaue Wortlaut der Fehlermeldung würde mich auch interessieren...

 

Hast Du den Ordner vor dem Freigeben manuell auf der Disk angelegt?

Danach kannst Du vorgehen wie hier beschrieben:

Windows Server How-To Guides: Teil 4 - Einrichten von Cluster Ressourcen - ServerHowTo.de

Siehe ab "und wir können eine Freigabe hinzufügen".

 

Sind alle Ressourcen online und keine Fehler oder Warnungen als Events im Cluster?

Share this post


Link to post

Hallo, danke für die nette Begrüßung. Ich werde es mal genauer erklären.

 

Knoten 1: Failover Cluster --> Fileserver

 

besitzt dieser Knoten den FS kann ich im Explorer über das Laufwerk

einen Ordner freigeben (welchen ich erst dort erstelle), welcher dann auch im Failover Cluster als

Freigegebener Ordner angezeigt wird. Will ich jedoch eine Freigabe aus

dem Failover Cluster erstellen, kommt die Fehlermeldung: SMB Fehler. (mehr kommt nicht)

Das war es. Keine Meldung im Eventlog oder im Failover Cluster. Was mir

noch aufgefallen ist, dass beim Anlegen der Freigabe im Failover Cluster

keine verfügbarer Speicher angezeigt ist. Er muss aber verfügbar sein,

sonst könnte ich ja nicht über den Explorer auf das Laufwerk zugreifen.

 

Knoten 2: wenn er der Besitzer ist, kann ich nicht einmal im Explorer auf dem

Laufwerk einen Ordner freigeben. Da gibts den Reiter gar nicht.

Berechtigungen hab ich gecheckt. Genau wie Knoten 1.

 

Das im Cluster freigegebene Laufwerk ist eine DDG (Symantec Storage Foundation). Diese ist dem FS zugewiesen. Und als freigegebens Laufwerk auf den Knoten zu sehen. Der Knoten der den FS besitzt verbindet beim Anmelden dieses Laufwerk.

 

Hoffe es ist etwas genauer erklärt.

 

Danke

Share this post


Link to post
Will ich jedoch eine Freigabe aus

dem Failover Cluster erstellen, kommt die Fehlermeldung: SMB Fehler. (mehr kommt nicht)

Hast Du davon einen Screenshot?
Das im Cluster freigegebene Laufwerk ist eine DDG (Symantec Storage Foundation).
Benutzt Du das Veritas File System und den Veritas Volume Manager?

Share this post


Link to post

Hast Du noch ein Volume, daß nicht vom Symantec (ehemals Veritas) Volume Manager verwaltet wird?

Lege bitte Freigaben im Cluster nicht über den Explorer sondern über die Failover Cluster Management Konsole an (per Wizard).

Aufruf des Wizards: http://www.serverhowto.de/uploads/pics/fileserver9.png

Doku: http://www.serverhowto.de/Teil-4-Einrichten-von-Cluster-Ressourcen.511.0.html

 

Kannst Du aktuell einen Validate auf beide Knoten laufen lassen? Wie sieht das Ergebnis aus?

Share this post


Link to post

Ja ich habe noch andere Volumes. Da kann ich ja Freigaben erstellen. Nur auf dem Laufwerk des FS nicht.

 

Ich habe die Freigaben bei der Installation über den Failover Cluster angelegt. Da ging es ja noch. Aber jetzt nicht mehr --> SMB Fehler. Deswegen probierte ich es über den Explorer. wo es ja auf dem Knoten 1 geht und auf dem Knoten 2 nicht.

Share this post


Link to post

Also kommen die Probleme nur in Zusammenhang mit Symantec Volumes?

Ich spreche nicht von lokalen Volumes, sondern von Shared Volumes, die Windows Basic Volumes sind (ohne Symantec).

 

Nochmal: Kannst Du aktuell einen Validate auf beide Knoten laufen lassen? Wie sieht das Ergebnis aus?

Share this post


Link to post

Das ist schon mal positiv.

 

Wie sieht es damit aus?

Also kommen die Probleme nur in Zusammenhang mit Symantec Volumes?

Ich spreche nicht von lokalen Volumes, sondern von Shared Volumes, die Windows Basic Volumes sind (ohne Symantec).

Ein Test ohne die Symantec Software wäre interessant, um diese als Fehlerquelle einzugrenzen oder auszuschließen...

Share this post


Link to post

Was meinst Du damit? Sprichst Du von lokalen Freigaben auf den Nodes oder von anderen Single Servern?

 

Hast Du Dir das HowTo auf ServerHowTo.de mal zu Gemüte geführt?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...