Jump to content
Sign in to follow this  
rep

Grundsätzliche Fragen 2xDC 1xEX2K3

Recommended Posts

Hallo Leute,

 

ich lese ab und zu hier mit, das eine oder andere kann man echt gut gebrauchen, dafür schon mal danke. Nun habe ich aber eine Frage, die ich, wegen ungenügender Erfahrung einfach mal im Konkreten Beispiel stellen muss.

 

Wir haben ein Testnetz zusammengestellt, und haben dort 4x W2K3-R2 Standard installiert. Dann einen zum DC gemacht (SRV1), logischerweise mit allen Rollen. Dann haben wir einen zweiten zum zusätzlichen DC gemacht (SRV2) und haben ein bisschen "gespielt". Viel war es nicht daher mal in Anführungsstrichen.

 

SRV2 ist dann zum zusätzlicher DNS geworden und zusätzlicher GC, später dann noch zum zusätzlichen WINS, nachdem der dann auf SRV1 lief. Einstellungen für die jeweiliegn Netzkarten:

 

DNS1 - SRV1

DNS2 - SRV2

WINS1 - SRV1

WINS2 - SRV2

 

Alle in einem Subnetz mit Router über das Internet verbunden. Alle hatten alle Updates von Microsoft. Das schien laut Funktion und Ereignisprotokoll auch sauber zu laufen. Dann haben wir ganz nach MS Empfehlung auf dem SRV3 (Mitgliedserver) einen Exchnage 2003 Standard installiert, bzw. Installieren wollen. Die Installation dauerte, da es nicht die performanteste Hardware war haben wir uns nichts gedacht. Nachher gingen wir davon aus das es laut Ereignislog schon da Probleme gab.

 

- Installation (IIS, NNTP, SMTP, ASP.NET etc...)

- /forstprep

- /domprep

- Setup

 

So steht es auch in meinen Büchern und in diversen Tutorials. Der Server hat nie wirklich gelaufen, immer Fehler ohne Ende, dcdiag, netdiag und dnslint laufen und liefen immer ohne Probleme... Replikationsprobleme laut replmon nicht vorhanden, Exchange Gruppen vorhanden mit Computerkonto in der Gruppe.

 

Auf dem SRV3 (EX) habe ich dann von der CD das "policytest" laufen lassen, da sagte er mir das auch den beiden DCs die Rechte nicht gefunden wurden, warum auch immer.

Wir haben dann mehrfach neuinstalliert, /desasterrecovery und auch nen paar andere Dinge.

 

Nun habe ich von jemanden gehört das "forestprep" auf dem Infraststrukturmaster (bei mir DC1 alias SRV1) auszuführen ist, und "domainprep" auf allen Domain Controllern (bei mir DC1+DC2 alias SRV1+SRV2). Ist das korrekt?

Muss auf dem Exchange selbst auch das gemacht werden, in welcher Reihenfolge, warum hat der Domain Admin auf dem SRV3 nicht die Rechte das zu machen und repliziert alle Änderungen korrekt, so das man das nicht auf den DCs machen muss?

 

Da wir nun alles neu gemacht haben, und ich vermeiden will, das ich noch mehr Zeit investiere wollte ich vorab bevor wir die Domain aufbauen dsa Thema hier mal diskutieren.

 

Kurzversion: Was muss man bei der installation eines Exchange 2003 auf einem Mitfliedserver in welcher Reihenfolge auf welchem PC genau machen?

 

Ich danke euch für Eure Mithilfe... Thx.

Share this post


Link to post
Nachher gingen wir davon aus das es laut Ereignislog schon da Probleme gab.

 

Was für Probleme?

 

Auf dem SRV3 (EX) habe ich dann von der CD das "policytest" laufen lassen, da sagte er mir das auch den beiden DCs die Rechte nicht gefunden wurden, warum auch immer.

Wir haben dann mehrfach neuinstalliert, /desasterrecovery und auch nen paar andere Dinge.

 

Was für "Rechte"? Was für "andere Dinge"?

 

Ist die Hardware von SRV3 in Ordnung? Ist das "richtige" Hardware? Kaputtes non-ECC memory kann sonst solche interessanten Effekte hervorrufen.

 

Nun habe ich von jemanden gehört das "forestprep" auf dem Infraststrukturmaster (bei mir DC1 alias SRV1) auszuführen ist, und "domainprep" auf allen Domain Controllern (bei mir DC1+DC2 alias SRV1+SRV2). Ist das korrekt?

 

Forestprep aktualisiert das Schema - das sollte auf dem Schemamaster der Forest-Root Domain ausgeführt werden (muss aber nicht)- in eurem Fall wahrscheinlich auf SRV1, wenn nicht spezifisch geändert wurde. Domainprep muss in jeder Domain des Forests die Exchange hosten soll ausgeführt werden - also entweder auf SRV1 oder auf SRV2.

 

Forestprep and Domainprep Explained in Detail

 

Muss auf dem Exchange selbst auch das gemacht werden, in welcher Reihenfolge, warum hat der Domain Admin auf dem SRV3 nicht die Rechte das zu machen und repliziert alle Änderungen korrekt, so das man das nicht auf den DCs machen muss?

 

Das läuft eigentlich auch so. Warst du eventuell mit dem lokalen Admin angemeldet?

 

Kurzversion: Was muss man bei der installation eines Exchange 2003 auf einem Mitfliedserver in welcher Reihenfolge auf welchem PC genau machen?

 

Dafür gibts von Microsoft ganz ganz viele Whitepapers. Grundsätzlich gilt: Wenn irgendwas nicht klappt, erstmal herausfinden wieso - und dann nicht Wild in der Gegen rumklicken, sondern gezielt das Problem lösen.

Share this post


Link to post

Ist die Hardware von SRV3 in Ordnung? Ist das "richtige" Hardware? Kaputtes non-ECC memory kann sonst solche interessanten Effekte hervorrufen.

 

Das ist eine Testumgebung, und sind schon etwas ätere Arbeitsplatzrechner, die immer gut gelaufen haben, aber wir haben das selbstverständlich auch im Auge gehabt. Daher kann ich Dir auch nicht mehr sooo genau die Fehler Präsentieren. Wir haben alles neu gemacht, mehrfach, Da immer mehr Fehler kamen, Speichertausch, Netzwerkkabel und BIOS Update hat Besserung gebracht.

 

 

Forestprep aktualisiert das Schema - das sollte auf dem Schemamaster der Forest-Root Domain ausgeführt werden (muss aber nicht)- in eurem Fall wahrscheinlich auf SRV1, wenn nicht spezifisch geändert wurde. Domainprep muss in jeder Domain des Forests die Exchange hosten soll ausgeführt werden - also entweder auf SRV1 oder auf SRV2.

 

Forestprep and Domainprep Explained in Detail

 

Korrekt, SRV1. Was da gemacht wird oder gemacht werden soll ist mir klar, und habe ich auch mehrfach gelesen. Daher ist meine Vermutung, das es am Exchange reichen muss, oder sonst auch nur an einem DC gemacht werden muss (DC pro Domain) wegen der Replikation auch klar bzw. logisch. Nur hatten Wir ja Probleme (welche auch immer) und eine Frage an einen Bekannten ergab dann geschilderte Aussage. Unter anderem auch an jedem DC domainprep machen.

 

 

Das läuft eigentlich auch so. Warst du eventuell mit dem lokalen Admin angemeldet?

 

Hatte ich auch im Kopf, und wäre logisch, aber nein, das war ich nicht. Vor allem konnte man mit ADSI Edit und Co auch schon einige Erweiterungen im Schema sehen auf den DCs.

 

 

Dafür gibts von Microsoft ganz ganz viele Whitepapers.

 

Ja, habe auch viel gelesen, auch wenn ich von Links durch erfahrene Benutzer gerne überschüttet werde. Nur wegen der Äußerung vom Kumpel wollte ich es genau wissen, davon stand nämlich nirgendwo was. Auch nicht das es da gemacht werden kann, und es "eigentlich" am Exchange reichen sollte. Daher meine gezielte Frage.

 

Ich halte fest, es müsste auf dem Mitgliedserver als Domain Admin eigentlich ausreichen forestprep und domainprep auszuführen. Nirgendwo sonst.

 

 

Grundsätzlich gilt: Wenn irgendwas nicht klappt, erstmal herausfinden wieso - und dann nicht Wild in der Gegen rumklicken, sondern gezielt das Problem lösen.

 

Ja, da gebe ich Dir Recht. Ich hatte sehr viel gelesen, und zwecks Erfahrungssammlung und KnowHow Aufbau hatte ich auch erst Reperatur und Google versucht, bevor ich mich für Neuinstallation entschieden habe. Es war mehr als undurchsichtig.

Share this post


Link to post

Als ich dann Deinstalliert hatte, und auf dem SRV4 (weitere Mitgliedsserver) dann Installieren wollte, da sagte mir auch ich bräuchte Rechte vom Exchnage-Gesamtadmin (aus dem Kopf geschrieben, irgendwie sowas wurde gesagt). Da ich als Domainadmin angemeldet war, habe ich das AD zur Verantwortung gezogen und neu installiert. So viel Zeit konnte ich dann auch nicht aufbringen, da wir ja noch was testen wollen.

 

Sonst ist meine Arbeitsweise auch nicht anders, einfach neu machen ohne Gefahren oder Ursache zu kennen geht meistens nur sehr kurz gut. Ich hatte aber auch schon so viel mit WINS und DNS rumgespielt zum schluss, das ich dann lieber noch mal alles neu mache und sehr gut mitschreibe...

 

Wollte halt nur die Aussage vorher noch mal verifiziert wissen. Ich versuche das dann noch mal nur vom Exchange SRV3 aus. Ich bin gespannt. Die Fehlermeldungen die genannt wurden war was von MAD.exe und INETINFO.exe und immer mehr oder weniger Topologieerknennung Fehlgeschlagen.

Ebenfalls hat der policytest.exe nicht gefunden, alles deutete auf AD (DNS) oder rechte Fehler hin, alles was im Netz gefunden wurde war aber korrekt eingestellt... daher meine aktuelle Maßnahme.

 

Wäre leider nicht das erste mal das mir mehrer Probleme auf einmal in den Weg kommen :( Ich denke das kennt der eine oder andere :-)

Share this post


Link to post
Wäre leider nicht das erste mal das mir mehrer Probleme auf einmal in den Weg kommen :( Ich denke das kennt der eine oder andere :-)

 

Das Problem ist halt das es sehr schwer dir irgendwie zuhelfen (wahrscheinlich auch der Grund wieso du den ganzen Tag über keine Antwort bekommen hast...).

 

Die Vorgehensweise die du beschreibst ist GRUNDSAETZLICH richtig, aber es gibt soviele Details die man falsch machen kann, sodass deren erraten ohne detaillierte Fehlermeldungen entweder Glück oder Hellseherei ist.

 

Eigentlich, wenn alles stimmt, dann kann man als Domain- und Enterprise-Admin (z.B. der Builtin-Administrator-Account der Root-Domain) einen Exchange 2003 mit "Weiter, Weiter, Fertigstellen" installieren. Wenn das nicht geht, ist irgendwas kaputt.

 

Aber so wie es aussieht hast du das Problem bereits durch eine Neuinstallation gelöst - klappt denn jetzt alles?

Share this post


Link to post

Hallo,

 

ja das ist mir klar... aber genau das... "ich habe eigentlich alles richtig gemacht" wollte ich wissen. Wir haben gerade aktuell die Server wieder mit allen Updates laufen.

 

Ich muss/will nun aber auf einen Admin warten bevor ich wieder los legen sollte. Wir arbeiten/lernen in der Umgebung zu 2. Dann geht es los mit:

 

- Domaine erstellen

- Mitgliedserver einbinden

- jeweils 2 DC,GC,DNS,WINS erstellen

 

Dann werden wir denke ich nach kontrolle aller Tools von allen Servern aus

 

- dcdiag, netdiag, dnslint

 

Den Exchange installieren. Und zwar genau so wie es beim Setup gesagt wird. Wenn das erledigt ist, SP2 drauf, und alle Microsoft Updates. Dann werden wir sehen ob es läuft ;)

 

Noch eine kleine Frage? Nach jedem Schritt (forestprep und domainprep vom Exchange SRV3 aus) neu starten? oder braucht das nicht? eine Zeit auf Syncronisation der DCs warten, oder braucht das nicht?

 

Danke schon mal für Deine Hilfe.

Share this post


Link to post
Noch eine kleine Frage? Nach jedem Schritt (forestprep und domainprep vom Exchange SRV3 aus) neu starten? oder braucht das nicht? eine Zeit auf Syncronisation der DCs warten, oder braucht das nicht?

 

Neustarts braucht es keine. Die Synchronisation der DCs dürfte sehr schnell gehen, da beide in der selben Site sind.

Share this post


Link to post

Die stehen sogar nebeneinander.... kann man irgendwo sehen oder nachlesen was auf beiden DCs vorhanden sein muss, damit ich sehen kann das es erledigt ist. Oder ein Tool das die Syncronisation komplett von Hand anstöst...

 

Nur zur Sicherheit. Ne kontrolle mit ADSI Edit oder so was?

 

Danke trotzdem schon mal... ich versuche das und wenn wir soweit sind, dann melden wir uns, sonst werden wir hier die Fehler mit euch versuchen zu lösen... dann nehm ich mir die Zeit, denn dann kann man fast auch von einem Grundsätzlichen Fehler bei mir ausgehen...

 

Dank Danke Danke

Share this post


Link to post
Die stehen sogar nebeneinander.... kann man irgendwo sehen oder nachlesen was auf beiden DCs vorhanden sein muss, damit ich sehen kann das es erledigt ist. Oder ein Tool das die Syncronisation komplett von Hand anstöst...

 

repadmin, oder sonst per GUI (AD Sites & Services).

 

Nur zur Sicherheit. Ne kontrolle mit ADSI Edit oder so was?

 

Du kannst dem Exchange-Setup glaub ich sonst auch per Kommandozeile fix einen DC mitgeben.

Share this post


Link to post

Alles klar. Die Tools schau ich mir an, kenn ich noch nicht alle, gibt es sicher bei sysinternals.com.... Da hab ich doch mal wieder was gelernt, ich halte hier auf jeden Fall alle auf dem laufenden...

Share this post


Link to post
Alles klar. Die Tools schau ich mir an, kenn ich noch nicht alle, gibt es sicher bei sysinternals.com.... Da hab ich doch mal wieder was gelernt, ich halte hier auf jeden Fall alle auf dem laufenden...

 

repadmin gehört zu den Support Tools - sind auf der CD bzw. Downloadbar.

Share this post


Link to post

Support Tools und Resource Kit sind Standard auf unseren Testinstallationen. Habe gerade was von Support Tools des Exchange gelesen, da soll polycietest.exe drin sein was checkt pb DSAccess alles finden würde was im DC gehört. Das könnte vor der Installation meine Fragen vielleicht schon beantworten.

 

Schreibe das mal so, damit es auch in Zukunft hier noch zu finden ist :) Support Tools Auch wenn ich noch nicht weiß was es in der Liste ist... ich bleib am Ball...

Share this post


Link to post

Wir haben nun alle Server als Image, nach einer neuen Standalone Installation. Kann also nun "schnell" bei NULL anfangen.

 

Ich habe gerade DHCP installiert und dann mittels dcpromo eine Domain erstellt. Dabei ist DNS installiert worden. Nach dem Autorisieren des DHCP und dem anlegen einer Reverse Zone und das Eintragen der normalen LAN IP-Adresse als Primären DNS Server auf der Netzkarte ist nach einem Reboot eigentlich alles OK. Die Domain steht.

 

Doch was ich sehe, ohen weiter sachen zu machen, ohne einen Mitgliedserver oder sonst was zu haben, ist das ich nun schon folgende Warnung habe:

 

Ereignistyp:	Warnung
Ereignisquelle:	MSDTC
Ereigniskategorie:	SVC
Ereigniskennung:	53258
Datum:		21.11.2008
Zeit:		19:48:51
Benutzer:		Nicht zutreffend
Computer:	BK-LABOR-2
Beschreibung:
MS DTC konnte das Höher-/Tieferstufen eines Domänencontrollers nicht ordnungsgemäß verarbeiten. MS DTC funktioniert weiterhin und verwendet die vorhandenen Sicherheitseinstellungen. Fehler: d:\nt\com\complus\dtc\dtc\adme\uiname.cpp:9351, Pid: 1140
No Callstack,
CmdLine: C:\WINDOWS\system32\msdtc.exe

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter [url=http://go.microsoft.com/fwlink/events.asp]Events and Errors Message Center: Basic Search[/url].
Daten:
0000: 05 00 07 80               ...€    

 

Ereignistyp:	Warnung
Ereignisquelle:	MSDTC
Ereigniskategorie:	SVC
Ereigniskennung:	53258
Datum:		21.11.2008
Zeit:		19:48:51
Benutzer:		Nicht zutreffend
Computer:	BK-LABOR-2
Beschreibung:
MS DTC konnte das Höher-/Tieferstufen eines Domänencontrollers nicht ordnungsgemäß verarbeiten. MS DTC funktioniert weiterhin und verwendet die vorhandenen Sicherheitseinstellungen. Fehler: %1

Weitere Informationen über die Hilfe- und Supportdienste erhalten Sie unter http://go.microsoft.com/fwlink/events.asp.

 

 

Ich warte nun mal, aber es gibt ja keine Syncronisation oder Replikation ;-) Ich warte einfach mal, und wenn es nur auf Antworten hier ist :)

 

 

GRuß

Share this post


Link to post

Verstehe den Text nicht ganz, aber ist schon komisch das man eine so Wichtig erscheindende Meldung ignorieren kann. Wenn Du das sagst... dann mach ich das. Oder kann man die auch ohne weiter Komplikationen "ausschalten"?

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...