Jump to content
Sign in to follow this  
Schurrik

Gruppenrichtlinien können manuell nicht aktualisiert werden

Recommended Posts

Liebe MCSEboard Community,

 

ich habe verschiedene Foren durchforstet und auch einige Beiträge zu Fehlern der Gruppenrichtilinien gefunden, jedoch war mein Problem nicht aufzufinden.

ich habe seit einiger Zeit das Problem, dass ich die Gruppenrichtlinien via gpupdate /force nicht aktualisieren kann.

 

Kurze Info zum Server/Client:

 

Windows Server 2003 R2 Standard Edition SP2 Domain Controller, bei den Clients handelt es sich um XP Pro SP3 Rechner.

 

Auf dem DC habe ich einige Richtlinien erstellt, wie z.B. ein Logonscript zum mappen von Netzlaufwerken und ein weiteres Script zur Druckerinstallation.

Im Grunde funktionieren die Richtlinie, die Scripte werden beim Anmelden an der Domäne verarbeitet.

 

Das Problem was ich habe ich folgendes.

Nehme ich Änderungen an der Richtlinien vor und möchte diese auf den Clients via gpupdate /force aktualisieren, bekomme ich eine Fehlermeldung:

 

Die Aktualisierung der Userrichtlinie wurde in der erwarteten Zeit nicht abgeschlossen. Der Vorgang wird abgebrochen...

Die Aktualisierung der Userrichtlinie wurde abgeschlossen.

Die Aktualisierung der Computerrichtlinie wurde in der erwartetem Zeit nicht abegschlossen. Der Vorgang wird abgebrochen...

Die Aktualisierung der Computerrichtlinie wurde abgeschlossen.

 

 

Führe ich beim Client einen Neustart durch, so werden beim nächsten Anmelden an der Domäne die neuen Änderungen ohne Probleme übernommen.

 

Die Ereignisanzeige weist leider keine Fehlermeldungen auf. Die Befehlsverarbeitung dauert ca. 5 Minuten, bis es zum Abbruch kommt.

 

Falls ihr noch irgendwelche Informationen benötigt, um das Problem weiter einschränken zu können, bzw. die Ursache besser feststellen zu können, gebt einfach bescheid ;-)

Share this post


Link to post
Share on other sites

Hi Schurrik,

 

willkommen im Forum. :)

 

Bist Du Dir sicher, daß es keine Fehlermeldungen in den (Application) Eventlogs der Clients als auch der DCs gibt?

 

Überprüfe bitte einmal mittels GPRESULT oder RSOP.MSC auf den Clients als auch den DCs, ob die folgende Policy unter Umständen gesetzt wurde: Computer Configuration --> Administrative Templates --> System --> Group Policy --> "Turn off background refresh of group policy" --> Enabled.

 

Falls ja, deaktiviere die Einstellung testweise einmal (für die Clients als auch die DCs) und versuche es noch einmal (nach einem Neustart des jeweiligen Clients der DCs, da sonst die Policy ja in Deiner Situation mit "GPUPDATE" nicht greift :D ).

 

Disable background refresh of Group Policy

 

Computer Configuration\Administrative Templates\System\Group Policy

 

Description

 

Prevents Group Policy from being updated while the computer is in use. This policy applies to Group Policies for computers, users, and domain controllers.

 

If you enable this policy, the system waits until the current user logs off the system before updating the computer and user policies.

 

If you disable this policy, updates can be applied while users are working. The frequency of updates is determined by the Group policy refresh interval for computers and Group policy refresh interval for users policies.

 

Unter Umständen verhindert die Einstellung ja auch das manuelle Aktualisieren.

 

Viele Grüße

olc

Share this post


Link to post
Share on other sites

Hallo olc,

 

danke erstmal für deinen Lösungsvorschlag.

Also in den Eventlogs, Client und DC, wird kein Ereignis bezüglich gpupdate angezeigt.

 

Die Einstellung "Disable background refresh of Group Policy" war auf "aktiviert".

Ich habe diese testweise mal auf "deaktiviert" gestellt und den Client und DC mal neu gestartet.

 

Das hat 50% meines Problems gelöst :D

Also die Userrichtlinie wird jetzt via gpupdate /force ohne Fehler ausgeführt.

Bei der Aktualisierung der Computerrichtlinie bekomme ich weiterhin die Fehlermeldung, dass die Aktualisierung der Computerrichtlinie in der erwarteten Zeit nicht abgeschlossen werden konnte.

 

Ich bin ja leider noch ein Neuling auf diesem Gebiet und werde mich mal weiterhin mit den Einstellungen der GPO befassen und ausprobieren, um den Rest des Problems zu lösen.

 

Vielleicht hat ja noch wer einen Vorschlag, was ich machen kann.

 

Gruß

 

Schurrik

Share this post


Link to post
Share on other sites

Die Einstellung "Disable background refresh of Group Policy" war auf "aktiviert".

Ich habe diese testweise mal auf "deaktiviert" gestellt und den Client und DC mal neu gestartet.

 

Was ist denn in dem Zweig noch so konfiguriert.

 

Stell mal "Aktualisierung der Computerrichtlinien durch Benutzer verhindern" auf nicht konfiguriert, bzw. auf deaktiviert für den betreffenden Computer.

 

"Mit dieser Einstellung können Sie steuern, ob ein Benutzer eine Aktualisierung der Computerrichtlinie veranlassen kann.

 

Wenn Sie diese Einstellung aktivieren, können Benutzer keine Aktualisierung der Computerrichtlinie veranlassen. Die Computerrichtlinie wird beim Start oder bei einer offiziellen Richtlinienaktualisierung aktualisiert."

 

HTH

Norbert

Share this post


Link to post
Share on other sites
Stell mal "Aktualisierung der Computerrichtlinien durch Benutzer verhindern" auf nicht konfiguriert, bzw. auf deaktiviert für den betreffenden Computer.

 

Aber diese Einstellung gilt doch nur für Benutzer, die keine Adminrechte haben.

Benutzer mit Adminrechten sind von dieser Einstellung ja nicht betroffen und können die Richtlinien manuell aktualisieren.

 

Also ich habe jetzt mal einen Screenshot von den Konfigurationen, bzw. welche Gruppenrichtlinien aktiviert/deaktiviert sind.

post-50796-13567389610403_thumb.jpg

Share this post


Link to post
Share on other sites
Aber diese Einstellung gilt doch nur für Benutzer, die keine Adminrechte haben.

Benutzer mit Adminrechten sind von dieser Einstellung ja nicht betroffen und können die Richtlinien manuell aktualisieren.

 

Richtig. Aber wer hat hier im Thread gesagt, dass du überall per lokalem Admin angmeldet bist wenn du gpupdate ausführst? :)

 

Also ich habe jetzt mal einen Screenshot von den Konfigurationen, bzw. welche Gruppenrichtlinien aktiviert/deaktiviert sind.

 

File-Upload.net - Ihr kostenloser File Hoster! geht schneller ;)

 

Bye

Norbert

Share this post


Link to post
Share on other sites
Richtig. Aber wer hat hier im Thread gesagt, dass du überall per lokalem Admin angmeldet bist wenn du gpupdate ausführst? :)

 

Hehe das ist richtig :D

 

Aber ich habe das Problem mittlerweile gelöst.

 

Die weitere Einstellung, die das manuelle Aktualisieren der Computerrichtlinien verhinderte, ist "Gruppenrichtlinien-Aktualisierungsintervall für Computer".

Diese habe ich nun auf "deaktiviert" gesetzt und sieh da, gpupdate wird ohne Fehler ausgeführt :D

 

Vielen Dank soweit an alle, die mir geholfen haben.

 

 

Gruß

 

Schurrik

Share this post


Link to post
Share on other sites
Aber ich habe das Problem mittlerweile gelöst.

 

Freut mich. Was mich aber mal interessieren würde:

Wer oder was schraubt an den Default Einstellungen dieser Policies? Bzw. wieso trat dieses Problem bei dir überhaupt auf? :)

 

Bye

Norbert

Share this post


Link to post
Share on other sites
Wer oder was schraubt an den Default Einstellungen dieser Policies? Bzw. wieso trat dieses Problem bei dir überhaupt auf? :)

 

Das ist eine gute Frage, welche ich dir leider nicht beantworten kann.

Ich bin einer von drei Admins bei uns in der Firma, naja eigentlich bin ich noch kein Admin (AZUBI) :D

 

Ich habe diese Aufgabe aufgedrückt bekommen und sollte hierfür eine Lösung finden.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...