Jump to content
Sign in to follow this  
blubberbrause

IIS5.0 - Integrierte Windows Authentifizierung Problem

Recommended Posts

Hi,

 

Ich habe unseren Intranet Webserver auf einer Windows 2000 Maschiene laufen.

 

Alles wird über die Anonyme Anmeldung erledigt. Allerdings habe ich die Anforderung für ein Verzeichnis nur bestimmte Nutzer zuzulassen.

 

Also habe ich diesem Verzeichnis entsprechende NTFS Berechtigungen gegeben, auf dem IIS ein virtuelles Verzeichnis eingerichtet und bei der Authentifizierung gesagt das nur die Integrierte Windows Authentifizierung verwendet werden soll.

 

Allerdings werden dann die Benutzer nochmals nach Benutzernamen und Kennwort gefragt. Das funktioniert zwar, allerdings wäre es unschön dem Vorstand zu erklären das er da nochmals seinen Benutzernamen und Kennwort eintippen muss.

 

Wie kann ich das loswerden und erreichen das der Benutzer automatisch anhand seines Windows Logins an das Verzeichnis kommt ?

 

Achja es ist ein Windows 2k AD. (Es laufen KEINE Zertifikatsdienste)

 

Gruss

 

Blubberbrause

Share this post


Link to post

Wenn der IE auf das Startverzeichnis anonym zugreifen darf, dann wird er auf das tieferliegende Verzeichnis auch erst einmal direkt zugreifen. Dann schickt der IIS eine Fehlermeldung zurück und der IE bietet eine Logonmaske.

 

Insofern müßtest Du schon das Stammverzeichnis für anonymen Zugriff sperren und der Gruppe Benutzer / Jeder Zugriff gewähren. Klar ist, daß die Integrierte Windows-Authentifizierung nur noch mit dem IE als Client geht und daß 'Erweitert - Integrierte Windows-Authentifizierung aktivieren' aktiviert sein muß.

 

Falls dies nicht gelingt und es sich um ein internes Netzwerk ohne Snifferrisiken handelt: Reicht womöglich die Standardauthentifizierung?

 

------------

Gruß, Auer

Share this post


Link to post

Es ist ein virtuelles Verzeichnis das auf ein anderes Verzeichnis im Netzwerk weist.

 

Auch wenn ich direkt den Pfad im Internet Explorer anlinke, dann kommt auch die Authentifizierung.

 

Gruss

 

Blubberbrause

Share this post


Link to post

Ich bin nun einen schritt weiter.

 

Wenn ich auf dem Client den Intranet Server zu den Trusted Sites hinzufüge, dann habe ich ohne Benutzername oder Kennwort zugriff auf den Ordner.

 

nur Leider können dann auch andere Benutzer die KEINE NTFS Berechtigung haben trotzdem das Recht "Verzeichnis durchsuchen" im Internet Explorer.

 

Was läuft da schief ?

Share this post


Link to post

Bei der Definition, was in einer Sicherheitszone alles erlaubt ist, gibt es unter 'Stufe anpassen' den Punkt 'Benutzerauthentifizierung - Anmeldung - Automatische Anmeldung mit aktuellem Benutzernamen ...'. Wenn dieser gewählt ist und der Server zur entsprechenden Zone gehört, handelt der IE mit dem IIS aus, ob er darf.

 

Wählst Du im IE direkt über Netzwerkumgebung den Ordner aus, so umgeht dein IE den IIS, er lädt sich die Dateien so, wie er lokale Dateien lädt.

 

Dürfen alle drauf zugreifen, sind die Berechtigungen für Jeder / Benutzer / Gast oder irgendwelche Standardgruppen zu großzügig eingestellt.

 

------------

Gruß, Auer

Share this post


Link to post

So,

 

Ich hab die Lösung.

 

Es funktioniert wenn das virtuelle Verzeichnis des IIS auf ein lokales Verzeichnis auf dem IIS Server verweist.

 

Allerdings ist mir schleierhaft warum das selbe (mit den selben Berechtigungen) nicht auf einem Netzwerkshare funktioniert.

 

Naja egal, hauptsache es geht.

 

Gruss

 

Blubberbrause

Share this post


Link to post

Soeben habe ich mir das doch noch einmal angesehen und mir bei meinem IIS (XP Prof) unter dem Punkt 'Virtuelles Verzeichnis' bei 'Beim Verbinden mit dieser Ressource soll ...' 'einer Netzwerkfreigabe ...' gewählt. Da gibt es sofort eine Schaltfläche 'Verbinden als', bei der nur ein Benutzername und Kennwort eingegeben werden kann.

 

Das Problem dürfte damit zusammenhängen, daß der IIS-Prozeß unter einem Konto läuft und der Prozeß beim Zugriff auf einen anderen Rechner entweder diese oder irgendeine andere Identität annimmt - und eben nicht mehr die Identität des Benutzers. Wie er dies lokal intern handhabt, so daß bei lokalen Verzeichnissen der Zugriff klappt ... keine Ahnung.

 

------------

Gruß, Auer

Share this post


Link to post

Hallo zusammen

 

Ich habe das gleiche Problem.

 

Wir haben von WinNT4 auf WinXP auf den Clients umgestellt.

Seit dann müssen wir uns bei einer Website immer anmelden.

 

Seit WinXP haben wird die GroupPolicies im Einsatz.

Wenn ich einen User nehme, der keine Policies hat, kommt die Abfrage nicht. Wenn ich einen mit den Policies nehme, dann kommt die Abfrage.

Daher liegt es sicher auch dort. Ich möchte nicht unbedingt an der Serverkonfiguration etwas ändern, sondern an den GPO.

 

Kann mir jemand helfen?

Ich könnte mir vorstellen,dass es unter der Computerkonfiguration/Sicherheitseinstellungen/Lokale Richtlinie/Sicherheitsoptionen

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...