Jump to content
Sign in to follow this  
Tim Toady

Unattended XP über Netzwerk: Treiber werden nicht kopiert

Recommended Posts

Hi zusammen!

 

Da ich die 1. Hürde bei der automatisierten XP-Installation übers Netzwerk genommen habe, war ich schon frohen Mutes es alleine weiter zu schaffen :(

 

Doch schon das nächste Problem:

Ich hab im Unterordner $OE***\$1 das Verzeichnis drivers angelegt und dort entsprechende Unterordner für die Modellreihen (Maximal 8 Buchstaben).

In der unattend.txt steht:

[unattended]

OemPreinstall=Yes

und die Pfade zur den INF-dateien sind auch hinterlegt.

Der PC kopiert aber nicht den drivers-ordner nach c:.

 

Ich hab schon alles Mögliche probiert in Bezug auf Schreibweise und so weiter, aber ich find den Fehler einfach nicht :(

 

Hier mal ein Auszug aus meiner unattend.txt:

[unattended]
   UnattendMode=FullUnattended
   OemSkipEula=Yes
   OemPreinstall=YES
   TargetPath="\WINDOWS"
   UnattendSwitch="yes"
   WaitForReboot="No"
   OemPnPDriversPath="drivers\FS-P300\LAN\"
   NonDriverSigningPolicy=Ignore
   DriverSigningPolicy=Ignore
   FileSystem=ConvertNTFS

 

Noch ne Frage an die Fachleute:

Gibt es einen bestimmten Pfad in dem die unattend.txt und die unattend.udf liegen müssen? Ich würd die beiden Dateien wegen der Pflege gern in ein anderes Verzeichnis legen. Zur Zeit liegen die Dateien im I386-Ordner.

 

Im Internet und hier im Forum hab ich bereits gesucht und Threads dazu gefunden, die genau das gleiche Problem haben, allerdings gab es dazu leider keine Lösung :(

 

Vielen lieben Dank im voraus!

LG TT

Share this post


Link to post
Share on other sites

Wo du die Dateien ablegst, ist reichlich egal. Nur beim Aufruf der Winnt32.exe musst du dann die Pfade zur Inf und zur Udf mitgeben. Dann kann das Setup die auch von woanders her ziehen.

 

Für OemPNPDriversPath probier es mal mit der folgenden Zeile:


OemPnPDriversPath=drivers\FS-P300\LAN
[/Code]

 

Allgemein kannst du die " weglassen... Hab grade mal in meiner INF geschaut, da sind auch keine drin ausser bei FullName und OrgName

Share this post


Link to post
Share on other sites

Hm.... also sagen wir mal so: ich bau meine Pfade immer so in etwa auf:

$OE***\$1\drv\1\1

$OE***\$1\drv\1\2

$OE***\$1\drv\1\3

 

Unter Umständen gibts schon ein Problem mit dem Pfad. Versuch den mal zusammenzukürzen, sprich kürzere Pfadnamen zu verwenden...

Share this post


Link to post
Share on other sites

Hi phoenixcp!

 

Ich glaub ich habs:

Wenn der $OE***-Ordner im Unterordner I386 liegt, werden die Treiber kopiert und er nimmt sie auch. Hab ich das überlesen oder steht das irgendwo? In de CHM-Files konnte ich es nicht finden.

 

Aber: Wahrscheinlich mein Fehler!

 

Naja, vielleicht hilfts Anderen ;)

 

LG TT

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...