Jump to content
Sign in to follow this  
StefanB

Netzlaufwerk zugriff verweigert

Recommended Posts

Hallo,

ich habe einen Windows 2000Server, auf dem Verzeichnisse freigegeben sind. Jetzt habe ich das Problem dass, wenn ich diese Verzeichnisse unter Windows98 verbinde, bei manchen Clients nach sporadischen Abständen das Laufwerk den Zugriff verweigern. Wenn man sich dann abmeldet u. neu anmeldet funktioniert es. Das passiert ca. 1-2 mal täglich.

Wir haben auch noch Win2k und WinXP, dort gibt es keine Probleme.

 

Vielen Dank schon mal für die Hilfe.

Share this post


Link to post

Hi,

das sind etwas wenig Informationen. Welche Fehlermeldung kommt, "Zugriff verweigert" oder "Host nicht erreichbar" (oder sowas in der Art) ?

Share this post


Link to post

Hallo,

also es kommt Zugriff verweigert der Benutzer hat keine Rechte.

Wenn sich aber der Benutzer neu anmeldet funktioniert es wieder.

Wenn sich der Benutzer das zweite mal anmeldet dann dauert es länger bis der Fehler auftritt (Nach aussage des Benutzers).

Meistens dauert es ca. 2-3h bis dieses Problem auftritt.

Vielen Dank schon mal für die Hilfe!

 

Gruß

Stefan

Share this post


Link to post

hallo,

 

ich bin administrator eines kleineren firmennetzwerkes und ich habe genau dasselbe problem. bei allen win98 clients taucht regelmäßig aber in unterschiedlichen zeitabständen die fehlermeldung "zugriff verweigert" (nicht Host nicht erreichbar) auf.

 

bei den winxp rechnern tritt das problem nicht auf, durch einen neustart lässt es sich beheben, neuanmeldung funktioniert bei mir nicht.

 

wer kann helfen?

Share this post


Link to post

hat denn KEINER eine idee oder zumindest einen link zu nem andren thread in irgendeinem forum?

 

es kann doch nicht sein, dass nur 2 leute dieses problem haben...

 

 

vielen dank

florian

Share this post


Link to post

Hallo Florian, ein bischen mehr Geduld musst Du schon mitbringen.

 

Vielleicht weiss ja jetzt einer etwas zu dem Thema.

Share this post


Link to post

Oh, da hatte ich damals die Antwort von StefanB übersehen ! :(

@fl0': Eine Lösung innerhalb von nicht mal 2 Stunden kannst Du in einem Board wirklich nicht erwarten.

Du schreibst, eine Neuanmeldung funktioniert bei Dir nicht ?

Heißt das, der Fehler, der dann kommt, ist, es ist kein DomainController verfügbar ?

 

Dazu müßtest Du jetzt noch schreiben, ob Ihr in dem Netzwerk einen WinsServer betreibt.

 

Meine Vermutung:

Ihr arbeitet ohne WinsServer, Deine Win98-Clients befragen dann immer den Masterbrowser nach dem DomainController.

Dieser Masterbrowser wird ständig neu ausgehandelt.

Wenn nach ein paar Stunden ein PC den Masterbrowser macht, der diese Info nicht korrekt weitergibt, kann sich der Win98-Client nicht mehr authorisieren, weil er keinen DC mehr kennt.

 

Abhilfe zu diesem Sympthom ist ein Eintrag des DC in der lmhosts. auf dem Client.

Die eigentliche Fehlersuche ist allerdings schwieriger, da Win98 nicht sehr gesprächig ist.

 

Also, gib mal bitte ein paar mehr Infos zu Deinem Netzwerk !

Share this post


Link to post

Ok, erstmal vielen Dank fuer die Antworten und Sorry, dass ich so ungeduldig war, kommt nicht wieder vor. :rolleyes:

 

Dann muss ich sagen, dass Administrator meinen Job wohl nicht wirklich beschreibt, ich habe zwar generell ein wenig Ahnung, aber wohl nicht so speziell wie hier.

 

@ zuschauer: zu dem Netzwerk: Wir haben einen Server mit win2k-server. Die Clients melden sich auf einer Domäne (ist das ein DomainController?) an, dann werden mit Hilfe eines VBS-Scripts Netzlaufwerke für verschiedene, freigegebene Ordner auf dem Server eingerichtet.

Ich weiss allerdings nicht, ob wir einen WinsServer betreiben, wo kann ich das nachgucken?

 

In der Tat kann ich das Problem nicht durch eine Ab- und Neuanmeldung beheben (nachdem zum ersten Mal die "Zugriff verweigert" - Meldung kommt), dann kann ich mich gar nicht mehr anmelden, ich meine die Fehlermeldung sagt, dass die Domäne nicht mehr gefunden werden kann.

 

Wie kann ich denn einen Eintrag des DC in der Imhosts vornehmen?

 

Ich hoffe, ich weiss nicht zu wenig.

 

gruß

florian

Share this post


Link to post

Hi fl0' !

 

Wenn die Clients sich an einer Domäne anmelden, dann an einem DomainController - kommt so hin.

 

Ob die Win98-Clients einen WinsServer kennen kriegst Du ganz einfach raus: Du gibst in einem DOS-Fenster ipconfig /all ein.

Wenn dort ein Wins-Server gelistet wird, gehen die zumindest davon aus, daß bei der IP einer läuft. Dann kannst Du an dem betreffenden Server mit dieser IP checken, ob dem so ist.

 

Zur lmhosts: Im Windows-Verzeichnis (bei Win98) existiert immer eine lmhosts.sam (sam von sample - Beispiel). Diese Datei mußt Du kopieren zu lmhostst. (ohne eine Endung).

Die lmhostst. editierst Du mit Notepad oder einem anderen Editor und machst folgenden Eintrag (xxx.xxx.xxx.xxx bedeutet die IP des Domaincontrollers):

 

xxx.xxx.xxx.xxx Netbiosname_des_DC #PRE #DOM:domainname

 

Netbios_name_des_DC ist der Name des DomainControllers

bei #DOM:domainname muß als "domainname" der Name Deiner Domäne rein.

 

Ich weiß jetzt nicht mehr, ob Du bei Win98-Clients sagen mußt, daß sie diese lmhosts. mit einbeziehen müssen.

Wenn es so einen Punkt geben sollte (weiß ich nicht mehr), dann findest Du den in den Netzwerkeigenschaften->TCP/IP->Wins

Da könnte dann eventuelle sowas stehen, wie "lmhosts. mit einbeziehen".

 

Dein prinzipielles Problem scheint zu sein, daß ein Server oder Client den "Chef" macht, der dafür nicht geeignet ist. Abhilfe dafür wäre ein WinsServer auf Deinem Server. Dieser WinsServer muß auf den Clients dann auch eingetragen werden. Das wär die optimale Lösung für Dein Problem.

Wenn Du Fragen hast, frag. Wir kriegen das Ding gemeinsam schon gebacken ! ;)

Share this post


Link to post

@zuschauer: Wenn ich auf einem der Win98 Clients ipconfig /all eingebe, werden 2 Wins-Server gelistet, jedoch keine IP. Wo sehe ich denn die Adresse meines Domain-Controllers? Oder hat der keine IP-Adresse?

 

--------------------------------------------------

IPconfig Liste eines Win98-Clients:

 

Hostname . . . . . . . . . : xxx

DNS-Server . . . . . . . . : xxx

Knotentyp . . . . . . . . . : Gemischt

NetBIOS-Bereichs-ID . . . . :

IP-Routing aktiviert. . . . : Nein

WINS-Proxy aktiviert. . . . : Nein

NetBIOS-Auflösung mit DNS . : Nein

 

0 Ethernet Adapter :

 

Beschreibung. . . . . . . . : Intel 82557-based Integrated Fast Ethernet

 

Physische Adresse . . . . . : xxx

DHCP aktiviert. . . . . . . : Ja

IP-Adresse. . . . . . . . . : xxx

Subnet Mask . . . . . . . . : 255.255.255.0

Standard-Gateway . . . . . . : xxx

DHCP-Server . . . . . . . . : xxx

Erster WINS-Server . . . . :

Zweiter WINS-Server . . . :

Gültig seit. . . . . . . : 13.11.03 08:20:56

Gültig bis . . . . . . . : 20.11.03 08:20:56

 

--------------------------------------------------

 

Es scheint mir also, dass du Recht hast & ich keinen WINS-Server am laufen habe.

Wie kann ich das denn jetzt ändern, also einen WINS-Server installieren?

Share this post


Link to post

Hi !

Zumindest ist am Win98 kein WinsServer eingetragen - also versucht der Client per Broadcast seinen DomainController zu finden und fragt dabei den Masterbrowser, den er momentan kennt. Genau der macht aber Probleme !

Wie Du an einem Win98 den benutzten DC rausbekommst - gute Frage, weiß ich keine Antwort mit reinen Boardmitteln !

Bei NT4/w2k/XP kannst Du das in der DOS-Box mit dem Befehl set abfragen. Unter logonserver steht dann der DC, der beim Login benutzt wurde.

Wie Du einen WinsServer installierst (ich geh von einem w2k-Server aus, Du hast das aber noch nicht geschrieben !):

 

Du gehst am DomainController in der Systemsteuerung auf Software-Installierte Windowskomponenten, dort auf Netzwerkdienste und wählst den WINSServer aus.

Damit wird er auf dem DC installiert.

Als 2. Schritt trägst Du diesen WinsServer auf allen Clients in Deinem Netzwerk ein (in den Netzwerkeigenschaften unter TCP/IP).

Dadurch melden sich alle Clients an Deinem WinsServer an und, was das wichtigste ist, derjenige PC, der den Masterbrowser macht, fragt IMMER den WinsServer, wen der alles kennt.

Damit hast Du Dein momentanes Problem erschlagen.

ABER: mindestens ein PC/Server in Deinem Netz hat Probleme - der, der in Deinem Crash-Szenario gerade den Masterbrowser macht.

Wer das ist, bekommst Du an NT4/w2k/XP-Maschinen relativ einfach raus, ich kenn aber kein Tool für Win9x, was diese Frage beantwortet.

 

Ich hoffe, das hilft Dir. Wenn Du da noch Fragen hast - frag ruhig !

Share this post


Link to post

@zuschauer:

hi, sorry, dass ich so spät antworte, meine woche war ziemlich stressig. heute bin ich dazu gekommen, den wins server einzurichten, es ging genau, wie du beschrieben hast & das problem ist seit dem nicht mehr aufgetreten soweit ich das beurteilen kann =)

vielen dank und daumen hoch für die fachmännische, geduldige & überaus freundliche hilfe =))

 

gruß

florian

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...