Jump to content

DHCP ist "zu langsam"


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo allerseits,

 

ich habe hier seit kurzem ein sehr merkwürdiges Problem und ich komme nicht auf

einen grünen Zweig, wie man so schön sagt. Folgender Hintergrund:

 

An einem Standort steht ein Windows 2003 mit der Funktion eines Fileserver mit DFS Shares (über VPN zu einem anderen Standort), Backupserver, DHCP. Das müsste iegentlich alles sein.

Der Server ist Teil eines lokalen Netzwerks das über VPN an mehreren Standorten läuft, jeder Standort hat ein eigenen IP bereich der von den Vorort stehenden DHCP Servern "mit Leases versorgt wird".

 

Der besagte Standort hat ein Problem mit dem DHCP. Der Server verteilt die Adressen scheinbar zu langsam. Beim hochfahren eines Rechners bekommt der Rechner das DHCP Signal so spät, dass das startup-skript (per Gruppenrichtlinie) nicht mehr anspringt. Der Rechner weist sich dann selbst eine der beliebten 169.* IPs (eindrucksvoll dokumentiert in der Ereignisanzeige) zu. Einen winzigen Augenblick später bekommt er die IP dann doch vom DHCP und dann geht alles seinen gewohnten Gang.

 

Der Server ist nicht großartig ausgelastet und hat jede Menge Reserven, Dienst hab ich auch schon neugestartet.

Das Netzwerk ist auch noch Lange nicht am Limit, und die Clients (Laptops mit WinXPSP2) haben an anderen Standorten auch nicht dieses Problem.

 

evt. Probleme mit irgendwelchen MS-patches bekannt?

Jemand sonst eine Idee? das Problem tauchte urplötzlich auf, obwohl serverseitig keine Umkonfiguration vorgenommen wurde.

 

Ich krich langsam die Panne hier ;) wie man so schön sagt.

 

Gruß g1n

Link to comment

das bezweifle ich, da dieselben clients am anderen standort (im selben netzwerk!) dieses problem nicht haben. selbes startupskript etc. das einzigste was sich da ändert ist der DHCP, selbst die shares sind die gleichen, dank DFS.

 

aber ich könnte ja trotzdem mal nachschauen, wenn mir jemand sagt wie ich dat finde ;)

 

Gruß g1n

Link to comment

aaaay carlito, auf den trichter bin ich noch nicht gekommen :D das ist mal eine gute idee, wenns denn nicht schon eingerichtet ist (einige der GPOs wurden nicht von mir erstellt), ich werds morgen mal checken. also bei einer GPOs läuft das schon, die benutze ich um auf diversen rechnern diverse software zu deployen. die frage ist nur inwiefern diese einstellung bei den anderen GPOs einfluss nimmt.

Link to comment

Die Richtlinie ...... immer auf das Netzwerk warten, verlegte den Start des Netzwerkes direkt hinter den Start von Windows, das wird dann auch gemeldet, man beachte die Bildschirm: Windows wird gestartet, Netzwerk .... .

 

Das erstmal checken!

 

Aus meiner Sicht: Ein DHCP verteilt keine IPs, er vergibt sie auf Anforderung des Clients, dessen Anforderung muss den DHCP erstmal erreichen.

Link to comment

ja, sorum ;) sorry

 

das problem hat sich scheinbar lösen lassen, indem ich am switch vorort einfach die spanning tree funktion ausgeschaltet habe, auf einmal bekommt man innerhalb von 1 sekunde direkt eine IP zugewiesen, das geht vielleicht fix ;)

 

diese spanning tree funktion verursacht so zum beispiel auf beim boot per PXE teilweise das die clients überhaupt eine IP bekommen und sie verlangsamt wohl das request.

 

ich werds die nächsten tage mal beobachten. und vielen dank für die vielen nützlichen tipps

 

gruß g1n

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...