Jump to content
Sign in to follow this  
maestro

Registry-Key für Standard-Mail-Client

Recommended Posts

Hallo,

 

folgender Hintergrund:

 

In einer Terminal-Server-Umgebung (Citrix Metaframe XP) wird u. a. Outlook als Client für Exchange betrieben.

 

Seit geraumer Zeit erscheint immer beim Start von Outlook die Frage, ob Outlook als Standard-Mail-Client eingerichtet werden soll:

"Outlook ist derzeit nicht als Standardmanager für E-Mail eingerichtet. Soll Outlook als Standard-Manager eingerichtet werden?"

 

Obwohl die benutzerdefinerten Einstellungen alle bei der Abmeldugn gespeichert werden, erscheint die Frage auch beim nächsten Start von Outlook wieder.

 

Jetzt zur Frage:

 

Wie kann ich über die Registry festlegen, dass Outlook der Standard-Mail-Client ist. Es muss doch möglich sein, für jeden Benutzer beim Start über ein Skript diese Option festzulegen...

 

Für Eure Hilfe im voraus herzlichen Dank. :cool:

Share this post


Link to post

Die Einstellung des Standard-Mailhandlers wird in der Registry unter

 

HKEY_LOCAL_MACHINE\Software\Classes\mailto\shell\open\command

 

abgelegt. Hat der normale Nutzer keine Adminrechte, so akzeptiert OE brav den Wunsch, kann ihn bloß nicht ausführen.

 

Bei mir steht da bsp.

 

C:\Programme\PegasusMail\WSENDTO.EXE %1

 

drin, ich verwende Pegasus, bei OE steht bsp.

 

"%ProgramFiles%\Outlook Express\msimn.exe" /mailurl:%1

 

drin, nun ist der Datentyp nicht REG_SZ, sondern REG_Expand. Diese Einstellung muß man sich einmalig als Admin erzeugen und in eine Reg-Datei sichern, diese nun auf den Clients unter Admin-Rechten einlesen.

 

Völlig unbekannt ist mir allerdings, wie man dies in einer Terminalserver-Umgebung macht - da fehlt mir die Gelegenheit. Wahrscheinlich genügt es da, den Wert einmalig in dem Analogon zur lokalen Registrierung zu ändern.

 

-------------

Gruß, Auer

Share this post


Link to post

Hallo,

 

danke für den Tipp. Leider ist dieser Key weder bei mir auf dem Standard W2K-Client vorhanden, noch auf dem Terminal-Server.

 

Der einzige Eintrag unter HKEY_LOCAL_MACHINE\SOFTWARE\Classes mit Mail beschäftigt, ist ".MAPIMail" mit dem REG_SZ-Wert "CLSID\{9E56BE60-C50F-11CF-9A2C-00A0C90A90CE}"

 

Eine Idee, warum dieser Key bei den Maschinen nicht existiert?

Share this post


Link to post

Der Schlüssel 'mailto' kann ebenfalls unter HKEY_CLASSES_ROOT oder unter HKEY_CURRENT_USER\Software\Classes zu finden sein. Allerdings habe ich keine Ahnung, wie bei einem Terminalserver die Registrierungseinträge verteilt sind.

 

Bloß: Eigentlich müßte der Eintrag von jedem Mailprogramm erst erzeugt werden, wenn sich dieses als Standardmailhandler eintragen soll. Melden sich am 'Standard-W2K-Client' nur Nicht-Admins ein, so können diese den Schlüssel mangels Berechtigung auch nicht erzeugen.

 

Folglich: Kann man sich am 'Standard-W2K-Client' einmalig als Admin anmelden, um den Schlüssel dann zu erzeugen und ihn per Suche in der Registrierung zu finden?

 

-------------

Gruß, Auer

Share this post


Link to post

Hatte selbiges Problem in einer Umgebung ohne Terminal Server, dafür mit einheitlichen, geschützten Profilen.

 

Nach dem Bestätigen der o.g. Meldung wird in der Registry der Eintrag First-Run für Outlook geändert.

 

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Setup]
"First-Run"=hex:d4,ac,58,66,58,fb,ec,42,9f,8a,e8,7d,b6,62,86,ba

Der Wert befindet sich im Benutzerprofil, kann vom Benutzer geändert werden, führt aber durch ein falsches Quell-Profil zur nervenden Meldung.

Suspekt finde ich darüber hinaus, dass die Meldung bei uns erst erschien, nachdem die Standardapplikationen in Programme der Option Internet Explorer-Wartung in der Default Domain Policy von einem Client importiert wurden.

Share this post


Link to post

Hallo Leute,

 

ich muss das Thema nochmal aufwärmen. Hat mittlerweile jemand die Ursache gefunden? Ich habe das gleiche Problem auf einem Windows XP-Rechner in unserer Umgebung. Die Fehlermeldung erscheint beim Start von Outlook nach jeder Neuanmeldung.

Die Fehlermeldung tritt auf, seit wir für den Benutzer wegen eines anderen Problems das Profil erneuert haben.

 

Den Eintrag im First-Run habe ich auch, allerdings mit anderem Wert:

[HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook\Setup]

"First-Run"=hex:d9,6e,2c,5f,a6,ec,36,47,aa,36,a1,27,44,41,17,d5

 

Leider habe ich nicht die Möglichkeit zum Experimentieren, da es sich um einen VIP handelt, der auch ziemlich unregelmäßig anwesend ist.

 

Ich bin für jeden Hinweis dankbar,

 

NeoLEX

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...