Jump to content
Sign in to follow this  
kurt

Exchange ist SSL fähig auch ohne ISA Server

Recommended Posts

Wie kann ich ein SSL verbindung bzw eine HTTPS verbindung zu meinem Exchange Server verwirklichen?

Ohne das ich einen ISA Server habe !

Ich habe einen W2000 Server und Exchange 2000 auf den ich per OWA zugreifen kann, ein eigenes Zertifikat habe ich schon

erstellt , jetzt möchte ich das Zertifikat OWA zuweisen, aber wie gesagt ich habe keine ISA Server.

Ich habe nach der Anleitung unter

 

http://www.msisafaq.de/Anleitungen/Server/Exchange_OWA_SSL_1.htm

gearbeitert, aber am schluss brauchts eben einen ISA

 

Wenn jemand einen Rat oder einen guten linke weiß bin ich sehr dankbar.

Oder anders, weiss jemand wo ich eine anleitung finde die

mir hilft isa zu installieren, ich habe eine version und habe versucht diese zu installieren, aber das war mir einfach zu schwirig. jeztzt leuft mein exchange ows so gut ich habe einfach angst mir alles zu versauen.

Share this post


Link to post

Hi

In einen älteren Beitrag bekam ich auf diese Frage diese antwort und habe somit ssl verwirklicht. ISA ist eine firewall die du nur zum schutz vor angreifern brauchst.

 

mein vorgehen:

 

erstellung für zugriff des Mailservers zb. sslsec.ch mit SSL

 

1. Zertifizierungstelle Installiert. (zert.stelle für gesamte org)

2. IIS für ssl klargemacht. ( IP und Port für virtuelle Website eingetragen)

3- Zertifikat für standard website erstellt und installiert.

 

Hier wird standardmässig ein zert. erstellt. Ich habe die jedoch gelöscht und ein neues mit dem CN sslsec.ch erstellt.

 

 

3. ein weiteres Virtuelles verzeichnis mit dem e2k system manager für OWA erstellt.

4. Dieses Verzeichnis nur für ssl zugriffe genemigen (einstellung mit IIS ändern).

 

5. danach im e2k system manager in den protokollen pop3 und smtp wieder zertifikate erstellt und die kommunikation für ssl aktiviert.

 

6. Bei der Firewall die ports 443 (web) und 995 (pop3) für den betreffenden Server freigeschaltet.

 

 

und wenn jetz alles richtig gemacht wurde und OWA funktioniert sollte es mit dem neuen virtuellen verzeichnis funktionieren.

 

 

 

also zb:

 

https://sslsec.ch/sslexchangeverzeichnis

 

 

Die meldung das die Onlinezertifzierungstelle nicht vertrauenswürdig ist, wird immer kommen. Damit musst du leben. ausser du lässt dir ein Zert. von einer Zertifikatsgesellschaft austellen. da kenne Ich aber leider keine. Diese Dienstleistung ist aber nicht gratis.

 

 

Ich weiss nicht ob meine Installation korrekt ist, aber es Funktioniert prima.

Share this post


Link to post

danke für den tip

ich habe aber probleme das so zu machen wie du es beschreibst

bin da ein anfänger.

 

hast du nicht eine genauere anleitung wie ich das machen muss

das were echt toll, ich möchte mir meinen owa nicht versauen

 

danke aber trotzden, jetzt weiss ich schon mal das es ohne

den ISA server gehen muss

Share this post


Link to post

hallo kurt.. diese antowrt hatte ich damals erstellt..

 

wo hast du denn schwierigkeiten ? Vielleicht können wir dir weiterhelfen wenn du das problem genau schilderst.

 

 

Gruss

 

Darkmind

Share this post


Link to post

Hier fangen meine schwierigkeiten an:

 

3. ein weiteres Virtuelles verzeichnis mit dem e2k system manager für OWA erstellt.

4. Dieses Verzeichnis nur für ssl zugriffe genemigen (einstellung mit IIS ändern).

 

5. danach im e2k system manager in den protokollen pop3 und smtp wieder zertifikate erstellt und die kommunikation für ssl aktiviert.

 

were super wenn ihr mir da helfen könnt

Share this post


Link to post

hallo kurt.. ich habe da mal ein paar screenshots...

 

hier mal der erste...

 

so erstellst du ein virtuelles Exchange Verzeichnis..

 

1. gehe in den Exchange Systemmanager.. und ich denke das bild spricht für sich...

 

 

Wenn du das gemacht hast.. musst du das verzeichnis im IIS bearbeiten.... dazu nacher mehr..

post-5510-13567388917498_thumb.jpg

Share this post


Link to post

wenn du das gemacht hast, musst du in die IIS Verwaltung.

 

Danach klickst du auf standardwebseite

 

Nun solltest du das dein neu erstelltes Virtuelles Verzeichnis dort finden.

klick auf eigenschaften für das virtuelle verzeichnis

klicke auf Verzeichnissicherheit

auf dieser Karte findest du zuunterst Das server zertifikat. klicke dort auf bearbeiten.. und dann kannst du dort konfigurieren das auf dieses Verzeichnis nur mit einer SSL Verbindung zugegriffen werden darf.

 

grüsse

 

Darkmind

post-5510-13567388917706_thumb.jpg

Share this post


Link to post

zu punkt 5..

 

das hat nichts mit owa zu tun. so kannst du lediglich den zugriff via smtp und pop3 durch ssl sichern. Ist aber für OWA nicht relevant.

 

Gruss

 

Darkmind

Share this post


Link to post

danke,

habe alles nach anleitung eingestellt, es geht aber es dauert

zu lange, bis ich auf owa zugreifen kann,

mit dem Internet Explorer, habe es mal mit mozilla brauser versucht

da leuft es einwandfrei und genauso schnell wir ohne ssl

was ist das schon wieder, muss ich da auf meinem exchange server noch was einstellen ?

 

nochmALS DANKE

 

kurt

Share this post


Link to post

hallo kurt

 

wunderbar.. shcon ein bisschen weiter.. das freut mich :)

 

ja dieses problem kenne ich..

 

du meinst es geht sehr lange bis das zertifikat geladen wird !?!

 

ja dieses problem kenne ich .. weis aber ganz ehrlich nicht mehr wie ich das gelöst hatte. ( ich werde alt :D )

ich glaube ich hatte das zertifikat gelöscht und danach nochmals ein neues erstellt. dann hats geklappt.. aber das kann ich so nicht bestätigen weil ich es nicht mehr genau weiss :suspect:

 

hmm.. wenn ich das nächste mal wieder eine ssl konfig mache und dieses problem lösten muss werde ich hier den vorgang posten.

installiere einfach nochmals ein neues zert. mit einem 512 bit schlüssel.

und wens klappt.. poste es doch hier :)

 

danke

 

gruss

 

Darkmind

Share this post


Link to post
installiere einfach nochmals ein neues zert. mit einem 512 bit schlüssel.

512 Bit Schlüssel gelten aber inzwischen als nicht mehr unbedingt sicher, naja sicherer als gar keine Verschlüsselung ;)

512 Bit Schlüssel entsprechen bei sysmetrischer Verschlüsselung etwa einem 56 Bit Schlüssel, die sind ja auch nicht mehr der Hit, wenn es jemand darauf anlegt....

Es sollten heute normalerweise schon 1024 Bit Schlüssel bei Public Key Verfahren sein.

 

grizzly999

Share this post


Link to post

hallo

habe neues zertifikat erstellt, ist aber immer noch langsam,

ausser mit Mozilla, da geht es immernoch prima.

habe da aber noch ein problem gefunden. Was ist zu tun

um das kennwort ändern zu können, wenn ich kennwort ändern

anklicke kommt nur ein weisses fenster.

 

gruss kurt

Share this post


Link to post

hallo

habe noch etwas rausgefunden, wenn ich mit einem pc auf dem

NT4 oder XP installiert ist, mit internetexplorer auf https:/ zugreife

leuft auch alles schnell wies sein soll, also ist das problem nur bei w2k

denke ich oder ?

 

 

wie das mit dem kennwort ändern geht habe ich auch schon

herrausgefunden !!!!

 

kurt

Share this post


Link to post

uuhmm ich weiss es nicht mal.. da ich min eigentlich nur mit w2k beschäftige :wink2:

 

aber wie gesagt.. man bekommt es auch mit w2k hin... wenn ich doch nur noch den lösungsansatz hätte.. es liegt mir auf der zunge.. :suspect: :(

 

ich habe das problem leider niergens voorliegend.. darum nicht einfach nachzuvollziehen.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...