Jump to content
Sign in to follow this  
M. Zink

Computer über VPN in Domäne heben W2K3 Server u. Vista Busines Client

Recommended Posts

Hallo,

 

ich möchte über eine bestehende VPN Verbindung direkt mit dem W2K3 Server meinen Client in die Domäne heben und später dann über DFÜ Netzwerk auch eine Domänenanmeldung vollziehen. Der VPN Tunnel steht und ich komme auch z.B. an Laufwerke oder kann über RDP auf den Server. Versuche ich jedoch der Domäne beizutreten mit dem Client dann erscheint lediglich folgende Meldung:

Es konnte keine Verbindung mit einem Active Directory-Domänencontroller für die Domäne "XYZ" hergestellt werden.

 

Stellen Sie sicher, dass der Domänenname richtig eingegeben wurde.

 

Wenn Sie den Namen richtig eingegeben haben, klicken Sie auf "Details", um Informationen für die Fehlersuche zu erhalten.

In den Details steht aber lediglich drin das er sowohl in dem lokalen Netz vom Client als auch im Netz vom VPN nach dem DC gesucht hat und nicht fündig wurde. Der Domänenname ist mit absoluter Sicherheit korrekt und auch groß und klein schreibung ist richtig.

 

Der Server ist ein Windows 2003 SB Enterprice mit allen Patches und Updates sowie genügend CALs.

Der Client ist ein Vista Business Gerät 32 Bit mit allen Updates.

 

Ich hab auch schon versucht den Computer vorher im AD schon mal manuell anzulegen aber das hatte keinerlei Auswirkung.

 

Kann ich jetzt schon davon ausgehen das das später ebenfalls Probleme gibt wenn ich mich dann über den VPN Tunnel an der Domäne anmelden möchte?

Share this post


Link to post
Share on other sites

Das sieht für mich so aus als würde der Client den Namen nicht richtig auflösen können.

 

Bekommt der Client den alle richtigen IP einstellungen, also DNS usw. mitgeteilt so das er auch den Domainnamen auflösen kann?

 

Testen kann man das auch wenn der VPN Tunnel steht mit nslookup.

Share this post


Link to post
Share on other sites

Die Einstellungen stimmen. Der DNS ist der Server selbst und auch der Gateway usw. von daher spricht eigentlich nichts dagegen das er den AD finden sollte. Ich hab nur irgendwas gelesen von wegen der Domänenname ggf. im WINS noch registrieren aber das sollte bei Vista oder XP doch nicht nötig sein oder?

 

Ich hab mal mit nslookup geschaut. Irgendwas passt da nicht. Ich bekomme vom Server eine IP da der Server sowohl VPN als auch DHCP usw. ist und im nslookup kann ich weder den Server noch die Domäne festlegen. Der meldet mir wenn ich den Server festlegen möchte "Adresse für Server xyz kann nicht gefunden werden: Server failed". der DNS ist aber eingetragen und sollte meiner Meinung nach auch funktionieren. Zumindest wenn ich lokal im Netzwerk bin kann ich problemlos Clients hinzu fügen und auch in der Domäne arbeiten.

 

Edit:

Ich habs grad noch mal geschaut. Vor lauter Fummeln hab ich versehentlich den falschen VPN Tunnel genutzt. Mit dem richtigen ist der Standardserver gesetzt und auch die IP passt. Der Standardserver ist angegeben mit servername.domäne.local und ich denke das das so richtig ist.

Share this post


Link to post
Share on other sites

Also ich weiß mir echt nicht mehr zu helfen. Das einzige was ich jetzt dann noch versuchen werde ist das Laptop direkt im lokalen Netz in die Domäne zu heben und dann mal schaun ob ich mich wenigstens von extern an die Domäne anmelden kann.

 

Was kann das denn für Ursachen haben das das nicht funktioniert? Ich würd gern wissen ob ich einen Fehler gemacht hab oder ob es an Hardware liegt oder doch an Software. Irgend eine ursache muss es ja haben.

Share this post


Link to post
Share on other sites

Ich wollte nur kurz Rückmeldung geben wie ich das Problem zwar nicht direkt gelöst habe aber zumindest für meinen Fall umgangen habe.

 

Der Domänenbeitritt über den VPN Tunnel wollte einfach nicht funktionieren. Aus meiner Sicht habe ich sowohl auf dem Server als auch auf dem Client echt alles berücksichtigt und es hätte funktionieren müssen. Ich frage mich langsam jedoch ob der reine Beitreten einer Domäne über VPN überhaupt geht. Zumindest ohne im RAS irgendwelche Definitionen zu machen.

 

Ich habe nun den Client einfach im lokalen Netz in die Domäne gehoben und unter Vista hat der mir sofort eine Verbindung angelegt zum SBS2003 (wo ich anfangs erst mal nicht wusste wozu die da sein könnte). Im lokalen Netz ging dann auch auf anhieb alles wie es sollte. Extern hab ich dann ne Weile die Option gesucht beim Anmelden eine DFÜ Verbindung zu wählen. Dies ist aber garnicht nötig bzw. sogar garnicht möglich. Man meldet sich einfach an so als wenn man im lokalen Netz wäre und wenn man dann angemeldet ist aktiviert man die neue Verbindung zum SBS2003. Dadurch besteht dann eine Verbindung zur Domäne und man kann arbeiten wie im lokalen Netz. Funktioniert echt prima und ist genau das was ich gebraucht hab.

 

Das einzige was ich jetzt noch nicht sicher weiß ist ob die Verbindung die der mit automatisch angelegt hat nun eine sichere Verbindung auch über VPN ist oder ob das sonst eine Verbindung darstellt. Ich denke eigentlich das es eine VPN Verbindung ist aber absolut sicher bin ich mir da noch nicht.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...