Jump to content
Sign in to follow this  
warbird001

Mehrere Adressen/Namen pro Server?

Recommended Posts

Hallo Alle

Habe hier einen Server mit einer 2. Netzwerkschnittstelle die ueber vmware

genutzt wird.

 

Nun habe ich den Server mit 2 IP Adressen (10.0.0.2 und 10.0.0.3)

aber gleichem Namen (SERVER2) im DNS.

Bisher funktioniert das soweit, es fuehrt aber immer wieder zu Fehlerprotokolleintraegen.

 

Wie kann ich das beseitigen?

 

Ein Versuch die zweite Adresse (10.0.0.3 als SERVER3) von Hand korrekt

in den DNS einzutragen fuehrt dazu das auch SERVER2 nur noch mit 10.0.0.3

aufgeloest wurde.

Ein Zugriff in der Art von

\\server3\c$

wahr auch nicht moeglich und wurde mit der Fehlermeldung Quittiert das der

Name schon vergeben sei.

 

mfg

Share this post


Link to post
Share on other sites

Das letztere bekommst Du wahrscheinlich mit "DisableStrictNameChecking" in den Griff. Hat der Server zwei Karten im gleichen Bereich oder eine Karte, auf die 2 IP-Adressen gebunden sind ?

Share this post


Link to post
Share on other sites
Das letztere bekommst Du wahrscheinlich mit "DisableStrictNameChecking" in den Griff.

 

Yepp, klappt. Danke.

 

Hat der Server zwei Karten im gleichen Bereich oder eine Karte, auf die 2 IP-Adressen gebunden sind ?

 

Er hatt 2 Karten im gleichen Bereich.

 

mfg

Share this post


Link to post
Share on other sites
Das solltest Du nicht tun, konfiguriere unterschiedliche Bereiche auf den Karten ...

 

Nur das ich das nicht missverstehe:

 

Karte1 : 10.0.0.2 Server2

Karte2 : 10.0.0.3 Server3

 

Die Karten duerfen nicht im selben Subnetz sein?

Wenn ja, warum nicht?

 

mfg

Share this post


Link to post
Share on other sites

Über welche Karte geht er denn in das 10.0.0.0 Netz ? Das kannst Du allenfalls über die Bindungsreihenfolge der Karten steuern (schau Dir mal die Routingtabelle an) ...

Share this post


Link to post
Share on other sites
Über welche Karte geht er denn in das 10.0.0.0 Netz ?

Das kannst Du allenfalls Über die Bindungsreihenfolge der Karten steuern

(schau Dir mal die Routingtabelle an) ...

 

Er geht ueber beide Karten in das 10.0.0.0 Netz.

 

Allerdings habe ich beim Testen in der Testumgebung wohl das eigentliche

Problem ein wenig aus den Augen verloren.

Server2(10.0.0.2) hatt eine zweite Netzwerkkarte(10.0.0.3)

er taucht nun zweimal als Server2 auf.

 

Die 2. Karte soll aber nur von einer auf Server2 laufenden vmware

Installation benutzt werden.

Innerhalb dieser VM laueft ein w2k3 smtp Server (10.0.0.13 Postserver).

 

Letztendlich ist es egal ob zugriffe ala \\10.0.0.3\Freigabe

oder \\Server3\Freigabe moeglich sind.

Die Karte ist nur fuer die vm gedacht.

 

Ich moechte nur die Fehlermeldungen vermeiden.

 

---

Quelle NetBT

Ereigniskennung 4319

 

Ein doppelter Name wurde im TCP NEtzwerk entdeckt.

Die IP-Adresse der die Meldung gesendet hatt, steht in den Daten.

Verwenden sie nbtstat -n an der Eingabeaufforderung um den doppelten Namen zu be

stimmen.

---

 

 

mfg

Share this post


Link to post
Share on other sites

Ich meinte damit, wie steuerst Du es, dass er mit Karte X ins 10er Netz geht ? Er hat ja 2 Karten mit dem gleichen Bereich, vom Registrieren im DNS mal ganz abgesehen ... Das ist unglücklich ...

Share this post


Link to post
Share on other sites
Ich meinte damit, wie steuerst Du es, dass er mit Karte X ins 10er Netz geht ? Er hat ja 2 Karten mit dem gleichen Bereich, vom Registrieren im DNS mal ganz abgesehen ... Das ist unglücklich ...

 

Ich habe den beiden Karten ganz normal ihre IPs zugewiesen nichts weiter.

Danach dann in vmware eingestellt das es die zweite benutzen soll.

 

mfg

Share this post


Link to post
Share on other sites
Ich habe den beiden Karten ganz normal ihre IPs zugewiesen nichts weiter.

Danach dann in vmware eingestellt das es die zweite benutzen soll.

 

mfg

Ja und, deswegen sind doch trotzdem 2 Karten mit dem gleichen IP-Bereich im Server eingebaut. Oder verstehe ich es nur nicht, weil es mit VMWare alles anders ist ?

Share this post


Link to post
Share on other sites
Ja und, deswegen sind doch trotzdem 2 Karten mit dem gleichen IP-Bereich im Server eingebaut. Oder verstehe ich es nur nicht, weil es mit VMWare alles anders ist ?

 

Karte1: 10.0.0.2

Karte2: 10.0.0.3

 

Subnetzmaske in beiden Faellen: 255.255.0.0

Die Default Route fuer Karte1: 10.0.0.1

Karte2 hatt keine Default Route.

 

Unabhaengig davon das da vmware im Spiel ist:

Meinst du das schon der Betrieb dieser 2 Karten mit dieser

Konfiguration ein grundsaetzliches Problem ist?

 

mfg

Share this post


Link to post
Share on other sites

Hast du die zweite Karte extra für den VMWare Server eingebaut oder was möchtest du damit bezwecken. Ausfallsicherheit oder Entlastung für den Host?

Wenn es geht würde ich das über NIC Teaming lösen. So hast du eine gewisse Ausfallsicherheit. Was läuft denn auf dem Host bzw Virtuell?

Zwei Karten im gleichen Segment halte ich für nicht so optimal.

Share this post


Link to post
Share on other sites
Ja genau, das versuche ich die ganze Zeit zu verdeutlichen :D

 

Kennst du den Grund dafuer?

IP kann es eigentlich nicht sein, Netbios?

 

Verstehen tue ich das derzeit nicht aber was solls,

fliegt die zweite Karte eben raus.

Mal sehen wie es mit nur einer Karte laeuft.

 

mfg

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...