Jump to content
Sign in to follow this  
watumba

Kein Domänenbeitritt über VPN

Recommended Posts

Hallo,

 

ich habe diese Woche eine Domäne (W2k3) in unsere Firma aufgesetzt. Alle lokalen XP-Clients sind eingebunden, nur 3 XP-Clients, die in unserer Filiale sitzen können nicht der Domäne beitreten. Diese bekommen bei Versuch der Domäne beizutreten sofort die Meldung, das die Domäne nicht ereichbar ist.

Die besagten XP-Clients sind mit Hilfe von 2 Netgear-Router via VPN im Netzwerk der Firmenzentrale.

Ich habe nat. schon einige Ursachen mit Hilfe der Suche und Google gefunden, aber bis her kein Erfolg.

 

Nslookup zum DC (auch DNS) funktioniert. (nach Eintrag in hosts am Client)

Netbios aktiv

Zugriff auf Terminalserver und Anwendungsserver (beide 2k3) auch Ok

Firewalls testweise deakt.

Die Router lassen auch alles durch

 

 

Hat jemand einen Rat ?

 

gruß

Share this post


Link to post

Hallo,

 

NetBIOS verständigt sich über Broadcasts, die von deinen Routern geblockt werden.

Versuch doch mal bitte beim joinen in die Domäne an den Clients nicht den NetBIOS Namen der Domäne anzugeben, sondern den DNS Namen. Da Deine DNS Auflösung offenbar funktioniert - wie Du schreibst - sollte das funktionieren.

 

Gruß olc

Share this post


Link to post

Ich habe gerade noch einmal Deinen ersten Post zu dem Thema gelesen --> Du schreibst, daß die DNS Auflösung nach dem Eintragen des DCs in die Hosts-Datei funktioniert. Das hatte ich beim ersten Mal überlesen.

 

Das kann nicht funktionieren, da der Client neben dem reinen Host A Eintrag auch die Dienste (Kerberos, LDAP etc.) aus dem DNS auslesen können muß.

 

Hast Du denn auf den Remote Clients den DNS Server des Hauptbüros eingetragen? Ich gehe davon aus, daß der DC gleichzeitig auch DNS Server ist oder? Du mußt DNS (ohne die "Krücke" mit der Hosts-Datei) definitiv korrekt zum Laufen bringen, sonst wird das nichts...

 

Gruß olc

Share this post


Link to post

Hallo,

 

der DC ( auch DNS) ist auf den Clients eingetragen. Ohne den Host-Eintrag funkt. NSlookup nicht. Woran kann das liegen?

 

gruß

Share this post


Link to post

Das läßt sich so einfach nicht beantworten.

 

Du schreibst, daß jeder Traffic derzeit durch die Firewall durchgelassen wird? Dann könnte es ein Routing Problem sein. Überprüfe doch einmal die üblichen Verdächtigen:

 

- Gateway-Einstellungen auf beiden Seiten

- eingetragene bzw. benötigte Routen

- pathping / tracert

- usw. usf.

 

Für eine konkrete Hilfestellung müßtest Du die Umgebung ein wenig genauer beschreiben...

 

[EDIT] Wobei - bei einem Routingproblem dürfte auch ein Ping auf den Host mit Hilfe des Hosts-Eintrag nicht funktionieren... Jetzt wird es kniffelig ;)

Überprüfe aber trotzdem einmal die oben genannten Einstellungen bzw. gib uns mal ein paar mehr Infos... [/EDIT]

 

Gruß olc

Share this post


Link to post

@watumba

 

Von "manuellen" Hosteinträgen kann ich nur abraten damit bekommst Du niemals ein richtig funktionierendes Domänennetzwerk hin.

 

Wenn nslookup ohne diese Hosteinträge nicht funktioniert dann stimmt etwas mit der DNS-Weiterleitung nicht und ich würde entsprechend die Firewall dazu überprüfen.

 

Am besten machst Du eine Side to Side Verbindungen beider VPN-Router. Anschließend konfigurierst Du den VPN Router in der Filiale so das er DNS und DHCP Relay an den Server in der Zentrale macht.

 

Achtung ein Domänenbeitritt von Clientcomputer welche von einem entfernten Ort per VPN angebunden sind, ist zu berücksichten das bedingt durch die AD Syncronisationen hier viel Traffic entsteht!

 

Gruß

Michael

Share this post


Link to post

Welche AD-Synchronisation bei einem Client ?

Es wäre interessant zu wissen, wie die Clients die Verbindung herstellen. Ist ein VPN zwischen den Routern hergestellt worden oder zwischen dem Client im Zweigstellennetz und dem Router oder dem Server im Hauptstellennetz ? IPCONFIG /ALL eines Clients im Zweigstellennetz und des Servers in der Hauptstelle würde einiges klarer machen ...

Share this post


Link to post

@IT-Home:

 

Die besagten XP-Clients sind mit Hilfe von 2 Netgear-Router via VPN im Netzwerk der Firmenzentrale.

...

 

Die Router lassen auch alles durch

 

Ich denke ein Teil der Fragen ist schon beantwortet. Aber Du hast Recht - ohne mehr Infos kommt man an dieser Stelle nicht weiter.

 

Ich denke mal darkhawk meine nicht die Replikation, sondern den normalen Traffic, der beim Anmelden etc. über die Leitung geht. ;)

 

Gruß olc

Share this post


Link to post

Hallo,

 

die VPN ist zw den Routern aufgebaut.

Ich bin aber jetzt ein paar Tage nicht in der Firma, ich melde mich wieder wenn ich vor Ort bin.

Danke erstmal und frohe Ostern.

 

gruß

Share this post


Link to post

Hallo,

 

bin jetzt endlich mal dazugekommen mir die Sache näher anzusehen.

Schuld war ein nicht FQDN. :o :o :o

Irgenwie ist es schon interessant warum Server 2003 jeden Domänen Namen zulässt!!!

 

Danke an alle.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...