Jump to content
Sign in to follow this  
Thommy83

Windows DNS Problem mit Alias

Recommended Posts

Hallo zusammen,

 

folgende Situation:

Wir haben in der Firma einen Fileserver, der auch als DNS- und DHCP-Server fungiert, einen Webserver (Apache) und eine Reihe von Clients. Der File+DNS-Server hat Zugang zum Internet.

 

Bei den Clients werden IP- und DNS-Serveradresse automatisch bezogen (DHCP). Als OS werden Win 2k oder XP verwendet.

 

Auf dem DNS-Server haben wir für den Webserver versch. DNS Aliase vergeben. (Je nach Alias liefert der Webserver eine andere Seite. Die Seiten sind nur im LAN zugänglich).

 

Wenn man nun (von einem Client aus) den jew. Aliasname im Browser eingibt funktioniert alles einwandfrei (Website wird geladen). Doch nun zu dem Problem: In unregelmäßigen Zeitabständen lässt sich der Webserver über bestimmte Aliase nicht mehr aufrufen (weder über den Browser noch lässt er sich über den Alias anpingen). Auf anderen Clients funktioniert zu diesem Zeitpunkt der Alias aber. Ist das ein lokales DNS-Problem? (Cache?) oder wurde möglicherweise auf dem DNS-Server etwas was konfiguriert? Problem betrifft alle Clients (Win2000, wie auch XP).

 

Weiß hier evtl. jemand Rat oder hat eine Idee an welcher Einstellung sowas liegen könnte?

 

Vielen Dank schonmal im Voraus!

 

Grüße

Thommy

 

P.S.: Falls ihr noch irgendwelche Angaben benötigt, teile ich diese euch gerne mit.

Share this post


Link to post

Achja noch eine Zusatzinfo: Auf dem DNS/DHCP-Server läuft Windows Server 2003. Wir hatten das Problem aber früher schon mit Windows 2000 Server.

Share this post


Link to post

was ist die Fehlermeldung? Access denied, Host not found, nimmt er eine falsche IP, etc. Funktioniert net use * \\<ipaddress>, net use * \\<servername>\c$

Share this post


Link to post

Wenn man den Rechner über seinen DNS Namen versucht anzupingen, kommt nix zurück, als würde er den DNS-Namen nicht kennen. Im Browser kommt dem entsprechend Seite wurde nicht gefunden.

Share this post


Link to post
Wenn man den Rechner über seinen DNS Namen versucht anzupingen, kommt nix zurück, als würde er den DNS-Namen nicht kennen.

Dann würde ich das als Tatsache ansehen und in der Richtung weiter forschen.

--> Warum liefert der auf den Clients eingetragene DNS-Server keine Auflösung zu dem Namen? --> wenn's wieder nicht geht, "ipconfig /all" und schauen, welche DNS-Server eingetragen sind.

 

Dann auf diese direkt zugreifen und dort eine Namensauflösung des Alias durchführen. Vermutlich euer DHCP-Server, würde mich aber nicht überraschen, wenn auch eine andere IP für den zweiten DNS-Server drinsteht, möglicherweise eine externe IP, die dann den Alias nicht kennt.

 

Wenn nur der eigene DNS-Server auf den Clients drinsteht, dort weitersuchen: DNS-Sys-Log nach Fehlern abgrasen. Server-lokal eine Auflösung durchführen. Prüfen, ob A-, cname- und PTR-Record zueinander passen.

 

Nebenbei: wenn die Aliasauflösung nicht klappt, besteht per ping auf die IP des DNS eine Verbindung? (evtl. Leitungsstörung?)

 

Gruß

Olaf

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...