Jump to content

Netzwerk Problem dual server


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo liebe Gemeinde,

 

zunächst einmal meine Hochachtung für dieses Forum und den regen Info-Austausch. Finde es wirklich Klasse, wie sich die Nutzer hier gegenseitig helfen. Und das bringt mich zu meinem Problem ...

 

Ich möchte gerne mein Netzwerk umstellen und habe ein Problem für das ich keine Lösung finde. Also zuerst einmal die derzeitige - gut funktionierende Konfiguration:

 

1 x WinServer 2003 (2 x NIC - 1 x static IP 192.168.58.10, 1 x RASPPPOE für internet)

5 x Windows XP SP2 (1 x NIC 192.168.58.12 - 17)

1 x 8-Port Switch von Netgear

1 x Printserver von NetGear

 

Auf dem WinServer laufen SQLServer und ISAServer 2004 (also ist der Server auf der einen Seite ein Fileserver und auf der anderen Seite auch Router ins Internet der Internet für die Workstations bereit stellt). Auf den Workstations ist in den TCP/IP Settings unter DNS und unter Standard Gateway der Server (192.168.58.10) eingetragen. Diese Konfiguration läuft einwandfrei und ohne Probleme. Die Workstations können auf die Netzwerkfreigaben des WinServer zugreifen und kommen flott ins Internet.

 

Nun habe ich mir einen neuen kombinierten Switch-Router-Firewall mit Wireless von Netgear gekauft, um die Routerfunktion vom Server zu entfernen und den WinServer nur noch als Fileserver zu fahren.

 

Es kommt also ein Server hinzu (1 x Netgear Router Switch mit statischer IP 192.168.58.11). Der Router ist konfiguriert um die IP und DNS dynamisch vom Internet Provider zu beziehen. Die Firewall erhält dieselben Regeln, die vorher auf dem ISAServer 2004 definiert waren ...

 

Auf dem Server (Win2003) habe ich die Netzwerkkarte über die RASPPPOE lief deaktiviert und die kabel entfernt. Ebenso RASPPPOE deinstalliert und ISAServer 2004 deaktiviert. Dann den Server neu gebootet. Es bleibt also nur die Netzwerkkarte für das interne Netz mit der statischen IP 192.168.58.10 Die DNS zeigt auf den NetGear Router (192.168.58.11)

 

In WinXP auf den Workstations habe ich die TCP/IP Einstellungen geändert: DNS 192.168.58.11 (der Router/Switch) und Standard Gateway 192.168.58.10 (der WinServer).

 

Nun habe ich das Problem, daß die Workstations zwar ohne Probleme uns wie gehabt flott ins Internet kommen (über den Router). Es ist aber kein Zugriff mehr auf die Netzwerkfreigaben des WinServer 2003 mehr möglich.

 

Könnte mir hier jemand auf die Sprünge helfen und sagen, wie ich die TCP/IP - DNS auf dem Server und den Workstations einstellen muss, damit ich mit den Workstations über den Router-Switch-Firewall (IP 192.168.25.11) ins Internet komme und andererseits auf die Netzwerkfreigaben des Server (IP 192.168.58.10) zugreifen kann?

 

Freundliche Grüße

Oliver

Link to comment

Hallo und willkommen on Board. :)

 

Ich gehe jetzt davon aus, dass der Win-Server KEIN DC ist, korrekt?

Dann sollten auf dem Server und den Clients der Netgear-Router sowohl als DNS und auch als Gateway eingetragen werden.

 

In WinXP auf den Workstations habe ich die TCP/IP Einstellungen geändert: DNS 192.168.58.11 (der Router/Switch) und Standard Gateway 192.168.58.10 (der WinServer).[/Quote]

Wieso der Server als Gateway? :confused:

 

Damian

Link to comment

Hallo Damian, vielen Dank!

 

Ja korrekt, Server ist kein DC. Wenn ich auf allen Clients den Router als DNS und Standard Gateway eintrage, wie werden dann Anfragen an den Server aufgelöst? Der Router leitet doch alle Anfragen ins Internet weiter und da kann ja der lokale Server (192.168.58.10) nicht gefunden werden ... In der hosts Datei auf den Clients gibt es jeweils noch Einträge in der Form 192.168.58.10 = C1, 192.168.58.12 = C2 ... usw. Wenn ein Client also den Server über die Bezeichnung C1 ansprechen will wie wird das dann aufgelöst?

 

Hallo und willkommen on Board. :)

 

Ich gehe jetzt davon aus, dass der Win-Server KEIN DC ist, korrekt?

Dann sollten auf dem Server und den Clients der Netgear-Router sowohl als DNS und auch als Gateway eingetragen werden.

 

 

Wieso der Server als Gateway? :confused:

 

Damian

Link to comment

Hi.

 

Wenn der Server nicht als DC eingerichtet ist, läuft das Netzwerk als Arbeitsgruppe und alle Ressourcen werden NetBIOS und Freigaben gefunden. Wie werden die Laufwerke gemappt? Über eine Batch?

 

Stimmen die Einträge in den Hosts-Dateien mit den Namen und IPs im Netzwerk überein?

 

Hast du auf dem Win-Server einen DNS laufen und eingerichtet? Dann könnte dieser die Namensauflösung im Netz übernehmen und mit einer DNS-Weiterleitung auf den Router verweisen.

 

Damian

Link to comment

Auf dem Server sind Verzeichnisse freigegeben und diese auf den Clients mit Laufwerksbuchtaben verbunden ... Vermute mal das meinst Du mit Mapping richtig?

 

Ja die Einträge in den hosts Dateien stimmen mit den Namen und IP's im Netzwerk überein. Ach ja und in den Systemeinstellungen der Clients ist überall derselbe Arbeitsgruppen-Name eingetragen.

 

Nein habe auf dem Server kein DNS eingerichtet und laufen. Sollte ich das tun? Wäre das von Vorteil? Wenn ja vermute ich mal müssten hier die DNS Einträge die Server IP sein und ein Forwarding auf die Router IP eingegeben werden?

 

Hi.

 

Wenn der Server nicht als DC eingerichtet ist, läuft das Netzwerk als Arbeitsgruppe und alle Ressourcen werden NetBIOS und Freigaben gefunden. Wie werden die Laufwerke gemappt? Über eine Batch?

 

Stimmen die Einträge in den Hosts-Dateien mit den Namen und IPs im Netzwerk überein?

 

Hast du auf dem Win-Server einen DNS laufen und eingerichtet? Dann könnte dieser die Namensauflösung im Netz übernehmen und mit einer DNS-Weiterleitung auf den Router verweisen.

 

Damian

Link to comment
Auf dem Server sind Verzeichnisse freigegeben und diese auf den Clients mit Laufwerksbuchtaben verbunden ... Vermute mal das meinst Du mit Mapping richtig?

Ja genau.

 

Ja die Einträge in den hosts Dateien stimmen mit den Namen und IP's im Netzwerk überein. Ach ja und in den Systemeinstellungen der Clients ist überall derselbe Arbeitsgruppen-Name eingetragen.

Dann sollte ein Ping auf den Servernamen (wenn eingetragen) aufgelöst werden.

 

Nein habe auf dem Server kein DNS eingerichtet und laufen. Sollte ich das tun? Wäre das von Vorteil?

Vorteil ja. Kommt darauf an, ob sich der Aufwand lohnt.

 

Wenn ja vermute ich mal müssten hier die DNS Einträge die Server IP sein und ein Forwarding auf die Router IP eingegeben werden?

Richtig. Der Server sollte als primärer DNS auf sich selber zeigen und ein Forwarding auf den Router haben.

 

Jetzt haben wir alles soweit durchgekaut - was genau funktioniert jetzt nicht? Was wurde schon getestet?

 

Damian

Link to comment

Hallo Damian,

 

irgendetwas ist faul mit meiner Konfi oder ich mache einen Fehler, dem ich nicht auf die Spur komme ...

 

Habe das nochmal probiert. Zugang ins Internet über den Router klappt reibungslos, aber Zugriff auf den Server geht gar nicht! Mit gar nicht meine ich das der Server in der Netzwerkumgebung nicht auftaucht und auch auf ein Ping nicht reagiert (Zeitüberschreitung). Ich kann den Server weder über seine IP noch über seinen Namen ansprechen.

 

Nochmal was ich jetzt probiert habe

Alle workstations:

- feste fortlaufende IP (192.168.13 - 17) und Namen (WS3 - WS7)

- StandardGateway = Router IP

- DNS Server = Router IP

- hosts file enthält alle IP's + namen (auch IP und namen des Server)

- Arbeitsgruppenname "companyname"

 

Server

- Feste IP

- standard gateway = router IP (da auf dem Server ein mailserver läuft, der Internetzugriff benötigt)

- DNS Server = eigene IP des Server

- hosts file enthält alle IP's und namen

- Arbeitsgruppenname "companyname"

 

Das merkwürdige dabei ist, wenn ich ohne den Router und ohne Internetverbindung arbeite und alle Rechner nur an einem Switch hängen ist der Server ebenfalls im Netzwerk nicht zu finden (auch kein Ping). Auch sieht der Server sich nicht selbst (also auf dem Server unter Netzwerkumgebung->Arbeitsgruppe sollte der Server erscheinen, tut er aber nicht ...

 

Ich verstehe nur noch Bahnhof. Ob mir jemand helfen kann?

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...