Jump to content

rakli

Members
  • Content Count

    1,806
  • Joined

  • Last visited

Everything posted by rakli

  1. sorry 2010 bei de Domains sind in einen Forest ForestMode : Windows2003Forest
  2. Hi, folgende script erzeugt bei der Ausgabe zwischen Name und cout Leerzeilen, wie bekomme ich die weg ? :-) $A = get-distributiongroup foreach ($i in $A) { $G = (Get-DistributionGroup $i).member | measure $i | ft name $G | fl count } Gruss Rakli
  3. Hi, die Umgebung: zwei Domains Dom1 und Dom2 in einer Vertrauensstellung. In der Dom1 steht eine Exchange 2008 In Dom2 ist eine Distributiongroup Testgruppe Auf Get-DistributionGroupmember Testgruppe wird keine Mitglied angezeigt Get-DistributionGroupmember Testgruppe -DomainController DomanController.Dom1 werden die Mitglieder angezeigt Frage: Obwohl ich Set-AdServerSettings -ViewEntireForest $True gesetzt habe, muss ich bei Get-DistributionGroupmember jedes mal den DomainController angeben? Gruss Rakli
  4. Hi, wir haben einige apples in die Domäne gebracht. Die Nutzer sollen lokale Administrator Rechte haben. Sie sollen dabei nicht ihr apple Konto benutzen, sondern ihr Domänen Konto. Unter Windows ist das ja kein Problem, wie geht das aber beim Apfel? Gruss Rainer
  5. Hi, wozu gibt es bei Get-Aduser die Option -Filter? Kann man nicht alle mit "Where" abfragen? Gruss Rakli
  6. Lösung gefunden: der Postfix macht ein LDAP Abfrage gegen das AD. Die User, welche er findet, nimmt er an - auch deaktivierte user. :-( Sendet man ein Mail an einen deaktivierten User, nimmt der Postfix die Mail an und leitet sie an den Exchange weiter. Dieser weiß damit nichts anzufangen und sendet die Nachricht zurück an den Postfix und sendet zurück u.s.w. ... - fertig ist der loop.
  7. Hallo, aus der Warteschlange kann ich Mails per powershell löschen (Exchange 2010). In der grafischen Oberfläche fehlt mir aber beim Klick mit der rechten Maustaste die Option? Gruss Rakli
  8. Mails an disabeld user landen auf dem exchange in einem loop. Es gibt keine Rückantwort an den Sender.
  9. Aber eigentlich dürfte der Exchange die Mail nicht annehmen, die Mailbox existiert ja nicht mehr? Es kommt aber keine Fehlermeldung in Oultook.
  10. Hi, folgende Situation, Exchange 2010, user ist disabled und seine Mailbox gelöscht (entfernt). Trotzdem kann man dem User Mail senden, es kommt keine Fehlermeldung. Das Mail landet in einem loop zwischen dem Exchange und dem edge server (postfix). Was ist die Ursache? Gruss Rakli
  11. Hi, kann man per powershell die Termine in Raumpostfächer auslesen (Zeitdauer, Teilnehmer, Organisator,...) ? Exchange 2010. Gruss Rainer
  12. Hi, wir haben einen forest mit zwei Domains firma.privat und firma.local (Server 2008) In der Domain firma.local gibt es den user testuser. Bei der Abfrage in der domain.local nach dem User bekommen ich folgenden Fehler: get-aduser testuser -server server.firma.local Abfrage Ok get-aduser testuser -server server.firma.privat Unter "DC=firma,DC=privat" kann kein Objekt mit der ID "testuser" gefunden werden. DCdiag gibt keine Fehler. Auch wenn ich Rechte auf Dateien vergebe, werden die User aus beiden Domains gefunden. bei Abfragen in der doamin.privat, das gleiche Spiel, ich kann keine user aus local abfragen Wo könnte ich nach dem Fehler suchen? Gruss Rakli
  13. Ich teste gerade die script, dabei ist mir aufgefallen, dass sie nicht über den forest suchen, sprich Gruppen in anderen Domains werden nicht gefunden. Ich würde jetzt die Server in den Domains ins Spiel bringen, geht das noch einfacher? Auf der Exchange Konsole gibt es z.B. den Befehl Set-AdServerSettings -ViewEntireForest $true Add-ADGroupMember : Unter "DC=firma,DC=cologne" kann kein Objekt mit der ID "CN=Enterprise Admins,CN=Users,DC=firma,DC=oslo" gefunden werden. + Add-ADGroupMember -Identity $Group -Members $UserTarget + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (CN=Enterprise A...stBack,DC=loslo:ADGroup) [Add-ADGroupMember], ADIdentityNotFoundException + FullyQualifiedErrorId : Unter "DC=firma,DC=cologne" kann kein Objekt mit der ID "CN=Enterprise Admins,CN=Users,DC=firma,DC=oslo" gefunden werde n.,Microsoft.ActiveDirectory.Management.Commands.AddADGroupMember
  14. Hi, ich versuch die Gruppenmitgliedschaft von einem User (Quelluser) auf eine anderen User (Zieluser) zu kopieren. Leider komme ich da trotz google Hilfe nicht weiter? Was mache ich falsch? Rakli $G = get-aduser Quelluser | Get-ADPrincipalGroupMembership | Select-Object name ForEach ($i in $G) { add-adgroupmember $i -member zieluser } Add-ADGroupMember : Cannot bind parameter 'Identity'. Cannot create object of type "Microsoft.ActiveDirectory.Management.ADGroup". The adapter cannot set the value of property "name". At C:\Test\gruppe.ps1:10 char:21 + add-adgroupmember $i -member zieluser + ~~ + CategoryInfo : InvalidArgument: (:) [Add-ADGroupMember], ParameterBindingException + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.ActiveDirectory.Management.Commands.AddADGroupMember
  15. Hallo, bei Befehlen wie diesem get-aduser rakli | Get-ADPrincipalGroupMembership | Select-Object name bekomme ich in der Ausgabe in der ersten Zeile name. Wie kann ich das verhindern? PS C:\Users\rakli> get-aduser rakli | Get-ADPrincipalGroupMembership | Select-Object name name <== soll weg ---- <== soll weg Domain Users Account Operators Server Operators Gruss Rakli
  16. Hi, für das cmdlet add-MailboxPermission muss ich den Parameter user in Hochkomma setzen. Was mir nicht gelingt. :-( Der Grave-accent verursacht einen Zeilenumbruch und ich bekomme ihn nicht maskiert, auch wenn einen zweiten setze. ForEach ($i in $user) { $u = '"' + $i + '"' $u # add-MailboxPermission -id ps.substitute -user $u -AccessRights FullAccess } Das Ergebnis - leider mit Zeilenumbruch. "username1 " "username2 " "username3 " Gruss Rakli
  17. Danke sehr guter Beitrag. Trotzdem habt Mitleid mit mir, in der Abteilung arbeiten viele Stunden als Hilfskräfte, die oft wechseln. Das heist auf der Liste, die ich bei Einstellungen abzuarbeiten habe, kommt noch ein Punkt hinzu.
×
×
  • Create New...