Zum Inhalt wechseln


Foto

Zertifizierungsstelle kaputt?

Windows Server 2012 R2 Active Directory

  • Bitte melde dich an um zu Antworten
6 Antworten in diesem Thema

#1 theonlybrand

theonlybrand

    Newbie

  • 45 Beiträge

 

Geschrieben 04. Juli 2017 - 15:25

Hallo zusammen,

 

nach meiner Abwesenheit an der Uni bin ich gestern in mein Büro zurückgekommen. Dort habe ich dann festgestellt, dass Kollegen von mir während meiner Abwesenheit

"etwas umkonfiguriert" haben, was genau kann mir keiner sagen. 

 

Folgendes Szenario:
1. Ich habe auf meinem Server einen Tomcat 8.15 installiert und will diesen mit einem Zertifikat von meiner CA ausstatten.

2. Habe einen CSR erstellt.

3. Ich gehe auf die Webregistrierung: Hier spielen sich jetzt kuriose Dinge ab!

 

Entweder ich gelange auf die Seite wo ich meinen CSR reinpasten kann, kann diesen dann aber nicht abschicken sondern bekomme eine Fehlermeldung (Zuordnungen von Kontennamen und Sicherheitskennungen wurden nicht durchgeführt. 0x80070534 (WIN32: 1332 ERROR_NONE_MAPPED)

 

Oder:

Er lässt mich garnicht erst auf die Seite zugreifen und meldet, dass diese während der Anfrage zurückgesetzt wurde.

 

Das Problem ist reproduzierbar und von Client zu Client und Browser zu Browser unterschiedlich.

 

Hat mir jemand einen Rat wie ich vorgehen sollte, dass mein Tomcat ein Zertifikat von der CA bekommt, das auch für ihn ausgestellt ist?

Freundliche Grüße
theonlybrand

 


Linux is like a tipi, no gates, no windows, and an apache inside


#2 TheCracked

TheCracked

    Board Veteran

  • 807 Beiträge

 

Geschrieben 05. Juli 2017 - 08:31

Tag,

 

ein bisschen mehr Infos wären nicht schlecht..

Was ist es denn für ein Server 2012 R2 .. 2016 ? 

Deine CA ist auf einem Windows Server installiert?

 

Wenn ja.. du gehst auf https://localhost/certsrv ... hier stellst du dann ein Zert. aus?.. Wann genau kommt die Fehlermeldung?

 

Prüfe im IIS ob das Virtuelle Verzeichnis für NTLM auth. konfiguriert ist.

 

 

Grüße

TC



#3 theonlybrand

theonlybrand

    Newbie

  • 45 Beiträge

 

Geschrieben 05. Juli 2017 - 09:23

Die CA ist auf einem Server 2016, leider gibts das hier noch nicht zur Auswahl.

 

Die Fehlermeldung kommt wenn ich unter certsrv/certrqxt.asp eine erweiterte Anforderung stellen will.

 

Das Verzeichnis ist auch für NTLM konfiguriert.

 

Zusatz: Google Chrome stuft die Webseite als "broken https" ein, Mozilla Firefox nicht. Die Zertifikate im Zertifikatsspeicher der beiden Browser sind jedoch identisch.


Linux is like a tipi, no gates, no windows, and an apache inside


#4 NorbertFe

NorbertFe

    Expert Member

  • 30.918 Beiträge

 

Geschrieben 05. Juli 2017 - 09:46

Broken https hat aber meist einen Grund. Wie bspw. fehlender SAN oder SHA1. Irgendwas davon muß es ja sein.
Notfalls eben nicht per Webseite das Zertifikat anfordern sondern an der cmd-line.

Bearbeitet von NorbertFe, 05. Juli 2017 - 09:46.

Make something i***-proof and they will build a better i***.


#5 theonlybrand

theonlybrand

    Newbie

  • 45 Beiträge

 

Geschrieben 05. Juli 2017 - 11:24

Wie bestätige ich denn einen CSR per Kommandozeile?


Linux is like a tipi, no gates, no windows, and an apache inside


#6 NorbertFe

NorbertFe

    Expert Member

  • 30.918 Beiträge

 

Geschrieben 05. Juli 2017 - 11:27

https://technet.micr...6(v=ws.11).aspx

-submit ist das was du suchst ;)

Make something i***-proof and they will build a better i***.


#7 theonlybrand

theonlybrand

    Newbie

  • 45 Beiträge

 

Geschrieben 05. Juli 2017 - 11:36

Danke Norbert! Und ich such mich mit sign und co zu Tode  :rolleyes:


Linux is like a tipi, no gates, no windows, and an apache inside




Auch mit einem oder mehreren der folgenden Tags versehen: Windows Server 2012 R2, Active Directory