Jump to content
Sign in to follow this  
Orchard

Cisco 801 Konfiguration

Recommended Posts

Hallo,

 

ich muss einen Cisco 801 ISDN-router konfigurieren. Da ich sowas noch nie gemacht habe, tue ich mir damit ganz schön schwer. Ich habe es bereits geschafft via Hyperterminal mich mit dem Gerät zu verbinden. Auch habe ich bereits mehrere Konfigurationen erfolgreich eingespielt, allerdings klappts trotzdem nicht so richtig.

 

Meine Anforderung an die Konfiguration ist denkbar einfach:

 

Der Cisco steht an Standort B. Am LAN-Port des Ciscos hängen via Switch 2 Netzwerkkameras (IP-Kameras).

 

Vom Standort A (Dort steht ein PC mit ner Fritzcard) soll man sich nun auf den Router einwählen können. Ich denke, dies sollte mit einer einfachen DFÜ-Verbidnung gehen oder?.

 

Im Router muss also nur eine eingehende Verbindung konfiguriert werden. Dazu sollte dann auf jeden Fall ein Benutzername und ein Passwort überprüft werden. Evtl. käme noch in Frage, die eingehende Rufnummer zu prüfen, damit man sich auch wirklich nur von diesem einen PC einwählen kann.

Der Cisco selbst soll also weder ne Wählverbindung noch sonstirgendwas aufbauen sondern lediglich auf einen "incomming call" warten. Findet dieser dann statt, soll der Cisco der Fritzcard eine IP-Adresse mit der gleichen Range wie sein eigener LAN-Port und die beiden Kameras geben und sämtlichen Datenverkehr von der Fritzcard in sein lokales Netz leiten (damit man quasi am Fritzcard-PC nach erfolgreicher einwahl zugriff auf die kameras hat). Klingt eigentlich ganz einfach oder???? ich versuche jetzt schon mehrere Tage mein Glück aber finde absolut keine Lösung. Es gibt zwar tausende Konfigurationen zu irgendwelchen einwahlen aber so gut wie niergendwo den fall, dass man sich in den Cisco nur von außen einwählen kann / soll / können soll.

 

Hat irgend jemand zufällig eine ganz einfache Konfiguration für mich (evtl. noch mit ein paar erklärenden worten zu der konfig damit ichs evtl. auch verstehe)

 

DANKE vorab

 

Gruß

 

Orchard

Share this post


Link to post

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

ist default, bei Bedarf kann man auch service password-encryption aktivieren.

hostname Hauptstelle
!
username xxxxx password xxxxxx

Das ist der Benutzer der sich einwählt

ip subnet-zero
isdn switch-type basic-net3

ISDN-Standard Deutschland

 

interface Ethernet0
description connected to EthernetLAN                                     
ip address 192.168.0.222 255.255.255.0
no keepalive
!
interface BRI0
description connected to Dial-inPCs(ISDN)                                          
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
isdn switch-type basic-net3
no cdp enable
!
interface Dialer1
description connected to Dial-inPCs(ISDN)                                          
ip unnumbered Ethernet0
encapsulation ppp
no ip split-horizon
dialer in-band
dialer-group 1
peer default ip address pool Cisco801-Group-1
no cdp enable
ppp authentication chap pap callin
ppp multilink
!
ip local pool Cisco801-Group-1 192.168.0.111 192.168.0.112

Der IP-Adress-Pool für die Einwahl

no ip http server
ip classless
!
dialer-list 1 protocol ip permit
!
line con 0
password xxxxxx
login
line vty 0 4
exec-timeout 60 0
password xxxxxx
login
!
end

Share this post


Link to post

Hi,

 

ich würde erstmal auf bri und dialer die authentication auf ms-chap stellen mit

 

ppp authentication ms-chap

 

und dann müsste der dialer noch irgendie an den ruf gebunden werden mit dialer remote- name <name der gegenseite> und/oder dialer caller <rufnummer der gegenseite>

 

 

gruss

 

rob

Share this post


Link to post

Wow.... vielen Dank erstmal an alle für die ausführlichen Beschreibungen.

 

Ich habe die erste Konfig mal in den Router geladen und gespeichert (voher natürlich alles mit wr er gelöscht). Die Konfig ging ohne Fehlermeldung einzuspielen (die erste Konfig, die keine Fehler brachte !!!!). Den Router habe ich dann an eine interne ISDN-Dose gehängt und mich versucht mit ner Fritzcard an einer zweiten internen ISDN-Dose zu verbinden. Leider passierte überhaupt nix. Am router haben noch nicht mal irgenwelche lämpchen (außer power) gebrannt. Kann es sein, dass der router an internen S0-Schnittstellen (von einer Tenovis Integral T5-Anlage) nicht richtig funktioniert. An derselben Dose hänge ich normalerweise mit ner FritzCard, diese funktioniert aber problemlos. Müsste nicht normalerweise die Lampe LINE brennen wenn die ISDN-Buchse eingesteckt ist????

 

Danke vorab

 

Gruß

 

Orchard

Share this post


Link to post

Hi,

 

 

mach mal auf dem cisco ein show isdn status und ein sh interface bri0.

 

den output bitte posten...

 

gruss

 

rob

Share this post


Link to post

Hallo,

 

hier der Output für den ISDN-Status

 

Cisco801#show isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

DEACTIVATED

Layer 2 Status:

Layer 2 NOT Activated

Layer 3 Status:

0 Active Layer 3 Call(s)

Activated dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

Cisco801#

 

 

Hier der Output von show intrerace bri0

 

Cisco801#sh interface bri0

BRI0 is administratively down, line protocol is down

Hardware is BRI with S/T interface

Description: connected to Dial-inPCs(ISDN)

 

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation PPP, loopback not set

DTR is pulsed for 1 seconds on reset

Last input never, output never, output hang never

Last clearing of "show interface" counters 01:54:06

Input queue: 0/75/0 (size/max/drops); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/0/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

0 packets input, 0 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

0 packets output, 0 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 output buffer failures, 0 output buffers swapped out

0 carrier transitions

Cisco801#

 

 

Was auch immer mir das alles sagen soll..... ihr könnt hoffentlich damit was anfangen....

 

DANKE vorab

 

Gruß

 

Orchard

Share this post


Link to post

Hi,

 

dein interface bri 0

ist shutdown! :cool:

 

einfach mal no shutdown setzen und nochmal den output posten.

 

gruss

 

rob

Share this post


Link to post

Hi Leute,

 

GENIAL..... es funktioniert. VIELEN DANK AN ALLE FÜR DIE KOMPETENTE HILFE.....

 

ich habe die Passwörter und die IP-Adressen passend abgeändert und die Konfiguration neu eingespielt. Dann habe ich die IP-Kameras an den Router gehängt.....

 

Die Einwahl an den Router klappte mit der Fritzcard problemlos, den router konnte ich auch pingen. Aber die Kamera hinter dem Router konnte ich nicht erreichen.....

 

Da ich das Problem ja schon mit dem BRI0 hatte habe ich einfach mal unter

 

show interface ethernet0

 

geschaut.

 

Auch hier stand was von "is administratively down".....

 

ich hab die schnittstelle mit "no shutdown" (wie beim Bri0 auch) atkiviert, jetzt konnte ich die Kameras erreichen......

 

Folgendes Problem habe ich noch festgestellt:

 

Gestern hatte die Einwahl geklappt. Heute ging sie nicht mehr.... DER FEHLER: der BRI0 war wieder "administratively down". Was kann ich tun, damit der BRI0 und Ethernet0 selbst nach ausstecken des Gerätes NIE MEHR auf Shutdown gehen????

 

Und folgende Frage noch: Wie kann ich die sich einwählenden Personen anhand der ISDN-Einwahl-Rufnummer beschränken?

 

Vielen Dank schonmal vorab und danke nochmal für die schnelle und fachkundige Hilfe......-> MACHT WEITER SO!!!!!

 

Gruß

 

Orchard

Share this post


Link to post

ja, ich hatte die config nachdem ich beim BRI0 "no shutdown" und auch beim ETHERNET0 "no shutdown" eingeben hatte mit "WR" gespeichert. Ich habe den Router gerade nochmal angeschlossen, jetzt sind beide schnittstellen aktivert.

 

Was für mich aber rätselhaft ist: Wenn ich mit sho running-config die Konfiguration auslese taucht weder beim BRI0 noch beim ETHERNET0 dieser "no shutdown" auf!!!! kann mir das mal jemand erklären?

 

Wie schaut es mit der Rufnummernbeschränkung der sich einzuwählenden Usern aus (also dass quasi sich nur die Rufnummer xxxxx / xxxxxx einwählen darf und sonst niemand? Kann mir hier noch jemand den entscheidenden Tipp geben.

 

Danke vorab

 

Gruß

 

Orchard

Share this post


Link to post

Hi,

 

 

die router zeigen das no shutdown meistens nicht an, man kann es aber auch in die config reinschreiben... ist ein interface shutdown, dann steht das auf jeden fall in der config...

 

 

du kannst im isdn eine nummernprüfung machen mit

 

 

int bri0

 

 

isdn caller 123456789

 

 

:cool:

 

gruss

 

rob

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...