Jump to content
Sign in to follow this  
Ciscler

Cisco 1841 to Soho 96

Recommended Posts

Hallo,

 

ich habe mal wieder ein Problem :(

Ich muss einen Cisco 1841 Router per VPN mit einen Soho96 Router verbinden.

Ich möchte dabei einen GRE Tunnel durch den IPSEC Tunnel legen. Die GRE Tunnel lasse ich auf das Loopback Interfaces des anderen Routers abschließen.

 

Der Tunnel baut sich aber nicht auf. Mit show crypto isakmp sa zeigt er mir nichts an.

Router#sh crypto isakmp sa

dst src state conn-id slot status

 

Habe auch das Problem das auf dem Interface wo die Crypto Map dran gebunden ist auf shutdown steht obwohl ich "no shutdown" sage.

Es ist auch nicht möglich die IP-Adressen nachträglich auf dem Interface zu ändern. Entweder mach ich was falsch oder der Cisco spinnt ;-) .

Auf dem Soho 96 habe ich ja nur das ethernet 0 interface auf dem hab ich dann die crypto map gebunden. Wenn ich auf dem ethernet 0 dann noch eine 2. IP lege

(die LAN IP) würde das funktionieren?

 

Es wäre wirklich super hilfreich wenn Ihr mir weiterhelfen könntet. Schonmal Danke im Vorraus. Bin wirklich für jeden Ansatz sehr dankbar.

 

Gruß Dirk

 

Config vom 1841:

 

Building configuration...

 

Current configuration : 2047 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

!

!

username admin privilege 15 password 0 router

!

!

!

crypto isakmp policy 5

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key cisco123 address 195.202.51.43 no-xauth

crypto isakmp keepalive 10

no crypto isakmp ccm

!

!

crypto ipsec transform-set WKFPSET esp-3des esp-sha-hmac

!

crypto map WKFPMAP 1 ipsec-isakmp

set peer 195.202.51.43

set transform-set WKFPSET

match address 100

!

!

!

interface Tunnel0

description Tunnel zum ITZ

ip address 10.241.13.18 255.255.255.252

ip mtu 1384

ip tcp adjust-mss 1344

delay 2000

keepalive 10 3

tunnel source Loopback0

tunnel destination 10.240.13.16

!

interface Loopback0

ip address 10.240.99.16 255.255.255.255

!

interface FastEthernet0/0

description VPN Outside

ip address 195.202.51.42 255.255.255.240

ip access-group 130 in

duplex auto

speed auto

crypto map WKFPMAP

!

interface FastEthernet0/1

ip address 192.168.0.5 255.255.255.0

duplex auto

speed auto

no mop enabled

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Vlan1

no ip address

!

ip classless

ip route 10.240.13.16 255.255.255.255 195.202.51.43

!

ip http server

no ip http secure-server

!

access-list 100 remark erlaubter Traffic im Tunnel

access-list 100 permit ip host 10.240.99.16 host 10.240.13.16

access-list 130 remark OUTSIDE

access-list 130 permit udp any any eq isakmp

access-list 130 permit esp any any

access-list 130 permit ip host 10.240.13.16 host 10.240.99.16

snmp-server community public RO

no cdp run

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

login

!

end

Share this post


Link to post

Config vom Soho 96 Router

 

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

ip subnet-zero

no ip dhcp use vrf connected

!

!

!

!

!

username admin privilege 15 password 0 router

!

!

!

crypto isakmp policy 5

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key cisco123 address 195.202.51.42 no-xauth

crypto isakmp keepalive 10

!

!

crypto ipsec transform-set WKFPSET esp-3des esp-sha-hmac

!

crypto map WKFPMAP 1 ipsec-isakmp

set peer 195.202.51.42

set transform-set WKFPSET

match address 100

!

!

!

interface Tunnel0

description Tunnel zur DVdWK

ip address 10.241.13.17 255.255.255.252

ip mtu 1384

ip tcp adjust-mss 1344

delay 2000

keepalive 10 3

tunnel source Loopback0

tunnel destination 10.240.99.16

!

interface Loopback0

ip address 10.240.13.16 255.255.255.255

!

interface Ethernet0

description VPN Outside

ip address 195.202.51.43 255.255.255.248

ip access-group 130 in

shutdown

crypto map WKFPMAP

!

interface BRI0

no ip address

shutdown

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

ip classless

ip http server

no ip http secure-server

!

!

access-list 100 remark erlaubter Traffic im Tunnel

access-list 100 permit ip host 10.240.13.16 host 10.240.99.16

access-list 130 remark OUTSIDE

access-list 130 permit udp any any eq isakmp

access-list 130 permit esp any any

access-list 130 permit ip host 10.240.99.16 host 10.240.13.16

snmp-server community public RO

!

control-plane

!

!

line con 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

Share this post


Link to post

In der Config wird zwar bei beiden Routern angezeit das die VPN Outside Interfaces auf shutdown stehen.

 

mit show interface ethernet 0 sagt er mir aber das diese up sind. Ich weiss nicht mehr weiter.

 

Router#sh int ethernet 0

Ethernet0 is up, line protocol is up

Hardware is PQUICC_FEC, address is 0013.c3f0.60e3 (bia 0013.c3f0.60e3)

Description: VPN Outside

Internet address is 195.202.51.43/28

MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 10Mb/s

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:26, output 00:00:06, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

145 packets input, 26612 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 input packets with dribble condition detected

1316 packets output, 168282 bytes, 0 underruns

0 output errors, 0 collisions, 1 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...