Jump to content
Sign in to follow this  
Guest

Dienste (DHCP,AD) für RIS auf mehrere Server verteilen

Recommended Posts

Guest

Hallo,

 

ich habe in einer Testumgebung einen RIS-Server installiert und ausführlich getestet. Kenne mich also soweit jetzt gut aus mit der Materie. Ich soll ein Netzwerk aufbauen, in dem ich einen RIS-Server implementiere. Hierbei solllen aber nicht alle Dienste die RIS benötigt (AD, DNS, DHCP) auf einem Server installiert werden, sondern auf mehrere Server verteilt.

 

Ich habe jetzt vor zwei Server zu installieren:

 

1. DC, AD, RIS

 

2. DHCP + DNS (DHCP wird im AD autorisiert!)

 

Es geht um ein Netzwerk in dem später so an die 40 Clients arbeiten sollen. Der vollständigkeithalber: Das netz ist nach außen hin (Internet) durch eine Firewall gesichert. Sollte aber bei der Planung des RIS-Servers keine Rolle spielen.

 

Macht diese Aufteilung der Dienste Sinn oder habt ihr andere Vorschläge für mich?

Bin für alle ideen und erfahrungswerte dankbar.

 

Viele Grüße

littlefisi23

Share this post


Link to post

Ich würde nur den RIS extra nehmen. DC = Infrastrukturserver (bei mir), d.h. DC+ DNS (wichtig wegen AD-integrierte Zonen) + DHCP + WINS + .....

 

Für RIS Images auf jeden Fall eine separate Partition erstellen.

 

grizzly999

Share this post


Link to post
Guest
Ich würde nur den RIS extra nehmen. DC = Infrastrukturserver (bei mir), d.h. DC+ DNS (wichtig wegen AD-integrierte Zonen) + DHCP + WINS + .....

grizzly999

 

Aber soweit mir bekannt ist installiert sich der RIS-Dienst doch in AD hinein, d.h. will ich RIS ausgliedern, muss ich doch auf dem RIS-Server noch zusätzlich ein zweites AD installieren oder?

 

Ganz ehrlich, die RIS-Sache ist eigentlich ganz easy in Betrieb zu nehmen, allerdings bin ich in AD nicht so der Fachmann, da in der Hinsicht ich noch nicht so viele Erfahrungen sammeln konnte. Ich brauche das AD nur aufgrund von RIS damit sich ein Benutzer am AD authentifizieren kann um ein Abbild zu erhalten und um die Computerkonten dort anzulegen, damit niemand fremdes ein Abbild beziehen kann. Ansonsten wird im AD nix konfiguriert (keinerlei Policies etc.) da alles schon per RIPrep-Image mitgegeben wird. Der vollständigkeithalber, softwareverteilung etc. spielt hier überhaupt keine rolle. Auftrag ist nur bei Bedarf ein bestimmtes Image an baugleiche Rechner zu verteilen.

 

Ich möchte DNS und DHCP ausgliedern, damit der RIS-Server unter Last nicht noch die DNS-Fragen abarbeiten muss, sprich installiere ich gerade Rechner mit RIS, können die anderen noch problemlos im Netz arbeiten bzw. surfen. Dies soll nicht beeinträchtigt werden.

 

Macht das sinn?? ;-)

 

Thx für alle ratschläge

Share this post


Link to post
Aber soweit mir bekannt ist installiert sich der RIS-Dienst doch in AD hinein, d.h. will ich RIS ausgliedern,

Nein, der RIS Server installiert sich nicht "ins AD hinein", er muss nur im AD authorisiert werden. D.h. aber nicht, dass er auf einem DC laufen muss.

 

Deine letzte Frage nach dem "Macht das Sinn" habe ich oben bereits aus meiner Sicht beantwortet.

 

 

grizzly999

Share this post


Link to post
Guest

Hi grizzly,

 

d.h. wenn ich jetzt einen Infratsruktur-Server habe mit allen Diensten (AD, DHCP, DNS) also sprich der mein DC ist

 

kann ich noch einen zweiten Windows 2003 installieren, und über die Systemsteuerung "hinzufügen/entfernen" Remoteinstallationsdienste hinzufügen in dem ich diesen RIS-Dienst beim AD auf dem DC autorisiere? Habe ich das so richtig verstanden?

 

Den Sachverhalt wusste ich nicht, wie gesagt habe alles auf einem Server installiert und da ist es ja relativ einfach einzurichten. Dachte immer ich kann auf einem Server nur RIS installieren, wenn auch auf dem selbigen schon ein AD vorhanden ist.

 

Also wenn dem wirklich so ist habe ich dazu gelernt und ich danke dir für den Tipp! Dann ist dein Vorschlag natürlich die optimalere Version.

 

THX!!! :)

Share this post


Link to post
kann ich noch einen zweiten Windows 2003 installieren, und über die Systemsteuerung "hinzufügen/entfernen" Remoteinstallationsdienste hinzufügen in dem ich diesen RIS-Dienst beim AD auf dem DC autorisiere? Habe ich das so richtig verstanden?

Ja, so ist das korrekt. Zum Autorisieren des RIS in der DHCP-Konsole rechte Maustaste auf DHCP -> Autorisierte Server Verwalten -> Autorisieren ->Name oder IP des RIS eingeben ;)

 

 

grizzly999

Share this post


Link to post
Guest

Also hab das jetzt mal so gemacht.

 

Server 1: AD, DNS, DHCP

 

Server 2: RIS

 

RIS und DHCP sind im AD autorisiert. Soweit so gut. Der RIS Server ist auch im DHCP autorisiert.

 

Es ist alles soweit konfiguriert. Problem: Wenn ich versuche einen Client mit RIS zu installieren, erhält dieser keine IP zugewiesen so dass keine Kommunikation stattfinden kann und das ganze abgebrochen wird.

 

Hab die Ereignisanzeige gecheckt, soweit alles in ordnung, dhcp server dienst neu gestartet und auch den BINLSVC Dienst neu gestartet. Tut sich leider nix.

 

Jmd einen rat dafür?

 

Könnte es sein, dass auf dem Server auf dem der RIS-Dienst läuft auch der DHCP Server installiert werden muss? Irgendwie gehört der PXE-Bootvorgang und der Installationsprozess mit RIS ja zusammen. Ist nur eine Vermutung, ich weiß es nicht!

 

Vorab vielen Dank für euren RAT!

 

PS: Achja, am DHCP scheint es nicht zu liegen. Wenn ich ein vorinstalliertes System hochfahre, dann bekommt der Client eine IP zugewiesen. Ich bin da echt ratlos...

Share this post


Link to post
Guest

Ich weiß mein Frage ist etwas speziell, aber ist denn keiner da der eine Antwort auf meine Frage geben kann?

Share this post


Link to post

Wenn ich versuche einen Client mit RIS zu installieren, erhält dieser keine IP zugewiesen so dass keine Kommunikation stattfinden kann und das ganze abgebrochen wird.

Bist du sicher, dass die Netzwerkkarte des Clients voll PXE-kompatibel ist?? Hatte hier in einer Versuchsumgebung das gleiche Problem, mit einer angeblich PXE-fähigen onboard-NIC. Habe dann testweise eine 3com-NIC eingebaut und mit Startdiskette gestartet, dann gings.

Share this post


Link to post
Guest
Bist du sicher, dass die Netzwerkkarte des Clients voll PXE-kompatibel ist?? Hatte hier in einer Versuchsumgebung das gleiche Problem, mit einer angeblich PXE-fähigen onboard-NIC. Habe dann testweise eine 3com-NIC eingebaut und mit Startdiskette gestartet, dann gings.

 

Also ich habe das ganze unter VMWare 5.5 nachgestellt. Sowohl die beiden Server als auch der Client sind also auf virtueller Basis getestet worden. Ich könnte schwören dass das vor einem halben Jahr noch unter VMWare ging, allerdings bin ich mir da nicht sicher. Hat da jmd Erfahrungen sammeln können? Vielleicht häng ich da mal nen wirklichen client ans netz und probier es so nochmal aus..

 

Ich bin davon überzeugt das es auf jeden fall nicht am dhcp liegt, weil fährt man (auch unter vmware) ein system hoch, verteilt dieser die IP-Konfiguration an den Client.

Share this post


Link to post

Erstelle im AD ein Computerkonto für den neuen Rechner. Während der Erstellung setze den Haken "Das ist ein verwalt..... Rechner" (hab nicht richtig im Kopf) und gib den GUID des Rechners ein. GUID (eine 32-stellige hexadezimale Reihenfolge) kannst du beim Start des Rechners ablesen. Muss ohne Bindestriche eingegeben werden.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...