Jump to content
Sign in to follow this  
Undying

HTTPS - SSL Verbindung

Recommended Posts

Hallo!

 

Ich bin gerade etwas verwirrt. Kann ich nicht 2 Websites mit SSL Bereitsstellen?

 

Die erste Website (Exchange Webmail) ist intern über http://webmail.domain.at/exchange/ bzw. mit https:// erreichbar. Soweit so fein.

 

Mein Intranet (2te Website) ist über http://intranet.domain.at/ erreichbar. Über https:// komm ich allerdings nciht auf die Intranetwebsite sondern auf die Webmail-Site (https://intranet.domain.at/exchange/

 

Geht das schlichtweg nicht? Oder liegt der Fehler wo anders?

 

Danke!

 

Undying

Share this post


Link to post
Share on other sites

Hi,

 

Du brauchst für jede Website ein eigenes Zertifikat. Auf dem Zertifikat ist der Name eingetragen und zwei verschiedene Domains mit einem Zertifikat sind daher nicht möglich.

 

Gruß

Dirk

Share this post


Link to post
Share on other sites

Hmm ok. Eigentlich ist es mir egal ob im internen Netz die Seite via http oder SSL aufgerufen wird.

 

Hab 2 Zertifikate. Eines hängt schon am Standard Ordner (Standardwebsite) und lautet publishing.domain.local

 

Das 2te Zertifikat hängt an der Intranet-Website. (intranet.domain.at)

 

Intern funktionierts wenn ich via http:// zugreife. Allerdings wenn ich https://intranet.domain.at versuche dann land ich beim webmail.

 

von extern funktionieren (ISA 2004) durchden Weblistern und die dortigen regeln sowohl webmail (via https://) als auch Intranet (via https://)

Share this post


Link to post
Share on other sites

Hallo,

 

Du mußt für die 2. Seite einen anderen Port für SSL benutzen, dann geht das das. Allerdings wird Dir eine Warnung wg. des "falschen" Zertifikats angezeigt.

 

Gruß Kai

Share this post


Link to post
Share on other sites

Dann kommt, dass dieses Port nicht für SSL Konfiguriert ist. Mah das gfalllt mir alles nicht ;-/ Vorallem hab ich auch wieder ein Problem wenn ich immer das Port angeben musst, da dies von außen nicht mehr funktionieren würde ...

 

Von Außen komm ich, dank ISA, auf die SSL Seiten (auf beide!) intern würd mir schon reichen, dass ich von https auf http umgeleitet werde. Nur bekomm ich auch das nihct hin!

 

Achja bitte nimm den link oben raus. Hatte das nur unabsichtlich angegeben! Wäre dir dankbar :o)

Share this post


Link to post
Share on other sites

Hmmm,

 

denke das hat was mit virtuellen Verzeichnissen zu tun

Ich habe

 

a) Exchange webmail (SSL, 443):

 

b) Trend Micro Officescan (SSL, 4343)

 

somit das ganze über verschiedene Ports gelöst,

vielleicht weiß ja jemand mehr.

 

Gruß Kai

Share this post


Link to post
Share on other sites

Hallo!

 

Ich hab das Problem in der zwischenzeit gelöst. Ich habe eine 2te (interne) IP an den Netzwerkadapter gebunden. Danach mit httpcfg.exe die IP dem IIS bekannt gemacht.

 

Die erste SSL Seite hab ich dananch an LAN IP1 mit Port 443 und die zweite an LAN IP2 mit Port 443 gebunden.

 

Pfeift wunderbar. Ins Web pupliziere ich die beiden SSL Seite via ISA 2004 und einem Wildcard Zertificat.

 

Danke für euere Hilfe!

Undying

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...