Jump to content

Boot Problem


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Also ich habe eine Festplatte mit zwei Partitionen, auf der einen liegt WinXP prof. , auf der anderen Win2k.

Leider ist irgendwas mit dem MBR oder ähnlichem nicht in Ordnung und der PC bleibt beim booten hängen und gibt keine Fehlermeldung aus.

Wenn ich mit der Wiederherstellungskonsole von Xp mit bootcfg /rebuild arbeite, findet er beide Installationen, wenn ich dann aber einen Namen und die Startart (/fastdetect) eintrage kommt nur: "Der ausgewählte Starteintrag konnte nicht zur Startleiste hinzugefügt werden."

 

Ich habe gerade nochmal mit "Knoppix" geschaut und festgestellt das auf keiner Partition eine boot.ini existiert. Aber die müsste ja theorethisch mit /rebuild geschrieben werden, oder nicht?

 

Liegt es vielleicht daran das ich mit fdisk die Primäre Partition (also die gesamte 40GB Platte die in obere zwei Partitionen unterteilt ist) zur aktiven partition gemacht habe?

 

Ein fixmbr bringt auch nix und bei fixboot meint er auch das es nicht möglich ist, weiß aber leider nicht mehr die genau Fehlermeldung.

 

Any help? Ich bin echt am verzweifeln...

 

TIA Daniel

Link to comment

Also ich habe jetzt die Win2000 Installation platt gemacht und die Partition neu formatiert. Windows 2000 neu installiert läuft auch wunderbar.

Ich habe jetzt einen kleinen Bereich C:\ (8MB) auf dem die ganzen Sachen wie boot.ini, ntldr etc. liegen.

D:\ ist dann ist dann meine Daten Platte, auf E:\ befindet sich die neue 2k Installation und auf F:\ die alte XP Installation an die ich nicht mehr rankomme.

 

Die boot.ini wurde von der 2k Installation so eingerichtet:

 

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(2)\WINNT
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Microsoft Windows 2000 Professional" /fastdetect

 

(Die Win 2k Installation ist also scheinbar auf der zweiten Partition meiner 40GB Platte.)

 

Also müsste doch logischerweise die alte XP Installation aud der ersten Partition liegen sprich, müsste angesprochen werden wenn ich in der boot.ini folgendes ergänze:

 

multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows XP Professional" /fastdetect

 

Wenn ich aber die boot.ini um diesen Eintrag erweitere und neue boote und Win Xp auswähle kommt die Fehlermeldung das die Datei ntoskrnl.exe beschädigt oder nicht verfügbar ist.

 

Wenn ich in besagtem Verzeichnis nachschaue ist sie jedoch vorhanden.

 

 

Vielleicht weiß ja jetzt jemand was ich machen kann...

 

P.S. Hab schon nach ntoskrnl.exe Probs. gesucht aber nix passendes gefunden...

 

Thx

Link to comment

Hi Daniel !

Es ist aus der Ferne wirklich schwierig, Deine Partitionierung der HD nachzuvollziehen.

Als Dein ursprüngliches System noch lief, welchen Laufwerksbuchstaben hatten die beiden Systeme jeweils ?

Was mich vor allem wundert, ist, daß Win2000 auf der 2. Partition liegt, mit dem Buchstaben E: :confused:

 

Ansonsten: WinXP kannst Du nicht mit ntdlr und ntdetect.com von Win2000 starten, dazu sind die Versionen von XP notwendig.

Die könntest Du allerdings in der XP-Wiederherstellungskonsole mit fixboot reparieren.

Dann würde aber XP auch nur wieder starten, wenn es vorher wirklich auf der ersten Partition war, was ich ehrlich gesagt nicht glaube.

Wahrscheinlich liegt auf der 1. Partition jetzt Deine 8MB-Partition und XP auf der 4. Partition.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...