Jump to content
Sign in to follow this  
wolly

priv1.db exchange 2000 macht probleme

Recommended Posts

Hallo liebe Gemeinde,

 

ich hab da ein kleines Problem mit meinem Exchange 2000 auf win2000 server in der AD.

 

Ich kriege seit 10 Tagen folgende Fehlermeldung in den Eventlogs:

 

Information Store (1832) Überprüfung der aus Datei "D:\mailboxstore\priv1.edb" bei Offset 4557357056 (0x000000010fa3c000) für 4096 (0x00001000) Bytes gelesenen Datenbankseite ist durch eine Inkonsistenz der Seitenzahlen fehlgeschlagen. Die erwartete Seitenzahl war 1112635 (0x0010fa3b), die tatsächliche Seitenzahl 1007188003 (0x3c087823). Fehler -1018 (0xfffffc06) bei Leseoperation.

 

Auswirkungen gibt es momentan keine. Alle User können prima exchange nutzen und ausser einer kleinen Fehlermeldung sicher backupexec die priv1.edb auch reibungslos.

 

Nun mag ich aber solche Meldungen nicht, da sicher irgendwann mal ein Fehler kommt, der darauf zurückzuführen ist und ich steh vor dem gleichen Problem.

 

Problem ist, dass ich im Urlaub war und meine Vertretung hat es verpasst das backup in den letzten 10 Tagen einzuspielen und somit der Sache aus dem Weg zu gehen. Nun haben die clients schon fleissig mails geschrieben und die möchte ich denen ja nicht nehmen.

 

Soll ich das Eseutil mal ausführen für eine "weiche" Reorganisation? Das könnte doch erfolgsversprechend sein, oder?

 

Danke für Hilef und Warnungen ...

 

 

Wolly

Share this post


Link to post
Share on other sites

Danke Günther! Hab mir den Artikel mal aufmerksam durchgelsen und stosse da auf folgendes ...

 

ISINTEG ist daher nicht so "scharf" wir ESEUTIL, da es keine Seiten löscht. ISINTEG geht aber davon aus, dass die Datenbanken konsistent sind, d.h. bei einem -1018 Fehler oder ähnlich gravierenden Problemen muss die Datenbank erst konsistent gemacht werden.

 

 

Sollte ich trotzdem ISINTEG ausführen und dann mal sehen, was die Tests bringen? Und dann gegenenfalls mit -Fix arbeiten?

 

Gruss

 

Wolly

Share this post


Link to post
Share on other sites

Bin auch nochmal die ganzen logfiles durchgegangen und das Problem tritt auf, seit eine korrupte mail von backupexec angemeckert wurde und der Kollege diese entfernt hat. Die mails werden jetzt nicht mehr aufgeführt, das beschreibene problem blieb zurück. Also schliesse ich einen Hardwaredefekt aus. Scheinbar stimmt einfach die Zuordnung seit der defekten mail nicht mehr.

Share this post


Link to post
Share on other sites

Hallo Günther,

 

gesagt getan, ich habs versucht. Das Problem: Insinteg läuft nicht.

 

Im Einsatz ist Exchange 2000. Also bin ich rein in C:Programme/exchgsrvr/bin und starte Insinteg mit folgendem Kommando: (- Servername ist VVHHCD)

 

isinteg -s VVHHCD -test alltests

 

Aber ich bekomme immer wieder die Auflistung der Parameter wie bei -?.

Hab auch mal versucht den Pfad zur DB mit -t anzugeben,a ber da geht nix.

 

Liegt es daran, dass unsere priv.EDB auf einem anderen laufwerk liegt als der ordner exchsrvr?

Share this post


Link to post
Share on other sites

Hi.

 

Der Befehl ist so richtig und sollte dir eigentlich die vorhandenen DB'S anzeigen, mit der Meldung das isinteg nur dann ausgeführt werden kann, wenn die Bereitstellung der DB's aufgehoben wird.

 

Es spielt keine Rolle wo die Datenbanken liegen.

 

Versuche einmal den Pfad zu isinteg in "Path" aufzunehmen.

 

LG Günther

Share this post


Link to post
Share on other sites

OK, ich hab Ihn jetzt in den path aufgenommen und versuch es am we nochmal. Mal sehen ob das geht. Währed des laufenden Betriebes hier im Haus ist das nicht so nett.

 

Die Bereitstellung der betroffenen DBs hab ich übrigends aufgehoben, den Informatuionsspeicher-Service aber laufen lassen. Das ist doch Ok so, oder?

 

Kann ich etwas kaputt machen, wenn ich das Insinteg während des Betriebes starteum zu testen, ob das mit dem path-Eintrag nun geht? Eigentlich doch nicht, weil er mir doch dann nur die Fehlermeldung geben müsste, dass ich die DBs erst unmounten muss, oder?

 

Gruss

 

Wolly

 

PS: Sorry, aber bei Insinteg bin ich auf dem Weg zum MCSE noch nicht gelandet :-)

Share this post


Link to post
Share on other sites

Hi.

 

Nein kann nichts passieren.

 

Du bekommst die Meldung welche DB's vorhanden sind inkl. Status (onmline/offline) und dann die Meldung, das ISINTEG eben nur dann ausgeführt werden kann, wenn die Bereitstellung der DB's aufgehoben wird.

Dann kannst du die weitere Ausführung des Befehls abbrechen.

 

LG Günther

Share this post


Link to post
Share on other sites

freu freu ... das geht schon mal ... jetzt krieg ich auch endlich die anzeige welche dbs online sind. werde dann am we mal versuchen die db zu fixen. danke bis hierher, günther !!!!

Share this post


Link to post
Share on other sites

Hallo Günther,

 

ISINTEG hat zwar ein paar Fixes gemacht und beim zweiten Test hat er Null Fehler angezeigt, mein backup Exec sagt aber noch immer, dass die Datei "Postfachspeicher (VVHHCD)" beschädigt ist. Diese Datei kann nicht überprüft werden.

 

Habe ich noch andere Möglichkeiten? Hat jemand sonst das Problem schon gehabt?

Share this post


Link to post
Share on other sites

Hier die passende Fehlermeldung auf dem Exchange-Server:

 

 

Ereignistyp: Fehler

Ereignisquelle: ESE

Ereigniskategorie: Protokollierung/Wiederherstellung

Ereigniskennung: 475

Datum: 08.09.2005

Zeit: 02:33:46

Benutzer: Nicht zutreffend

Computer: VVHHCD

Beschreibung:

Information Store (1920) Überprüfung der aus Datei "D:\mailboxstore\priv1.edb" bei Offset 4557357056 (0x000000010fa3c000) für 4096 (0x00001000) Bytes gelesenen Datenbankseite ist durch eine Inkonsistenz der Seitenzahlen fehlgeschlagen. Die erwartete Seitenzahl war 1112635 (0x0010fa3b), die tatsächliche Seitenzahl 1007188003 (0x3c087823). Fehler -1018 (0xfffffc06) bei Leseoperation.

Share this post


Link to post
Share on other sites

Hi.

 

Die Fehlermeldung sagt, das eine Datenbankseite korrupt ist, und anscheinend konnte auch ISINTEG das Problem nicht beheben.

MS meint dazu lapidar - Datenbank aus Sicherung wieder herstellen.

 

Möglichkeit:

Mit BackupExec eine Sicherung aus Postfachbasis durchführen. Dann sollte dir eigentlich angezeigt werden in welchen Postfach der Fehler liegt. Dieses Postfach exportieren, löschen und dann wieder herstellen.

 

LG Günther

Share this post


Link to post
Share on other sites

Wenn ich mir mal die Wiederherstellung ansehe, zeigt Backup Exec mir bei den Microsoft Exchange Mailboxes (dort wo die alle einzeln aufgelistet sind) bei keiner Mailbox ein Problem. Nur unter dem Punkt Microsoft Information Store/Erste Speichergruppe ist ein Warnzeichen bei der Sicherung von gestern und da wird der Postfachspeicher als beschädigt ausgewiesen.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...