Jump to content

SBS2K3, Backup Exec 9.1 und Exchange


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo @all,

 

ich habe ein Problem mit dem Sichern des Exchange Servers auf dem SBS2K3 und weiss mittlerweile nicht mehr weiter...

 

Folgende Situation:

Auf einem SBS2K3 ist Backup Exec 9.1 SP2 mit allen Hotfixen installiert. Während der Installation von Backup Exec habe ich ganz normal einen User x eingerichet, der die Datensicherung durchführt. Nach der Installation habe ich eine Testsicherung eingerichtet, die auch wochenlang reibungslos funktioniert hat. Alles, angefangen von den lokalen Daten über den kompletten Exchange Server bis hin zum 2. W2K3 Server wurde anstandslos gesichert.

Dann habe ich offensichtlich einen Fehler begangen und habe mich mit dem User x über OWA angemeldet, da ich die ganzen gesendeten Objekte (ich lasse mich über die Sicherung per Mail informieren) löschen wollte, damit das Postfach vom User x nicht überläuft.

Von da an fingen die Probleme an. Backup Exec konnte nicht mehr auf den Exchange Server zugreifen. Ich erhielt ständig die Fehlermeldung "Access denied", wenn ich auf den Exchange über Backup Exec zugreifen wollte. Auch das Einrichten eines 2. Anmeldekontos, das Konto des Administrators, hat nix gebracht. Kein Zugriff.

 

Ich habe im Netz gegoogelt, war auf der Seite von Veritas und habe auch einige KB-Artikel gefunden (Document IDs 234575, 266075, 269946), aber nix hat geholfen.

Dann habe ich den User x aus der AD und aus Backup Exec gelöscht und einen neuen User eingerichtet und siehe da, es funktionierte wieder! Super dachte ich mir, jetzt willst Du es aber nochmal wissen und hab mich wieder mit diesem User über OWA angemeldet und was ist passiert? Genau... wieder kein Zugriff auf den Exchange Server.

 

Ich versteh das nicht... wieso hab ich keinen Zugriff mehr auf den Exchange Server, sobald ich mich mit dem User auf den Exchange Server anmelde? In einem KB-Artikel von Veritas stand, das man Outlook auf dem Exchange Server installieren soll, aber das werde ich natürlich NICHT machen! Was hat Outlook auf einem Server verloren? Vor allem auf einen Exchange? MS rät ja auch davon ab.

 

Ich weiss nicht mehr weiter.... :( Ich kann doch nicht ständig einen neuen User für Backup Exec kreiren, wenn ich mich mit dem aktuellen per OWA anmelde!

 

Hat jemand eine Idee, oder einen Tipp für mich?

 

*edit: der User ist natürlich sowohl lokaler als auch Domänen-Admin. Mittlerweile verschickt er noch nicht einmal Mails über Backup Exec... HILFÄÄÄÄÄÄÄÄÄÄÄÄÄ :(

Link to comment

Hat denn keiner von euch eine Idee, oder kennt das Problem...? :(

 

Oder anders gefragt: Wie macht ihr das mit der Sicherung des Exchange Servers auf einem SBS mit Veritas Backup Exec? Es werden doch sicherlich von euch einige Backup Exec und nicht das integrierte ntbackup von Windows benutzen.

Link to comment

Hy Dominique,

 

sorry, die Lösung habe ich auch nicht, ich bekomme nur bei den Kunden so einiges mit, habe aber selber mit BE wenig zu tun.

Möchte nur kurz eine Info loswerden:

 

Soweit ich das weiß, sollte laut Veritas auf dem Server, der das BE fährt, ein Outlook installiert sein, weil die MAPI-Komponenten für die Postfachsicherung benötigt werden... daher die Outlook-Installation. Veritas geht in diesem Falle wohl eher davon aus, daß es ein separater Server ist, der KEIN Exchange fährt...

 

Dies nur zur Info.

 

Und jetzt noch einen Workaraound:

 

Warum vergibst Du Dir nicht die Berechtigungen für Deinen normalen Domänenaccount auf die Mailbox des Sicherungskontos (User x) und öffnest es zusätzlich in Deinem Outlook ? Dann kannst Du ganz geschmeidig die gesendeten Objekte desPostfachs User x löschen, ohne Dich mit diesem User am Exchange anmelden zu müssen...

 

Hoffe, das kann Dir helfen ;-)

Ist zwar ein Umgehen des Problems, aber wenn es so funzt ...

 

Grüsse

 

schroeder750

Link to comment

Hallo schroeder :)

 

erstmal vielen Dank für Deine Antwort :)

 

Das BE die MAPI-Komponenten für die Postfachsicherung benötigt habe ich auch in einen der unzähligen KB-Artikel von Veritas gelesen, nur das sich diese auf ältere Versionen bezogen und laut Veritas (wenn ich das richtig im Kopf habe), das Problem ab BE 9.x behoben sein sollte.

 

Des weiteren gibt es ja speziell für den SBS eine BE Version, die alle Komponenten wie Exchange- und SQL-Server abdeckt, bzw. mitsichert. D.h. diese Version wird auf dem Server installiert und sollte (dachte ich) auch dem entsprechend funktionieren.

 

Das gleiche Problem ist mir beim googlen ein paar mal über den Weg gelaufen, aber irgendwie hat keiner eine Antwort drauf.. :(

 

Der Vorschlag mit dem "umbiegen" auf den normalen Domänenaccount ist eine gute Idee :) Da ich keine eigene Workstation in der Domäne habe (Kunde, Suport und Administration per Remote) bin ich schlicht und ergreifend nicht drauf gekommen ;) Dann werd ich mir halt ne alte Kiste dort hinstellen :)

 

Ich werd das auf jeden Fall ausprobieren und das Ergebnis hier posten.

 

Erstmal danke und falls jemand des Rätsels Lösung kennt, immer her damit :)

Link to comment

Also ich war nochmal auf Veritas und hab nochmal nachgeschaut und siehe da... ich hab einen Artikel gefunden der das Problem löst.... http://seer.support.veritas.com/docs/273168.htm

 

Damit das Anmeldekonto von BE Zugriff auf die Exchange DB hat, muss die Mail-Adresse in der Adressliste (GAL) sichtbar sein... Das hatte ich immer unterbunden, weil die User diese Mail-Adresse nicht zu wissen brauchen :rolleyes:

 

Der Zugriff auf Exchange über OWA funzt auch :)

 

Wieder was dazu gelernt und ein paar graue Haare mehr.. hm.. sollte anfangen sie mir zu färben :D

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...