Jump to content

Copy-Befehl


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

hi leuts,

 

ich will ein Userprofile direkt auf unserem Server zwecks Backup speichern.

Befehl in der "Backup.bat" lautet wie folgt, funtzt aber nicht:

 

copy c:\Dokumente und Einstellungen\UserX\*.* Z:\

 

=> ich glaube, dass die Leerzeichen das Problem sind. Die Help-Syntax des Copybefehls hat mir aber leider auch nicht weitergeholfen.

Noch was: Wie kann ich verhindern, dass er den User jedesmal fragt ob er die Dateien überschreiben soll? In der Helpsyntax steht da was von "\V" drinnen um diese Meldung zu unterdrücken und einfach immer zu überschreiben. Aber an welche Stelle muss ich das einbauen falls es dieser Parameter überhaupt ist?!?!?!

:confused:

Bitte um Rat

Link to comment

Pfade mit Leerzeichen umschliesst du einfach mit Anführungszeichen.

 

Benutz besser Xcopy, da du ja wahrscheinlich auch Unterverzeichnisse mitkopieren willst.

 

Das würde dann ungefähr so aussehen:

 

xcopy "c:\Dokumente und Einstellungen\UserX\*.*" Z:\ /Y /E

 

Erklärung:

 

/Y Unterdrückt die Aufforderung zur Bestätigung, dass eine vorhandene Zieldatei überschrieben werden soll.

 

/E Kopiert alle Unterverzeichnisse (leer oder nicht leer).

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...