Jump to content
Sign in to follow this  
Oliver-kiel

Unattended $OEM Verz.

Recommended Posts

Hallo zusammen,

ich habe da noch ein kleines Problem, jedoch keine Lösung auf den Seiten hier gefunden. Ich will XPSP2 unattended uebers Netz installieren, das klappt auch soweit alles, nur mein $OEM Verzeichniss wird nicht mitkopiert und ich muss auch den Lizenzevertrag annehemen und PC-Name U.S.W. angeben......

Die Dateien befinden sich im Ordner XPSP2 auf dem Server und die installation rufe ich ueber den generierten Batch - File auf, nur die Pfad angabe habe ich angepasst und die WINNT.SIF bzw. unattended.txt habe ich nach meinen Bedürfnissen angepasst....

Boopten tue ich mit einer Netzwerkbootdisk und mappe dann mein Netz-LW G:\xpsp2\I386 und starte dann die unattended.bat

 

MFG Oliver-kiel

Share this post


Link to post
$OEM Verzeichniss wird nicht mitkopiert

Das $OEM$ Verzeichnis wird auch nicht mitkopiert, es gibt auch keine Option dafür. Was willst du genau kopieren?

 

Und wenn die Antwortdatei nicht ausgwertet wird, dann ist entweder was falsch drin (aber alles falsch drin ist unwahrscheinlich) oder sie wird nicht gefunden oder nicht angegeben.

Eine Fehlerdiagnose von hier aus ist aber leider mit

Boopten tue ich mit einer Netzwerkbootdisk und mappe dann mein Netz-LW G:\xpsp2\I386 und starte dann die unattended.bat[/Quote]

nicht möglich, dazu müsste man allerhand mehr wissen (wo liegt die Antwortdatei, wie sieht der Aufruf in der Batch aus

 

Ah Moment, ich lese gerade: du willst das nur das SP unattended installieren. Das geht aber über <sp-pfad>\update.exe /q /u /tralala

 

Was du da machst, wäre eine unbeaufsichtigte Installation des Betriebssystems. Dazu braucht man das original Betriebssystem, nicht ein ServicePack. :rolleyes:

Überprüfe doch noch mal dein Anliegen und dein Vorgehen

 

 

grizzly999

Share this post


Link to post

Hallo ,

ich habe Das Bs Windows Xp mit SP2 (Slipstreamen) auf meinem Server im Verz. XPSP2 liegen, die Winnt.sif liegt im I386 Verz.

Meine Batch ist der Standard vom Setupmgr.exe

zusätzlich befindet sich in dem $OE; Verz. meine Software Office 2003 O&O und einige andere Sahcen von der CD funktioniert die Unattended Installation einandfrei, es ist aber lästig, ständig die CD mit sich rumzutragen, wenn es denn auch uebers Netzwerk Geht....

Es ist nut komisch das er das $OEM nicht mitkopiert

Share this post


Link to post

Warum schreibst du das nicht gleich, dass das eine Slipstream Installation ist?

 

Wie gesagt, das $OEM$ Verzeichnis wird nicht mitkopiert, es ist lediglich ein Distributionspunkt. Man kann darunter ein Verzeichnis C oder D oder E (...)anlegen, dann wird alles was da drunter ist, nach C oder D oder E (...)kopiert. Mann stattdessen unterhalb von $OEM$ auch ein Verzeichnis $1 oder $2 oder $3 (...), dann wird alles unter dem jeweiligen Ordner auf die erste, zweite, dritte (...) Partition kopiert.

 

Warum deine Antwortdatei nicht ausgewertet wird, weiß ich nicht, mehr Informationen liegen bisher noch nicht vor.

 

grizzly999

Share this post


Link to post

Das $1 Verz. und dann Install usw blablabla habe ich alle hier meine winnt.sif habe sie komplett von cd uebernommen und nichts dra geändert...

Zudem benutze ich auch noch die RunOnceEx Methode

;SetupMgrTag

[Data]

AutoPartition=0

MsDosInitiated="0"

UnattendedInstall="Yes"

UseWholeDisk=Yes

 

[unattended]

UnattendMode=FullUnattended

OemPreinstall=Yes

OemSkipEula=Yes

TargetPath=\Windows

Filesystem=*

UnattendSwitch="yes"

WaitForReboot="No"

DriverSigningPolicy=Ignore

Repartition=Yes

OemPnPDriversPath="Drivers\"

DriverSigningPolicy=Ignore

 

[GuiUnattended]

AdminPassword=*

EncryptedAdminPassword=No

OemSkipRegional=1

TimeZone=110

OemSkipWelcome=1

 

[userData]

ProductKey=XXXXX-XXXXX-XXXXX-XXXXX-XXXXX

FullName="AMDt"

OrgName="Database"

ComputerName=Database01

 

[RegionalSettings]

LanguageGroup=1

Language=00000407

 

[identification]

JoinWorkgroup=Arbeitsgruppe

 

[Networking]

InstallDefaultComponents=Yes

 

[branding]

BrandIEUsingUnattended=Yes

 

HomePage=http://www.Google.de

SearchPage=http://www.Google.de

 

[shell]

CustomDefaultThemeFile = "%SYSTEMROOT%\Resources\Themes\UNATTENDED.Theme"

Share this post


Link to post

Ich rufe die Unattended folgendermassen auf, mal sehen ob ich das aus dem kopf hinbekomme

set bla bla bla

set blablabla

winnt /:s%setupfiles% /unattend:%AnswerFile%

so ungefähr sieht der Aufruf aus, und danke fuer das unkenntlich machen des Keys, das nächste mal passe ich besser auf

Oliver-kiel

Share this post


Link to post

Ahja, das typische Murks-File vom Setupmanager :cry::cry: (meine nicht dich, sondern den bl.....den Setupmgr ;) )

Das mit den set und nachher verwenden der Variablen ist ja ganz schnuckelig, ich mach's immer raus und gebe die Pfade und Dateien direkt an (empfehle ich auch immer). Egal. ABER: Deine Netzwerkboot-Disk ist bestimmt DOS oder Win9x, und da lautet der Aufruf numal winnt.exe (scheinst du ja geändert zu haben, denn der Setupmanager schreibt immer winnt32.exe rein) mit dem Parameter /u:, nicht /unattend: ;)

 

 

grizzly999

Share this post


Link to post

Oh mann, dann wird es wohl evtl. nur an dem /u: anstatt unattend gelegen haben,, Sag mal, wie gibst du denn die Pfade direkt ohne variablen an ??? So ein grosser Scripter in batch bin ich noch nicht.........

Und danke fuer die Hilfe

Share this post


Link to post

Ich mappe das freigegebene Laufwerk auf dem Server auf einen Buchstaben, klar z.B. net use i: \\server\install

Dort direkt in i: liegt bei mir übrigens immer die unattend.txt, die winnt.exe, die smartdrv.exe (die meistens keinen Platz mehr auf meiner Netzwerkboot-Disk hat) und evtl Tools wie format.com, fdisk.exe

Unterhalb des Verzeichnisses Install liegt dann erst der I386 Ordner. Muss man aber nicht so machen. Aber davon ausgehend, dass direkt im Install die Antwortdatei und die dorthin kopierte winnt.exe liegt, sieht das bei mir in der unattend.bat dann so aus

 

i:\winnt.exe /u:i:\unattend.txt /s:i:\i386

 

 

grizzly999

Share this post


Link to post

Hallo zusammen,

ich habe da immmer noch ein Problem bei meiner Unattended Installtion uebers das Netzwerk, alles funktioniert einwandfrei, aber der Inhalt des $OEM$ Verz. wird einfach nicht auf die Platte nach C:\install kopiert, ich weiß langsam echt nicht mehr weiter, wäre schön wenn jemand einen RAt dazu hätte, wie ich das Problem beheben kann....

MFG Oliver-kiel

Share this post


Link to post

XPSP2

--------$OEM$

---------$1

----Drivers

Install

$$

----System32

Web

$Docs

$Progs

cmpnents

I386

 

Also, so in ungefähr sieht mein Verz. aus ich hoffe es reicht zur Ansicht aus....

MDG Oliver-kiel

Share this post


Link to post

Laufen deine Baumäste optisch von rechts nach links, befindet sich also bei dir Install unterhalb von Drivers und das unterhalb von $1 ?

Sieht fast so aus. Aber das $OEM$-Verzeichnis mit allem drum und drunter muss unterhalb vom I386 liegen.

 

Ich zeige dir jetzt, wie das bei mir aussieht. Als Anmerkung: Das Verzeichnis Install ist bei mir die Freigabe, auf die vom Netzwerk aus zugegriffen wird, und das einzige, was bei mir im Verzeichnis Install liegt, sind die paar vorgestern schon beschriebenen Dateien. Dann muss das so aussehen:

 

-Install

----I386 (mit allen SubDirs von der CD)

--------$OEM$

------------$1

---------------Drivers

------------$$

 

 

grizzly999

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...