Jump to content
Sign in to follow this  
klaeuser

Authentifizierung in verschiedenen Domainen

Recommended Posts

Hallo allerseits,

 

hier ein sehr interessantes Problem.

Ich habe hier einen Webserver der in einer DMZ (keine Domaine)steht. Auf die Anwendung auf diesem Server kann ich aus unserem Büro LAN ohne Probleme zugreifen.

Zusätzlich gibt es eine LAN-Verbindung zu einer anderen Firma die eine eigene Domaine hat.

Wenn jetzt ein Mitarbeiter dieser Firma versucht auf die Webanwendung zuzugreifen, erscheint wie auch bei uns ein Anmeldefenster. Eine Homepage ohne Authentifizierung auf dem gleichen Server kann er ohne Probleme sehen.

Gibt er jetzt seinen Usernamen und Passwort ein, passiert nichts. Folgende Einträge sind im Proxy der anderen Firma zu sehen:

 

[07/Sep/2004:10:05:17 +0200] - 10.55.32.70 TCP_HIT/200 4769 GET

http://xyz/images/english.jpg g0221 - "image/jpeg" -

[07/Sep/2004:10:05:34 +0200] - 10.55.32.70 TCP_MISS_PRIVATE_STATUS_CODE/401

4776 GET http://xyz/ice/'>http://xyz/ice/'>http://xyz/ice/ g0221 DIRECT/149.192.96.205

"text/html" -

[07/Sep/2004:10:05:44 +0200] - 10.55.32.70 TCP_MISS_PRIVATE_STATUS_CODE/401

4611 GET http://xyz/ice/ g0221 DIRECT/149.192.96.205

"text/html" -

[07/Sep/2004:10:05:45 +0200] - 10.55.32.70 TCP_MISS_PRIVATE_STATUS_CODE/401

4378 GET http://xyz/ice/ g0221 DIRECT/149.192.96.205

"text/html"

 

Außerdem kat mir der Typ der NW-Truppe der anderen Firma noch gesagt das unser Server NTLM (? Intergratet Windows Authentication) verlangt und der Client dann die Domaine der anderen Firma mitschickt. Das akzeptiere dann unser Server nicht. Wie gesagt, der Server steht in einer DMZ ohne Verbindung zu einer Domaine, und Unser Büronetz ist in einer Domaine.

Die Intergratet Windows Authentifizierung muss aktiviert bleiben, da sonst die Webanwendung nicht funktioniert.

 

Nun steh ich da und komm nicht weiter.

 

Kann man unter Umständen dem Webserver die Domaine bekanntmachen. Oder gibts da eine andere Möglichkeit.

 

Gruss

Klaus

Share this post


Link to post

Hallo,

 

der Techniker hat schon recht. Wenn Dein Standalone-Server eine eigene Domain hat, dann kann die NTLM durchaus Probleme bereiten. Wenn das andere Netzwerk beispielsweise ein NW-Netzwerk ist, dann benötigst Du auf jeden Fall den Gateway-Dienst für Novell NetWare auf Deinem Server, damit die NTLM die Anmeldeinformation auswerten kann. Alternativ kannst Du einmal schauen, ob die Anmeldung an Deinem Server eine NetBios-Anmeldung ist (nur bei einer NT-Domäne). Dann mußt Du diese zulassen.

Alternativ kannst Du den IE auch ohne Windows-Authentifizierung konfigurieren.

 

mfg Andreas

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...