Jump to content

Login Script - cmd.exe


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

ich habe bei mir zuhause einen W2K server mit AD stehen und habe im netlogon ordner eine test.cmd erstellt.

Es steht einfach nur

----

@echo test

pause

----

drin.

 

Wenn ich bei den Profilen->Anmeldeskript den Dateinamen eingebe passiert nichts. Also das Script wird beim anmelden nicht gestartet. :(

Und wenn ich die Datei manuell von einem XP oder 2K rechner aus starte, kommt diese Fehlermeldung:

----

"\\Fileserver\NETLOGON"

CMD.EXE wurde mit dem oben angebenen Pfad als aktuellem Verzeichnis gestartet.

UNC-Pfade werden nicht unterstützt.

Stattdessen wird das Windows-Verzeichnis als aktuelles Verzeichnis gesetzt.

test

 

C:\WINDOWS>pause

Drücken Sie eine beliebige Taste . . .

----

Woran könnte es liegen, bzw. was habe ich falsch gemacht?? :confused:

An den Standardfreigaben habe ich nichts geändert!

 

Für Antworten wäre ich sehr dankbar!! Habe nämlich schon stdlang im Netz gesucht, und nix gefunden!

 

 

(Man beachte den Rechtschreibfehler von M$ ->angebenen :D )

Link to comment

Moin,

 

falls es dir was hilft hier mal ein script wie ich es in kleineren firmen benutz.

 

Gruss Manuel

 

 

Script:

 

@echo off

 

:nt

echo -------------------------------------------------------------

echo Willkommen %username% .

echo Sie haben sich an der Domain %userdomain% angemeldet .

echo Ihr Betriebssystem ist %os% .

echo Ihr Computer heisst %computername% .

echo Sie haben sich an %logonserver% angemeldet .

echo -------------------------------------------------------------

 

goto net

 

:net

net use x: \\fileserver\freigabename

 

 

:end

Link to comment

Hmm,

ich weiß jetzt wo mein Problem liegt:

und zwar habe ich beim Login immer lokal ausgewählt gehabt und nicht an der Domäne anmelden.

Jetzt habe ich zum testen am W2K Server einen Benutzer 'test' angelegt. Allerdings kommt jetzt beim Einlogversuch die Meldung das die Domäne nicht verfügbar ist!

Ich habe auf dem W2K Server AD installiert.

Auf meiner XP Maschine habe ich in unter Computername in den Systemeigenschaften die Domäne angegeben. Und das hat alles wunderbar funktioniert solange ich mich lokal anmelde!

 

Ich bin ein ziemlicher Neuling was W2K Server betrifft (wie man wohl sieht :) )

Vielen Dank für Antworten, bin irgendwie Ratlos

Link to comment
Original geschrieben von zer0flag

Hmm,

Ich bin ein ziemlicher Neuling was W2K Server betrifft (wie man wohl sieht :) )

Na ist ja nun wirklich nicht das Problem ! Ich hab noch keinen getroffen, der MS Windows mit der Muttermilch mitgekriegt hat.

 

Mein Problem ist da z.B., daß ich XP überhaupt nicht kenne.

Ich kann also mit "Auf meiner XP Maschine habe ich in unter Computername in den Systemeigenschaften die Domäne angegeben" nicht viel anfangen.

 

Erstmal zur Klärung: Hast Du XP Home oder XP Professional ?

XP Home kann nicht in eine Domäne, ist halt für zu Haus.

 

zuschauer

 

PS: Auch wenn ich Dir bei XP kaum weiterhelfen kann. Das ist hier ein Forum, da gibt´s auch genug Leute mit XP-Erfahrung. Also weiterfragen bzw. posten !

Link to comment

Hallo,

 

also das Problem mit dem XP habe ich aus der welt geschafft. Ich habe jetzt nen W2K Pro Rechner... ;)

 

Jetzt kann ich mich auch über 'test' an der Domäne anmelden!

Aber die ursprüngliche Fehlermeldung von meinem ersten Post mit der cmd.exe besteht immer noch!! :(

 

Der Rechner ist auch in der Domäne drin, also ich habe den in den Systemeigenschaften bei Netzwerkidentifikation in die Domäne aufgenommen!

Melde mich auch an ihr an, und nicht lokal!

 

Wenn ich jetzt in die Netzwerkumgebung auf

\\fileserver\netlogon\test.cmd

gehe, gibt er mir die Fehlermeldung aus!

 

:confused:

Link to comment
Original geschrieben von zer0flag

Hallo,

Und wenn ich die Datei manuell von einem XP oder 2K rechner aus starte, kommt diese Fehlermeldung:

----

"\\Fileserver\NETLOGON"

CMD.EXE wurde mit dem oben angebenen Pfad als aktuellem Verzeichnis gestartet.

UNC-Pfade werden nicht unterstützt.

Stattdessen wird das Windows-Verzeichnis als aktuelles Verzeichnis gesetzt.

test

 

Wenn Du das mit Fehlermeldung meinst, das ist ok so.

Diese Fehlermeldung kommt immer, wenn Du ein Batch-File aus einem UNC-Pfad (=\\SERVER\FREIGABENAME) startest.

 

Kommt denn nun beim Anmelden an der Domäne Dein Script ?

 

zuschauer

Link to comment

ja es funzt! Danke :D

 

Und ich mache mir da stundenlang gedanken über diese Meldung!! *kopfschüttel* Aber hinterher, weiß man immer mehr! :)

 

Leider finde ich nur keine ordentliche Referenz über Einlogskripte, finde ich schade...

 

Jetzt hätte ich nur noch die kleine Frage wie der Parameter lautet das das Fenster maximiert und nicht minimiert läuft!?!?!

Wenn Du das auch noch weißt, wäre das echt spitze!! :-))

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...