Jump to content
Sign in to follow this  
georges

Terminal Server / Zugriff auf Applikation sperren

Recommended Posts

Hallo Zusammen

 

Habe da ein Problem, dass noch nach einer "eleganten" Lösung sucht.

 

Gehen wir davon aus, dass auf einem Terminal Server diverse Applikationen installiert sind, auf die diverse User zugreifen. Diese User verfügen aber nicht über die gleichen Lizenzen.

 

Sämtliche Applikationen werden den Usern über Verknüpfungen, welche über Globale Gruppen freigeschaltet bzw. gesperrt sind, zur Verfügung gestellt. Dies funktioniert auch wunderbar :)

 

Wie verhindere ich jetzt aber, dass ein User der z. B. nicht über eine Visio 2000 Lizenz verfügt, aber eine solche Visio-Datei per Mail bekommt, diese nicht einfach doppelklickt und öffnet. Dies Funkioniert, da die Zuordnung der Extensions für den ganzen Server gilt und nicht userspezifisch ist. :cry:

 

Hat jemand sich schon mal mit dem Problem herumgeschlagen?

 

Danke für eure Tipps.

 

Gruss

Georges

Share this post


Link to post

Das kannst Du unterbinden, indem die EXE-Datei entsprechend verrechtet wird. Dazu die Berechtigungen der EXE-Datei neu setzten, so dass nur noch Admins, System und die Anwendungs-Gruppe Rechte auf die Datei haben.

Share this post


Link to post

Hi Klausk

 

Die Idee hab ich auch schon gehabt, finde sie aber nicht so cool, da ich die Applikationen auf insgesamt 15 Servern sprerren sollte und dies nach Möglichkeit nicht von Hand machen möchte. :(

 

Könnte natürlich jetzt hingehen und die modifizierten exe-Dateien per Batch verteilen. Jetzt aber sind die Domänen-Admins ja dummerweise Mitglied der Gruppe der lokalen Admins (Administrators [servername\Administrators]) und da geht das Dilema los. Jeder der 15 Server hat natürlich seinen eigenen Namen. Die lokalen Administratoren einfach rauskippen möchte ich nicht.

 

Was mich wunder nähme, gibt es keine Möglichkeit die Berechtigung für die einzlnen Appliaktionen per GPO zu steuern?

 

Jeden Fall, danke für Deine Idee.

 

Gruss

Georges

Share this post


Link to post

Hi Klausk

 

Vielen Dank für Deinen Tipp. Das setzten der Berechtigungen für die exe-Dateien unter Computer Configuration / Windows Settings / Security Settings / File System hat den gewünschten Erfolg gebracht. Das ist genau die "elegante" Lösung die ich gesucht habe. :) :)

 

Einfach die gewünschte exe eintragen, mit secedit.exe die Policy refreshen und wohlfühlen. :cool:

 

Gruss und Dank

Georges

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...