Jump to content
Sign in to follow this  
RobertCraven

Probleme mit der unattend Installation

Recommended Posts

Hallo Leute,

 

nun hah ich schon wieder ein Problem. Leider hab ich keinen Plan was Falsch sein soll. Hab auch schon das Board und das INet den ganzen Tag durchwühlt.

 

Sobald ich die Installation starte läuft diese auch an. Die Installationsroutine fängt an ein paar Dateien zu kopieren und hört dann mit folgender Fehlermeldung auf:

 

In der mit der Option /u angegeben Antwortdatei

i:\unattend.txt

liegt ein Sysntaxfehler in Zeile 0 vor.

 

Setup muss beendet werden.

 

:confused::confused::confused::confused::confused::confused:

 

Ich versteh das net. Die Unattend.txt hab ich mit dem SetupManager erstellt und mehrmals auch im Netz vergleichbare Aufbauten gefunden.

 

Hier ist meine Datei:

 

[Data]

AutoPartition = 0

MsDosInitiated = "1"

UnattendedInstall = "Yes"

 

[unattended]

UnattendMode = FullUnattended

OemSkipEula = Yes

OemPreinstall = Yes

ExtendOemPartition = 1

FileSystem = ConvertNTFS

TargetPath = \WINDOWS

 

[GuiUnattended]

AdminPassword=blablablabla

EncryptedAdminPassword=Yes

AutoLogon=Yes

AutoLogonCount=1

OEMSkipRegional=1

TimeZone=110

OemSkipWelcome=1

 

[userData]

ProductKey=xxxx-xxxx-xxxx-xxxx-xxxx

FullName="FIRMA"

OrgName="FIRMA"

ComputerName=W0001

 

[Display]

BitsPerPel=32

Xresolution=1024

YResolution=768

 

[RegionalSettings]

LanguageGroup=1

Language=00000407

 

[setupMgr]

DistFolder=D:\XP-Prof

DistShare=install

 

[branding]

BrandIEUsingUnattended=Yes

 

[Proxy]

Proxy_Enable=0

Use_Same_Proxy=1

 

[identification]

JoinDomain=FIRMA.DE

DomainAdmin=administrator

DomainAdminPassword=kennwort

 

[Networking]

InstallDefaultComponents=Yes

 

Die Installation wir über eine DOS Netzbootdiskette mit winnt.exe aufgerufen. Der genaue Aufruf lautet:

i:\i386\winnt.exe /s:\\SERVER\install\i386 /t:c: /u:i:\unattend.txt

 

Der Rechner selbst besitzt eine 2 GB C Partition mit FAT16.

 

 

Soviel Ärger wie mit der Unattend von XP hatte ich damals bei NT nicht!!! :cry:

Share this post


Link to post

Hab ich auch schon probiert, nur leider hat es damit nicht funktioniert.

Meines wissens benötigt man die winnt.sif aber nur für eine unattend über eine CD. Ich versuche eine über das Netzwerk aufzubauen.

 

Grüße

Share this post


Link to post

Mach mal folgenden Versuch: Kopiere nur die winnt.exe aus dem I386 heraus direkt in das Install-Verzeichnis, so dass der Aufruf dann so gestartet werden kann:

 

i:\winnt.exe /s:\\SERVER\install\i386 /t:c: /u:i:\unattend.txt

 

grizzly999

Share this post


Link to post

Hi Grizzly,

 

danke für den Tip, aber leider war dies auch nicht von Nutzen.

Ich hab jetzt spasseshalber mal in der unattended.txt alles heraus gelöscht bis auf den Punkt [Data]. Also nur zum Verständinis, in dieser steht nun an erster Stelle [Data] und sonst nix. Diese ist nun komplett leer.

Und dieses Mistding bleibt mit der selben Fehlermeldung stehen:

 

In der mit der Option /u angegeben Antwortdatei

i:\unattend.txt

liegt ein Syntaxfehler in der Zeile 0 vor.

 

HALLO GEHTS NOCH, was ist bitte schön eine Zeile "0"???? :shock:

Sobald ich etwas an dem Aufbau [Data] , oder sonstige Abschnitte geändert habe, hat er mir direkt die richtige Zeilennummer als Fehlerquelle ausgespuckt.

Selbst wenn ich die Datei eigenhändig zusammenbaue (ohne Setupmanager oder Kopieren) immer wieder die selbe Fehlermeldung.

 

Das einizige was mir noch zu meiner XP CD einfällt ist, das es eine Select CD ist. Daran kann es doch aber nicht liegen? :confused:

Share this post


Link to post

Störe dich nicht an dieser Meldung die Zeile 0 betreffend.

Es liegt anscheindend ein Syntaxfehler in einer der Zeilen vor. Am ehesten tippe ich wirklich auf ein Problem mit Hochkommas irgendwo in der Antwortdatei (fehlend oder falsch gesetzt), so wie im Artikel beschrieben.

Ich hatte diese Fehlermeldung noch nicht, dafür aber Werte, die aufgrund solcher "Fehler" bei XP/2003 einfach nicht genommen wurden.

Du solltest unbedingt die Werte für die Schlüssel mit Hilfe der Beschreibungen in der Hilfedatei deploy.chm für die Unattended von XP (nicht von 2000!) überprüfen. Da steht drin, wie die auszusehen haben, ob Hochkomma erforderlich, oder wie sonst der Wert eingetragen werden muss. Es gibt hier Unterschiede zwischen Einträgen in der Antwortdatei für 2000 und XP ;)

 

 

grizzly999

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...