Jump to content

Migration 2k3 auf 2011 fehlgeschlagen


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

na toll! Meine erste Migration auf SBS2011 und die geht natürlich schief :mad:

 

Alles lief super durch. Nur leider wird mir nun die Hilfe bei Fehlschlag der Inst. angezeigt.

 

Der hatte sich autom. mit dem Domänen-Administrator angemeldet, den ich Ihm in der Antwortdatei mitgegeben habe. Leider habe ich Schussel keinen neuen Migrations-Admin angelegt. Kann es vielleicht daran liegen?

 

In dem Error-Log steht nämlich folgendes:

 

Setup encountered an error: System.Reflection.TargetInvocationException: Ein Aufrufziel hat einen Ausnahmefehler verursacht. ---> System.Reflection.TargetInvocationException: The TME thread failed (see the inner exception). ---> System.Runtime.InteropServices.COMException: Der Serverprozess konnte nicht gestartet werden, da die konfigurierte Identität falsch ist. Überprüfen Sie Benutzernamen und Kennwort. (Ausnahme von HRESULT: 0x8000401A)
  bei System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
  bei System.EnterpriseServices.Thunk.Proxy.CoCreateObject(Type serverType, Boolean bQuerySCInfo, Boolean& bIsAnotherProcess, String& uri)
  bei System.EnterpriseServices.ServicedComponentProxyAttribute.CreateInstance(Type serverType)
...
...

 

Oder liegt es doch an etwas Anderem? Hat Jemand von Euch ein Tipp?

 

Na ja. Jedenfalls habe ich das mit dem Migrations-Admin jetzt nachgeholt. Kann ich das Setup von hier aus nun nochmals versuchen (in der Hilfe steht was von komplett von vorne anfangen :suspect: )?

Edited by iDiddi
Link to comment

Hier der restliche Error-Log:

 

   bei System.Runtime.Remoting.Activation.ActivationServices.IsCurrentContextOK(RuntimeType serverType, Object[] props, Boolean bNewObj)
  bei Microsoft.WindowsServerSolutions.IWorker.Tasks.ConfigureWSSOutgoingEmailTask.Run(ITaskDataLink dataLink)
  bei Microsoft.WindowsServerSolutions.TaskManagement.Data.Task.Run(ITaskDataLink dataLink)
  bei Microsoft.WindowsServerSolutions.TaskManagement.TaskScheduler.RunTasks(String taskListId, String stateFileName)
  bei Microsoft.WindowsServerSolutions.Setup.SBSSetup.ProgressPagePresenter._RunTasks(Object sender, DoWorkEventArgs e)
  bei System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
  --- Ende der internen Ausnahmestapelüberwachung ---
  bei Microsoft.WindowsServerSolutions.Setup.SBSSetup.ProgressPagePresenter.TasksCompleted(Object sender, RunWorkerCompletedEventArgs e)
  --- Ende der internen Ausnahmestapelüberwachung ---
  bei System.RuntimeMethodHandle._InvokeMethodFast(IRuntimeMethodInfo method, Object target, Object[] arguments, SignatureStruct& sig, MethodAttributes methodAttributes, RuntimeType typeOwner)
  bei System.Reflection.RuntimeMethodInfo.Invoke(Object obj, BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean skipVisibilityChecks)
  bei System.Delegate.DynamicInvokeImpl(Object[] args)
  bei System.Windows.Forms.Control.InvokeMarshaledCallbackDo(ThreadMethodEntry tme)
  bei System.Windows.Forms.Control.InvokeMarshaledCallbackHelper(Object obj)
  bei System.Threading.ExecutionContext.runTryCode(Object userData)
  bei System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
  bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean ignoreSyncCtx)
  bei System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
  bei System.Windows.Forms.Control.InvokeMarshaledCallback(ThreadMethodEntry tme)
  bei System.Windows.Forms.Control.InvokeMarshaledCallbacks()
  bei System.Windows.Forms.Control.WndProc(Message& m)
  bei System.Windows.Forms.NativeWindow.DebuggableCallback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
  bei System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
  bei System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
  bei System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
  bei System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
  bei Microsoft.WindowsServerSolutions.Common.Wizards.Framework.WizardChainEngine.Launch()
  bei Microsoft.WindowsServerSolutions.Setup.SBSSetup.MainClass._LaunchWizard()
  bei Microsoft.WindowsServerSolutions.Setup.SBSSetup.MainClass.RealMain(String[] args)
  bei Microsoft.WindowsServerSolutions.Setup.SBSSetup.MainClass.Main(String[] args)

 

Habe mich sonst aber strikt an den Migrationsleitfaden gehalten.

Link to comment

Also viel findet man ja nicht darüber im Internet :(

 

Habe aber "The Ultimate Guide to SBS Setup Failures" gefunden. Ist zwar für SBS2008, wird aber bei SBS2011 nicht viel anders sein, oder? Werde ich jetzt mal durchkauen, ob da was auf mein Problem zutrifft.

 

Ich habe allerdings die Befürchtung, dass ich, falls ich von vorne anfangen muss, den alten SBS2003 auch zurück sichern muss. Ist das korrekt?

Link to comment

Ich vermute mal, dass Sharepoint die Probleme verursacht hat. Habe diese Fehler im Ereignisprotokoll gefunden:

 

Protokollname: System

Quelle: Microsoft-Windows-DistributedCOM

Datum: 21.06.2011 16:23:42

Ereignis-ID: 10016

Aufgabenkategorie:Keine

Ebene: Fehler

Schlüsselwörter:Klassisch

Benutzer: DOMAIN\spsearch

Computer: SERVER2.DOMAIN.local

Beschreibung:

Durch die Berechtigungseinstellungen (Computerstandard) wird der SID (S-1-5-21-2858078704-1006810407-4263141692-3661) für Benutzer DOMAIN\spsearch von Adresse LocalHost (unter Verwendung von LRPC) keine Berechtigung zum Aktivierung (Lokal) für die COM-Serveranwendung mit CLSID

{B15C0E47-C391-45B9-95C8-EB596C853F3A}

und APPID

{35B4B29E-0A6B-4ED7-B0A1-117BF912F497}

gewährt. Die Sicherheitsberechtigung kann mit dem Verwaltungsprogramm für Komponentendienste geändert werden.

 

und

 

Protokollname: System

Quelle: Service Control Manager

Datum: 21.06.2011 16:25:32

Ereignis-ID: 7041

Aufgabenkategorie:Keine

Ebene: Fehler

Schlüsselwörter:Klassisch

Benutzer: Nicht zutreffend

Computer: SERVER2.DOMAIN.local

Beschreibung:

Der Dienst "SPTimerV4" konnte aufgrund des folgenden Fehlers nicht unter DOMAIN\spfarm mit dem aktuell konfigurierten Kennwort angemeldet werden:

Anmeldungsfehler: Dem Benutzer wurde der angeforderte Anmeldungstyp auf diesem Computer nicht zugeteilt.

 

Dienst: SPTimerV4

Domäne und Konto: DOMAIN\spfarm

 

Das Dienstkonto verfügt nicht über das erforderliche Benutzerrecht "Anmeldung als Dienst".

 

Benutzeraktion

 

Teilen Sie dem Dienstkonto "Anmeldung als Dienst" auf diesem Computer zu. Sie können dazu die lokalen Sicherheitseinstellungen (Secpol.msc) verwenden. Stellen Sie sicher, dass dieses Benutzerrecht dem Clusterdienst, auf allen Knoten des Clusters zugewiesen ist, wenn dieser Computer ein Knoten im Cluster ist.

 

Wenn Sie bereits dieses Benutzerrecht dem Dienstkonto zugeteilt haben und es so aussieht, als ob das Benutzerrecht entfernt wurde, dann wenden Sie sich an den Domänenadministrator, um herauszufinden, ob dieses eventuell durch ein Gruppenrichtlinienobjekt, das dem Knoten zugewiesen ist, entfernt wurde.

 

Das passt ja auch zu der Meldung im SBSSetup.log. Aber warum bricht deshalb denn direkt die komplette Installation ab :(

 

Wie kann ich die Installation denn retten, ohne (wg. eines klitzekleinen Fehlers) alles neu machen zu müssen?

Link to comment

So. Kleine Rückmeldung.

 

Musst alles von vorne anfangen, grrr. Also Verzeichnisdienst (Systemstatus) auf dem Quellserver wiederhergestellt. Alle Updates und migrationsvorbereitende Maßnahmen erneut durchgenudelt + Migrations-Benutzer (!) angelegt. Antwortdatei dementsprechend abgeändert und den Zielserver erneut installiert, puuuhhh (kommt davon, dass man nach den Vorbereitungen keine DaSi mehr macht).

 

Na ja, jedenfalls hat es nu geklappt.

 

Aber mal ehrlich: Das ist jetzt noch nicht so ganz ausgereift mit dem SBS2011, meint Ihr nicht?

 

Denn in der Migrationsanleitung steht zwar drin, dass man einen neuen Benutzer anlegen soll, aber auch nur, bevor man den Migrationsassistenten startet. Theoretisch also auch über den neuen Server.

 

Außerdem ist mir aufgefallen, dass der Robocopy-Befehl für das Kopieren der Freigaben vom Quell- zum Zielserver nicht korrekt ist. Dann fehlt da noch die Gruppenrichtlinie SBS Ordnerumleitung bei der Liste der zu löschenden Objekte und und und...

 

Wat soll's. Hab's ja jetzt zum Laufen bekommen. Danke Euch trotzdem :)

Link to comment
  • 3 weeks later...
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...