Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
Superstruppi

VMs verlieren sporadisch Netzwerkverbindung

Empfohlene Beiträge

Hallo ihr zwei

 

Was für NIC Hardware / Treiber sind im Einsatz? Auf die neuste Version und NCU aktualisieren. Ev. auch mal TCP Offloading deaktivieren...

 

Btw. Wieso bekommt jede VM eine NIC zugewiesen? Wieso nicht Teaming und den VMs einen gemeinsamen Virtuellen Switch zuweisen?

 

Grüsse

Michel

 

P.S.

NCU habe ich zwar installiert, weiß aber nicht, wie man das unter Core aufruft...
Schau dir den Link in Post 13 an, dort steht alles...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Hallo ihr zwei

 

Was für NIC Hardware / Treiber sind im Einsatz? Auf die neuste Version und NCU aktualisieren. Ev. auch mal TCP Offloading deaktivieren...

 

Btw. Wieso bekommt jede VM eine NIC zugewiesen? Wieso nicht Teaming und den VMs einen gemeinsamen Virtuellen Switch zuweisen?

 

Grüsse

Michel

 

P.S. Schau dir den Link in Post 13 an, dort steht alles...

 

Wie startet man NCU in einer Coreumgebung? - Edit: das schau ich gleich mal. Post 13...

Leider sind wir noch nicht in Richtung Teaming gekommen, da die Basics noch nicht passen. Die dezidierte Zueweisung ist ja das Mindestmaß, das funktionieren soll...

Ich glaube, das beste wird sein, einen Standard-Server mit GUI zu installieren u. auf diesem die Hyper-V Rolle zu installieren... Dann lässt sich auch Netzwerktechnisch alles gut konfigurieren.

 

Besten Dank u. lG,

Mario.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ich hab meine server auf dem "normalen" 2008R2 laufen. was mich eben wirklich stutzig daran macht, ist, dass es auf 3 380ern funktioniert und genau auf einem nicht. es sind 4 identische installationen für 4 verschiedene standorte. die trennung der NIC's ist erforderlich, da wir über eine NIC eine replikation der "application-VM" laufen lassen, eine ist fürs management, und 2 sind je für die VM's (verschiedene netze, VLANs). hyper-v mac-adressen sind von dynamisch auf manuell gestellt, da ich hiermit schon probleme hatte. ich werd mal versuchen, das offloading abschalten zu lassen...

 

vg,

michael

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Na na - nicht gleich aufgeben ;)

 

Sobald du die NCU gestartet hast, kannst du dort auch alles konfigurieren. Schau dir mal die Updates von HP und das mit dem Offloading an...

 

Grüsse

 

ich checke immer noch nicht, wie ich NCU als GUI starten kann. geht wohl nur über commandline.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ich hab grad mit meinem HP-partner des vertrauens gesprochen...hier mal ein link aus der MS KB:

 

The network connection of a running Hyper-V virtual machine is lost under heavy outgoing network traffic on a Windows Server 2008 R2-based computer

 

und ein interessanter dialog im technet:

 

Hyper-V Network connection dies randomly

 

ich hoffe, dass ich bis ende der woche feedback geben kann.

 

grüsse,

michael

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Den Microsoft Patch hatte ich schon vor Wochen eingespielt. Aber ich bin sehr gespannt, wie es dir weiterhin geht. Ich habe inzwischen auf virtuelle Legacy-NICs (100MBit) umgestellt, was das Problem löst, aber für mich nur eine Zwischenlösung ist.

 

Bitte um Info, sobald es was Neues gibt!

Besten Dank u. lG,

Mario.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

hallo mario,

ich hab immer mehr den verdacht, dass es sich doch um einen fehler auf den DL380G6 bezieht...hab mein komplettes szenario auf 4 ML350G5 (je 1 VM AD 2008R2, 1 VM mein messaging system, 2003R2) nachgestellt und es läuft seit 3 tagen flüssig. nicht ein netzwerkaussetzer, mein AD repliziert sich ohne probleme, usw...mein nächster versuch ist jetzt eine 4-port karte in den 380er zu stecken und damit weiterzutesten.

 

grüsse,

michael

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ach ihr habt eine karte reingebaut? ich hab meine bis jetzt mit den 4 internen laufen lassen. daher mein ansatz mit der NIC. ich hab weder teaming noch sonst was. hab alle patches und die tcp offload geschichte machen lassen - kein effekt.

 

das hab ich noch nicht probiert:

Hyper-V Hotfix Rollup now Available - Virtual PC Guy's WebLog - Site Home - MSDN Blogs

ist auch anscheinend gestern erst rausgekommen.

 

bin in KW38 wieder vor ort und werde danach berichten.

 

grüsse,

michael

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi,

 

wir haben sowohl als auch. Bei manchen Kunden sind nur die internen in Verwendung, bei einem anderen Kunden eben alle u. die VMs bekommen die NICs der zugesteckten Karte.

 

Den Patch schau ich mir gleich mal an - besten Dank!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Da ich den Link für meine Lösung hier bei Euch gefunden habe, möchte ich Euch zumindest an meinem Erfolg teilhaben lassen....

 

Folgende Informationen habe ich befolgt und nun funktioniert die Netzwerkverbindung aller virtuellen Maschinen perfekt:

 

Here's what I did to fix it, live migrated the guests off so I could muck around with a host, deleted the virtual switch, deleted the team that the switch was using, updated the network drivers to the latest package, and on all of the network adapters that belonged to the team (my adapter is a quad port so I did this for all 4 ports) went into the Advanced tab on each and disabled 'Large Send Offload (IPv4)', 'Large Send Offload (IPv6)' and went into TCP Offloading Options on the same tab and disabled 'TCP Checksum Offload (IPv4)', 'TCP Checksum Offload (IPv6)', 'UDP Checksum Offload (IPv4)', 'UDP Checksum Offload (IPv4)'. Rebooted after that and recreated the team, recreated the virtual switch. I then live migrated the guests to that host and did the same to the other host. I also disabled spanning-tree on the switches for the ports in the VM team, but I don't think I had a problem there.

 

Wobei ich ausschließlich die genannten Einstellungen der Netzwerkkarte vorgenommen habe:

Large Send Offload (IPv4) => Diabled

Large Send Offload (IPv6) => Diabled

 

... sonst nix, nur OK gedrückt... und schon hat's funktioniert!

 

 

Link zum rettenden Beitrag

 

Vielen Dank dafür...

 

Gruß,

Marc

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×