Jump to content
Sign in to follow this  
Hans Jürgen

Windows Update Fehler 0x800A138F "Falscher Parameter" 0x80070057

Recommended Posts

Hallo zusammen,

 

wir haben seit ca. Mai 2003 ein dickes Problem mit Windows Update (W2KSP4-Server mit 8 W2KSP4-Clients und ein Standalone W2KSP4-PC):

 

Mit Ausnahme von 4 der Clients, wo es merkwürdigerweise funktioniert, findet Windows Update die installierbaren Dateien und Patches, aber beim Klick auf Installieren kommt folgende Meldung (auch beim Server):

----------------------------------------------------------------

Windows Update-Fehler:

 

Es ist ein Fehler aufgetreten. Windows Update kann die gewünschte Seite nicht anzeigen.

 

Wählen Sie eine der folgenden Seiten, um Informationen über Windows Update-Dienste zu erhalten, oder senden Sie uns Ihr Feedback.

 

Windows Update-Homepage

Info

Supportinformationen

 

Nutzen Sie den Onlinesupport, falls bei Windows Update Fehler auftreten sollten.

 

Fehlernummer an Microsoft senden (0x800A138F)

Hinweis Hiermit werden Fehlerinformationen gesendet, aber es wird kein Supportereignis erstellt. Möglicherweise werden Sie keine Antwort erhalten.

----------------------------------------------------------------

In der c:\winnt\Windows Update.log findet sich bei uns folgende Fehlermeldung:

 

2003-08-20 21:49:00 19:49:00 Success IUENGINE Querying software update catalog from https://a248.e.akamai.net/v4.window...getmanifest.asp'>https://a248.e.akamai.net/v4.window...getmanifest.asp

2003-08-20 21:49:09 19:49:09 Success IUENGINE Querying software update catalog from https://a248.e.akamai.net/v4.window...getmanifest.asp

2003-08-20 21:49:11 19:49:11 Error IUENGINE Determining machine configuration (Error 0x80070057: Falscher Parameter.)

2003-08-20 21:57:19 19:57:19 Success IUENGINE Shutting down

2003-08-20 21:57:22 19:57:22 Success IUCTL Shutting down

-----------------------------------------------------------------

 

Einer der nicht funktionierenden Rechner ging wieder, nachdem ich W2kSP4 neu installiert hatte. 2 Wochen später war auch da wieder Schluß.

 

Die von MS angegeben möglichen Fehlerursachen treffen nicht zu.

 

In der Knowledge-Base ist nichts zu finden, bzw. das, was da steht, hat nicht geholfen.

 

Falls es mit Zertifikaten zu tun hätte, sollten ja eigentlich alle Rechner gleichzeitig ausfallen bzw. eine Neuinstallation nichts nutzen.

 

Das haben wir auch schon versucht:

----------------------------------------------------------------

Ggf. Datum + Uhrzeit korrekt einstellen

Ggf. Popup-Stopper deaktivieren

Ggf. in 'hosts' a248.e.akamai.net entfernen!

(ist in \WINNT\system32\drivers\etc)

 

Im Internet Explorer: Extras-Internetoptionen

in Sicherheit ggf. Standardstufe aktivieren

in Erweitert kontrollieren ob SSL 2 + 3 aktiv

 

Start-Ausführen: regsvr32 iuctl.dll /u

----------------------------------------------------------------

Haben zwischenzeitlich auch alle Patches "von Hand" geladen incl. Stammzertifikatupdate, nichts genützt.

 

Super ist der folgende Link

http://www.updatexp.com/0x800A138F.html mit 13 Schritten zur Beseitigung des Problems, hat auch nichts geholfen. Unser "falscher Parameter"-Fehler ist dort noch nicht aufgetaucht.

 

Hier http://www.freelists.org/archives/triadtechtalk/09-2003/msg00006.html findet sich zwar unser Fehler, aber da wir weder NETOP noch LYNX haben, hilft es auch nichts. Es könnte demnach vielleicht ein falsch geschriebenes Datum in der Registry sein, aber wie finden?

 

Wer hat noch eine Idee???

 

Schönes Wochenende wünscht

Hans Jürgen

Share this post


Link to post

Ich mag es nicht, als Admin zu surfen und mir Software auf meinen Rechner installieren zu lassen - gut, das ist eine Geschmacksfrage. Deshalb löse ich das Problem der Patches mit dem hfnetchk (bei Microsoft danach suchen), der checkt meinen Rechner auf evtl. fehlende Patches, diese installiere ich per Hand.

 

[Edit] Windows-Update funktioniert bei mir übrigens auch nicht, da müßte ich irgendwelche zusätzlichen Richtlinien bearbeiten. Aber da meine andere Lösung vollständig funktioniert, stört mich dies nicht allzusehr.

 

-------------

Gruß, Auer

Share this post


Link to post

Das Problem ist gelöst, es handelt sich um ein falsches DriverDate in den OKI-Druckertreibern für unsere C5300 und 4200 Drucker!

 

Beseitigt habe ich den Fehler in der Registry, in dem ich bei den Treibern (suche: PS5UI.DLL) jeweils das DriverDate auf 00 00 00 00 00 00 00 00 gesetzt habe.

 

Nach Neustart des Rechners funktioniert jetzt Windows Update wieder einwandfrei.

 

Es ist mir unverständlich, warum in der Windows Update.log Fehlermeldung nur "falscher Parameter" anstatt "falscher Parameter im Druckertreiber xxx OKI" steht und man 5 Monate überall nachfragen muß, um das Problem dann endlich zu lösen. Bei Microsoft ist der Fehler grundsätzlich bekannt als falsches Datum in den Treibern von NETOP und LYNX. Wenn man das aber schon kennt, warum wird dann die Fehlermeldung von Windows Update nicht so gestaltet, dass man auch was damit anfangen kann???

 

Trotzdem vielen Dank für den Tip mit hfnetchk, werde ich vermutlich auch demnächst stattdessen nutzen!

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...